WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: FYI for compiling compatible drivers for kernel 3.8+  (Read 4567 times)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
FYI for compiling compatible drivers for kernel 3.8+
« on: August 20, 2013, 10:04:18 PM »
I have come across many issues compiling drivers for kernel 3.8.10 builds.

The first issue "error: implicit declaration of function ā€˜__devexit_pā€™ [-Werror=implicit-function-declaration]"
is fixed by removal of all references to __devinit,  __devexit and __devexit_p which are no longer supported in kernel 3.8.x

Along with references to __devexit_p are the parenthesis around the value passed to __devexit_p which need to be removed.
eg: on line with      = __devexit_p (driver remove),
edit to:   =driver remove,

Then the driver will compile (assuming no further issue to be addressed occur).


just an FYI, hope this helps build drivers for 3.8+   unless anyone has a better method?

 
« Last Edit: August 20, 2013, 10:08:19 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: FYI for compiling compatible drivers for kernel 3.8+
« Reply #1 on: September 01, 2013, 03:03:17 PM »
Next issue I've had references these two functions "kmap_atomic" and "kunmap_atomic"  which apparently no longer accepts two arguments in kernel-3.6 + onward

for example
kmap_atomic(sg->page, KM_IRQ0)
kunmap_atomic(buf, KM_IRQ0)

edited to
kmap_atomic(sg->page)
kunmap_atomic(buf)



compiles and runs without error.   best to allow the driver development team update and test, this works as a temporary measure at least.

« Last Edit: September 01, 2013, 04:40:22 PM by coreplayer2 »