WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: v4l (s2-liplianin) - compile problem  (Read 1986 times)

Offline gfi

  • WikiUser
  • *
  • Posts: 1
v4l (s2-liplianin) - compile problem
« on: September 21, 2011, 01:56:16 PM »
Hello,

Have anybody experience with compilation of s2-liplianin (video4linux extension)?
I need only full dvb support from this package, if anyone have compiled that package, let me know.
I'm playing with that over week. On other linux distribution without problem.

I tried compile it with linux-headers, but also with full unpacked kernel (last, linux-2.6.33.3-patched)

ERRORS (still same):
I've created .config with option make xconfing (under qt4).

When I try 'make', then shows still some errors:

After start first:
1.
make -C /home/tc/s2-liplianin/v4l/bin/sh: /sbin/lsmod: not found
- when trying make_makefile.pl
2.
make -C /home/tc/s2-liplianin/v4l/bin/sh: /sbin/lsmod: not found
- when trying make_myconfig.pl

----------------------------------------------
Then continue with make_config_compat.pl

And still same errors:
creating symbolic links...
ln: unregonized option '--target-directory=.'

Forgot I something or missing me some tcz packeges?

That seems, problem is with Perl (I've Perl5 installed).

Many thanks for any answer. I'm newbie in TC, I think best distribution, but also I haven;t experience with Perl, Python.
As I wrote, on other distributions withou problem (also with older kernel).


Solved (ln: unregonized option...).
Sorry for thread, I looked at my repository, compare it with onboot, and I forgot installing 'coreutils.tcz' - OnBoot. I had them only in Download mode...
« Last Edit: September 21, 2011, 02:45:05 PM by gfi »