WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Videos are not displayed using Firefox5  (Read 1048 times)

Offline xyz-worx

  • Jr. Member
  • **
  • Posts: 66
Videos are not displayed using Firefox5
« on: August 24, 2011, 03:19:42 AM »
Hi all,

I tried to view the videos in the screenshot section. Unfortunately the only thing I can see
is a gray box showing a 'X' inside. Currently I use Firefox5 for browsing.

As far as I could see, the videos are in 'ogg' format. After a little 'googling' I found at Mozilla,
that Fireforx (or the Gecko-machine) needs the MIME-types
audio/ogg, video/ogg or application/ogg
to display videos directly.

Using the 'LiveHTTP Headers' add-on I found out, that the videos are delivered as
application/octet-stream.

On the Mozilla site there is a hint how to adjust the MIME-configuration for Apache servers.
LiveHTTP shows, that you are using 'lighttpd'. I suppose, that there will be a possibilty to
adjust MIME-types, too.

xyz-worx



Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10424
Re: Videos are not displayed using Firefox5
« Reply #1 on: August 24, 2011, 06:29:17 AM »
We are aware of the issue, and we have no control over the mime types.

Workarounds are trying one of the mirrors, downloading the videos and playing in your favorite player, or using Opera (not sure if Chromium needs the mime types or not). The Java fallback works too, but it's only active on non-html5 browsers.

I believe someone posted our videos on youtube, as well.
The only barriers that can stop you are the ones you create yourself.

Offline xyz-worx

  • Jr. Member
  • **
  • Posts: 66
Re: Videos are not displayed using Firefox5
« Reply #2 on: September 12, 2011, 04:09:48 AM »
Hi Curaga,

in late August I wrote a mail to ibiblio.org regarding my concern - and it worked:

The ogg-type videos now have the correct MIME-type and can be displayed in Firefox 5 and 6 directly.

xyz-worx