WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Could not start X-Server after installing Xorg-7.5  (Read 3363 times)

Offline Sheleh

  • WikiUser
  • *
  • Posts: 33
Could not start X-Server after installing Xorg-7.5
« on: August 21, 2011, 09:59:06 PM »
After trying to get wide screen mode resolution and install Xorg-7.5-3d System only boots into command line mode. After $ startx command, nothing happens.

How to remove Xorg-7.5?


P.S. System installed in the Scatter Mode (Traditional).
« Last Edit: August 21, 2011, 11:19:12 PM by Sheleh »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5930
Re: Could not start X-Server after installing Xorg-7.5
« Reply #1 on: August 21, 2011, 10:05:39 PM »
Hi Sheleh
Open /tce/onboot.lst and remove the xorg entry. Reboot and un-install xorg using AppsAudit.

Offline Sheleh

  • WikiUser
  • *
  • Posts: 33
Re: Could not start X-Server after installing Xorg-7.5
« Reply #2 on: August 21, 2011, 10:25:24 PM »
Hi Rich!
/tce/onboot.lst - file not found
/tce - directory not found

But if I'll find onboot.lst which non-GUI application I can edit it?

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10106
Re: Could not start X-Server after installing Xorg-7.5
« Reply #3 on: August 21, 2011, 10:35:23 PM »
But if I'll find onboot.lst which non-GUI application I can edit it?

Vi - "vi /path/tce/onboot.lst"

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5930
Re: Could not start X-Server after installing Xorg-7.5
« Reply #4 on: August 21, 2011, 10:43:48 PM »
Hi Sheleh
Type  sudo find /mnt -iname onboot.lst  to find onboot.lst.
The vi editor is not very user friendly, make a back up copy of onboot.lst before you edit it.
cp onboot.lst onbootbak.lst

Offline Sheleh

  • WikiUser
  • *
  • Posts: 33
Re: Could not start X-Server after installing Xorg-7.5
« Reply #5 on: August 21, 2011, 11:12:12 PM »
Code: (bash) [Select]
sudo find / -iname *.lstSo I found 18 different lst-files, but not onboot.lst

Sorry, I forgot to say that the system was installed in the scatter mode
« Last Edit: August 21, 2011, 11:18:13 PM by Sheleh »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5930
Re: Could not start X-Server after installing Xorg-7.5
« Reply #6 on: August 21, 2011, 11:27:50 PM »
Hi Sheleh
I've never dealt with scatter mode. Maybe you don't have onboot.lst and tce directory?
NO guarantees, but try  sudo find / -iname xorg*  and delete xorg manually. As i said, NO guarantees.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6980
    • My Community Forum
Re: Could not start X-Server after installing Xorg-7.5
« Reply #7 on: August 21, 2011, 11:35:48 PM »
Open AppBrowser and click local. Path to tce/optional will be displayed, so you will see where is tce dir used by the system.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9862
Re: Could not start X-Server after installing Xorg-7.5
« Reply #8 on: August 21, 2011, 11:39:11 PM »
That's it with scatter mode, you don't get to remove extensions easily. It's manually searching down files.
The only barriers that can stop you are the ones you create yourself.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5930
Re: Could not start X-Server after installing Xorg-7.5
« Reply #9 on: August 22, 2011, 09:39:57 AM »
Hi bmarkus
Quote
Open AppBrowser and click local. Path to tce/optional will be displayed, so you will see where is tce dir used by the system.
He can't get into a GUI environment because  startx  fails.