WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: webcam/microphone not work with Flash  (Read 5693 times)

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
webcam/microphone not work with Flash
« on: August 06, 2011, 05:20:52 PM »
Hi,

flash plug-in (version 10.3.181.34 or the beta 11.0.1.60), in either opera1# or firefox5, does not understand neither my web-cam or my microphone;
both my webcam and microphone are working well in skype-oss,
also both flash plug-in works well in opera and firefox;

so it is a flash configuration problem (library or configuration missing? improper file access rights?)
but flash is just a library, i changed nothing from default flash10.tcz

simptom: when i play a flash (for example in youtube), if I right click on movie then a menu shows up, here I select "Setings...", then a dialog shows but frozen; I can not access the icons from this dialog (folder, micropone, webcam, close buton). but the movie plays further without my control;

http://swifthumors.blogspot.com/2008/03/linux-flash-webcam-headache.html
does not helped much, but maybe helps others more skilled;

also, i can change settings online from
http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager06.html
but it seems to have no effect for flash,
neither a proper administrator file as /etc/adobe/mms.cfg as found on gento linux site;

i need video and oss sound in messengers like meebo, or google talk etc
does anybody know what is missing? thanks in advance

« Last Edit: August 07, 2011, 02:05:05 PM by nick65go »

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
Re: webcam/microphone not work with Flash
« Reply #1 on: August 07, 2011, 02:08:46 PM »
testing on www.testwebcam.com I discovered that in the right click dialog "Adobe Flash Player Settings" can be switched between options icons and settings with the TAB key (options will be with yellow border), but i can not modify anything;

also "LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so firefox &" does not help it;
http://lab.marand.com/2010/04/making-webcam-work-in-flash-on-ubuntu/

I have no more ideas for now;

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10012
Re: webcam/microphone not work with Flash
« Reply #2 on: August 08, 2011, 01:13:34 AM »
Are you sure that's the correct path? libv4l.tcz is in /usr/local
The only barriers that can stop you are the ones you create yourself.

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
Re: webcam/microphone not work with Flash
« Reply #3 on: August 08, 2011, 06:11:28 AM »
sorry, my typo mistake, it is /usr/local/lib/libv4l/ and I tried with v4l2convert.so  and v4l1convert.so also without succes.
hunting blindly...

About sound: on adobe site, they say before downloading that flash knows only ALSA. hmm.. flash works with OSS because the old (not updated) libflashsupport.so; but libflashsupport could eventualy control the sound only (the video subroutines are not called). So i think ALSA emulation (from OSS) is need for microphone, as i read on oss forum.

Does anybody have a working webcam in flash (web browser)?
then we could narrow the problem to: driver, library, configuration.

I do not like close source, this is why i swithced from windows to linux. But for video communication linux is not in good shape , yet. If you have suggestions about linux video alternatives to skype, meebo, yahoo IM, please tell me.

thanks.
« Last Edit: August 08, 2011, 06:29:03 AM by nick65go »

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
Re: webcam/microphone not work with Flash
« Reply #4 on: August 08, 2011, 01:25:48 PM »
info about my setup

from dmesg:
Linux video capture interface: v2.00
gspca: main v2.8.0 registered
gspca: probing 093a:2468
pac207: Pixart Sensor ID 0x27 Chips ID 0x08
pac207: Pixart PAC207BCA Image Processor and Control Chip detected (vid/pid 0x093A:0x2468)

from lsmod:
Module                  Size  Used by    Not tainted
gspca_pac207            3520  0
gspca_main             14148  1 gspca_pac207
videodev               25016  1 gspca_main
v4l1_compat             9020  1 videodev
i2c_i801                5748  0
i2c_core                9380  2 videodev,i2c_i801
osscore               542900  1 oss_hdaudio

both skype and mplayer need LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so to work

from LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so mplayer tv://
MPlayer SVN-r33811-snapshot-4.4.3 (C) 2000-2011 MPlayer Team
Playing tv://.
TV file format detected.
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
 comment: first try, more to come ;-)
Selected device: CIF Single Chip    
 Capabilities:  video capture  read/write  streaming
 supported norms:
 inputs: 0 = pac207;
 Current input: 0
 Current format: RGB24
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
Movie-Aspect is undefined - no prescaling applied.
VO: [x11] 352x288 => 352x288 Planar YV12
Selected video codec: [rawyv12] vfm: raw (RAW YV12)
==========================================================================
Audio: no sound
Starting playback...


maybe I will have more luck with new 3.0 kernel drivers
« Last Edit: August 08, 2011, 01:27:21 PM by nick65go »

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
Re: webcam/microphone not work with Flash
« Reply #5 on: August 09, 2011, 01:43:12 PM »
on 09 Aug 2011 "Adobe just released Flash Player 10.3.183.5 which fixes some of the Mac OSX 10.7 Lion bugs. It definetly fixes the Dialog box issue"
but not my opera/firefox bugs in linux, as webcam and microphone are not detected yet;

anyway, video + sound in youtube (for example) is still OK, no regression;
IMHO, Adobe support for Linux market (<5% ?) is dust in the eyes, as usually;

Offline nick65go

  • Full Member
  • ***
  • Posts: 231
Re: webcam/microphone not work with Flash
« Reply #6 on: August 09, 2011, 05:12:42 PM »
Succes to report here in Archlinux!;

uname -a
Linux myhost 2.6.39-ARCH #1 SMP PREEMPT Sat Jul 9 15:31:04 CEST 2011 i686 Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz GenuineIntel GNU/Linux

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 413c:a005 Dell Computer Corp. Internal 2.0 Hub
Bus 004 Device 002: ID 093a:2468 Pixart Imaging, Inc. SoC PC-Camera

need to use: LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so opera &

but now I have the Adobe "Settings..." dialog working in flash 10.3.181.34 for opera 11.50
webcam identified as "CIF Single Chip (V4L2)"
microphone as "HDA Intel"

So, still not sure if it is about the kernel version, or missing libraries for accelerated video?
window manager is the ancient "twm",

lsmod:
Module                  Size  Used by
arc4                    1094  2
snd_hda_codec_idt      48270  1
ecb                     1645  2
snd_hda_intel          19261  1
iwl3945                66309  0
snd_hda_codec          66665  2 snd_hda_codec_idt,snd_hda_intel
radeon                908324  2
iwl_legacy             45634  1 iwl3945
gspca_pac207            5465  1
snd_hwdep               4919  1 snd_hda_codec
gspca_main             21406  2 gspca_pac207
mac80211              189598  2 iwl3945,iwl_legacy
ttm                    45533  1 radeon
snd_pcm                60311  3 snd_hda_intel,snd_hda_codec
videodev               70734  2 gspca_main
drm_kms_helper         24245  1 radeon
cfg80211              126930  3 iwl3945,iwl_legacy,mac80211
media                   8513  1 videodev
snd_timer              15542  1 snd_pcm
firewire_ohci          25683  0
snd                    43399  7 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
b44                    22961  0
drm                   147653  4 radeon,ttm,drm_kms_helper
ssb                    41380  1 b44
soundcore               5018  1 snd
joydev                  7535  0
firewire_core          43390  1 firewire_ohci
iTCO_wdt               10333  0
iTCO_vendor_support     1553  1 iTCO_wdt
sdhci_pci               6886  0
sdhci                  15197  1 sdhci_pci
snd_page_alloc          5909  2 snd_hda_intel,snd_pcm
mmc_core               60838  2 ssb,sdhci
dell_laptop             7151  0
intel_agp               8664  0
intel_gtt              11417  1 intel_agp
evdev                   7310  7
rfkill                 12510  2 cfg80211,dell_laptop
i2c_algo_bit            4431  1 radeon
crc_itu_t               1077  1 firewire_core
thermal                 6603  0
dell_wmi                1225  0
serio_raw               3430  0
i2c_i801                7039  0
pcmcia                 31566  1 ssb
pcmcia_core            10154  1 pcmcia
sg                     21022  0
mii                     3383  1 b44
dcdbas                  4284  1 dell_laptop
r592                   10363  0
memstick                5494  1 r592
sparse_keymap           2636  1 dell_wmi
agpgart                22160  4 ttm,drm,intel_agp,intel_gtt
i2c_core               16665  6 radeon,videodev,drm_kms_helper,drm,i2c_algo_bit,i2c_i801
psmouse                55927  0
battery                 8905  0
button                  3654  0
video                   9852  0
ac                      2545  0
processor              21884  2
wmi                     7367  1 dell_wmi
ext4                  334562  1
mbcache                 4321  1 ext4
jbd2                   59098  1 ext4
crc16                   1077  1 ext4
sr_mod                 12956  0
cdrom                  31341  1 sr_mod
sd_mod                 25483  2
pata_acpi               2396  0
uhci_hcd               19312  0
ata_piix               18569  1
libata                154285  2 pata_acpi,ata_piix
ehci_hcd               34847  0
usbcore               119324  5 gspca_pac207,gspca_main,uhci_hcd,ehci_hcd
scsi_mod              110702  4 sg,sr_mod,sd_mod,libata
« Last Edit: August 10, 2011, 09:04:18 AM by nick65go »