WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: mc slow extension loading at boot  (Read 11387 times)

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc slow extension loading at boot
« Reply #45 on: June 23, 2011, 11:01:54 AM »
Thanks for your suggestions.

I didn't notice any difference after adding the boot code  floppy=0,irq though.  etc/profile.d/sun-jre.sh doesn't run at startup but I have it in my .filetool.lst. Removing it from the .filetolls.lst didn't affect the boot speed either.

Offline Lee

  • Hero Member
  • *****
  • Posts: 645
    • My Core wiki user page
Re: mc slow extension loading at boot
« Reply #46 on: June 23, 2011, 11:23:54 AM »
I'm starting a new project where I will boot a generic pc from a usb stick which will be its only storage device.  I'm setting up the new USB stick on a different pc, one which I regularly boot from my primary boot USB stick (and in fact the new USB stick is, at this point, (functionally) a copy of my primary boot USB stick).

The primary USB stick, which works just fine, is an HP v125w 4GB, partitioned as one partition which is formatted FAT32 and using grub4dos to boot tiny core or micro core 3.7.1.  Only /boot and /tce are accessed from the stick during boot (no persistent /usr, /home or /opt).

The new USB stick is a brand new PNY Attache` "mini" set up the same way.  When booting from this new stick, TC hangs when trying to load the onboot extensions.  I didn't wait around for more than a couple of minutes to see if it would continue.  If I boot with the base and norestore boot codes, it boots up (but is not particularly useful as the target machine will be running headless with only ssh access).

I'm checking the install to make sure I didn't do something stupid.  If not, then the next steps will be
1) redo the install from scratch - maybe even follow the instructions
2) redo the install from scratch using ext2
3) additional troubleshooting as required

Edit - 06/28/2011:
I skipped step 1 above and went straight to step 2 (using ext2) and it boots nicely and loads extensions.  I'll still need to get to the root of the issue, as I simply don't want to be locked out of using a standard FAT USB stick, even though it doesn't matter for the current project.

« Last Edit: June 26, 2011, 02:38:19 PM by Lee »
32 bit core4.7.7, Xprogs, Xorg-7.6, wbar, jwm  |  - Testing -
PPR, data persistence through filetool.sh          |  32 bit core 8.0 alpha 1
USB Flash drive, one partition, ext2, grub4dos  | Otherwise similar

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc slow extension loading at boot
« Reply #47 on: June 24, 2011, 10:37:47 AM »
I've now made opt persistent (and edited .filetool.lst), but the issue remains.
How can I log udevd?