Tiny Core Linux

General TC => Tiny Core on Virtual Machines => Topic started by: xpto09 on March 20, 2011, 01:27:47 PM

Title: Flash: no sound
Post by: xpto09 on March 20, 2011, 01:27:47 PM
After a long time, I returned to use TC in virtualbox.
I remember that there was not problem to install flash.
I tried several times.
After a short time, there is no more sound.
What changed?

I have installed oss, firefox (run), getflash.
There is sound using osstest.
Title: Re: Flash: no sound
Post by: hamnose on July 21, 2011, 12:43:39 AM
This post is so old. I felt bad to see it. Quite an unusual thing that FAQ's would have much more than ridiculously topical information but the FAQ for Tinycore actually has a bit of info and it addresses this. I put the copies of the files libflashplayer.so and libflashsupport_32.so in all the browser plugin directories I found on my system and in the directory /usr/lib. I think that is all the FAQ instructs one to do.
Title: Re: Flash: no sound
Post by: coreplayer2 on July 21, 2011, 07:22:06 PM
Interesting,,   so where did yo find this "libflashsupport_32.so" file please?
Title: Re: Flash: no sound
Post by: hamnose on August 10, 2011, 01:28:48 AM
Sorry, I reply to a hundred year old post and take a hundred years to reply to you.

Hmm. I haven't seen that file libflashsupport_32.so in a while but I had to have both it and the libflashplayer.so in the mozilla plugin directory to get flash to work. Another mystery. Maybe I downloaded the 64 bit flash and got the files mixed up. But it worked. Later I found that the tcz install would not always work. And later I would not see this file libflashsupport_32.so and I would just put the libflashplayer.so which I got from Adobe in the /use/local/lib/mozilla/plugin directory not bothering to put it in /usr/lib as the readme suggested and that would be all flash needed. I vaguely remember reading something telling me to do this but I can't find that now and I can't find the files I was using, so I guess I'll never know. Sorry.

Lately it seems that libflashplayer.so needs to be put in /usr/local/minefield6/firefox-6.0/plugins. These things keep changing.

Now I take back what I said about the readme. It isn't so great...    ...No, Now I take that back, the new tcz package for flash 10 works fine so the readme is great after-all...

I forgot to tell xpto09 to try installing the oss-alsa package along with the oss. Not that it matters now, it was such a long time ago.
Title: Re: Flash: no sound
Post by: Rich on August 10, 2011, 11:36:51 AM
libflashsupport_32.so   shows up in   OSS.tcz
Title: Re: Flash: no sound
Post by: hamnose on August 15, 2011, 12:37:39 AM
Thanks. I was actually wondering about this.