Tiny Core Linux

General TC => General TC Talk => Topic started by: 3rail on June 26, 2010, 07:05:20 PM

Title: wpa supplicant with swapped in ipw2200 wireless card and wpa2 (solved)
Post by: 3rail on June 26, 2010, 07:05:20 PM
I'm throwing this out there on a whim, I don't really expect to get any replies but what the heck.

I've got a thinkpad x31 all set up nicely with TCL 2.11.5 and I've been trying to get the wireless to work with wpa.  The wireless card is a cisco mpi 350 and it works fine with the airo driver until you try to use WPA.  The symptom is that during boot it says "wpa is supported" but when you try to engage wpa supplicant, it says "driver does not support wpa." which leaves you scratching your head.  After much googling, it seems there's some firmware update to get it to support wpa but I wasn't able to find it and there is much pain out there trying to get this mini pci wireless card to work with wpa under linux.

So instead I swapped in an intel mini pci wireless b/g card from an unused t41 into my x31.  Machine boots fine and recognizes the card, asks for the firmware and I took care of all that.  Things were looking up.  But then I get stuck once I try to engage wpa supplicant.  it complains that "WPA: 4-Way Handshake failed - pre-shared key may be incorrect" and I know that I've got the correct wpa password in there.  Not much luck googling a resolution to that error message from wpa supplicant so I'm pretty stuck on what my next move should be.

Basically my throw it on the wall and see if it sticks question is, "has anyone been able to get around this error message (WPA: 4-Way Handshake failed - pre-shared key may be incorrect) from wpa supplicant?"

TIA

update: replacing the wpa_passphrase encoded version of the password with the plaintext quoted version has solved this issue.  I'm successfully connected to my wireless AP using wpa2 using this workaround.