Tiny Core Linux

Tiny Core Extensions => TCE Tips & Tricks => Topic started by: rtb on June 16, 2010, 10:34:28 AM

Title: [xorg] How to: correct resolution for dell c400/intel 830m chip
Post by: rtb on June 16, 2010, 10:34:28 AM
This tutorial might work for other 8-900 series graphics chipsets that you can't get to work under typical methods.
Tutorial written for tc 2.11.3

Install:
graphics-2.6.29.1-tinycore.tcz
Xorg-7.4.tcz

add the following line to /opt/.filetool.lst
etc/X11/xorg.conf

Then create the file etc/X11/xorg.conf and add the following text.(you probably need root access for this)

Section "Monitor"
 Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

Section "Device"
        Identifier      "Configured Video Device"
        Option          "AccelMethod" "UXA"
EndSection

Section "ServerFlags"
        Option  "DontZap"       "False"
EndSection



I'm not sure if the serverflags section is relevant I haven't tried it without it yet.  I just thought I'd put this up after trying for months to get tc to not be in 680x400 mode.
Title: Re: [xorg] How to: correct resolution for dell c400/intel 830m chip
Post by: libretto on June 25, 2010, 03:20:47 AM
can you use the default "vesa" instead of the "Xorg" driver ?
for vesa to work you just edit the .xsession under your  /home/tc  directory to the resolution you want save it then reboot should do.
Title: Re: [xorg] How to: correct resolution for dell c400/intel 830m chip
Post by: rtb on June 25, 2010, 07:46:15 AM
no, 830m chip is total garbage in linux, afaik its been forgotten in kernel updates.  Using vesa you can only get 600x400 resolution.  I've just installed wine and realized its going to need some graphics settings changed because its unviewable.  Its just one obstacle after another on this thing.
Title: Re: [xorg] How to: correct resolution for dell c400/intel 830m chip
Post by: Juanito on June 26, 2010, 01:35:02 AM
855patch, 855wrap or 810resolution might be useful - I was using 855wrap with success back in the dsl days with a dell d400 and an i845 chipset

http://www.chzsoft.de/855patch.html (http://www.chzsoft.de/855patch.html)
Title: Re: [xorg] How to: correct resolution for dell c400/intel 830m chip
Post by: ^thehatsrule^ on July 01, 2010, 12:29:26 AM
I'm not sure if the serverflags section is relevant I haven't tried it without it yet.
Yea, it's not relevant.
Title: Re: [xorg] How to: correct resolution for dell c400/intel 830m chip
Post by: Edd on July 11, 2010, 10:31:24 AM
Can I ask for a clarification on this instruction:
Quote
Install:
graphics-2.6.29.1-tinycore.tcz
Xorg-7.4.tcz

Following the wiki (http://wiki.tinycorelinux.com/Using+Xorg+over+Xvesa), I exited to the prompt and attempted to install Xorg by typing
Code: [Select]
sudo Install Xorg-7.4.tcz but this simply gives me the Usage help for Install.  I re-tried a second method, first downloading these extensions to /tce/optional and then included that path in my command above, assuming I needed to include this as my [SOURCE] argument, but that gave me the same result.  I also tried approaches both without 'sudo' to no avail.

I suppose I am missing a simple command or step, but I haven't been able to locate the details for what I need.   Thanks.
Title: Re: [xorg] How to: correct resolution for dell c400/intel 830m chip
Post by: Juanito on July 11, 2010, 10:42:09 AM
You can use the appbrowser "local" button to load the extensions or from a terminal window:
Code: [Select]
$ tce-load -i Xorg-7.4.tcz