Tiny Core Linux

Tiny Core Base => TCB News => Alpha Releases => Topic started by: roberts on June 06, 2010, 07:03:19 AM

Title: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 06, 2010, 07:03:19 AM
Tiny Core v3.0 Alpha6 is now posted at http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/3.x/release_candidates

Change log for Alpha 6
* Updated libjepg
* Updated libsysfs
* Updated systool
* Updated get_device
* Updated bcrypt
* Updated rungetty
* Updated wallpaper to read current solid background color.
* Updated usbinstall added UUID clause to waitusb option.
* Updated tce-update to handle KERNEL resolution in dep files.
* Updated tce-update to acknowledge when system is up-to-date.
* Updated tce-update to accept tce dir as parameter.
* Fixed bug in tc-functions autoscan.
* Removed unneeded jpegtrans, logsave, and libss*
* New default background color.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: jur on June 06, 2010, 07:41:49 AM
I see the quotes at wbar.sh was also fixed... thanks! All seems working smoothly, except:

Trying out wallpaper color reading default color... 2nd or 3rd try it came up with a green which was not my set color.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 06, 2010, 07:56:55 AM
Posting the contents of your .setbackground will be helpful.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: sci_fi on June 06, 2010, 09:42:11 AM
Good morning.

Just upgraded to a6. Quick observation:

Althought tce-update indicates no updates required.

xset fails with
xset: error while loading shared libraries: libXfontcache.so.1: cannot open shared object file: no such file or directory

Since I run xset to set mouse parameters during icewm initialization this happens right away.

No other comments so far.

Best regards,

sci_fi

Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: bmarkus on June 06, 2010, 09:56:55 AM

* Updated tce-update to handle KERNEL resolution in dep files.


Robert, can you provide details what does it mean?
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: curaga on June 06, 2010, 10:07:00 AM
Good morning.

Just upgraded to a6. Quick observation:

Althought tce-update indicates no updates required.

xset fails with
xset: error while loading shared libraries: libXfontcache.so.1: cannot open shared object file: no such file or directory

Since I run xset to set mouse parameters during icewm initialization this happens right away.

No other comments so far.

Best regards,

sci_fi



Parts of Xorg 7.4 still depend on libXfontcache. Will add that lib to the 3.x version of Xorg 7.4.

edit: done. Please update your Xorg-7.4 extension (or move to 7.5 ;))
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: sci_fi on June 06, 2010, 11:20:40 AM
Thanks, Curaga. I have made the move to Xorg 7.5. Experimenting now.

Best regards,

sci_fi
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 06, 2010, 12:09:28 PM

* Updated tce-update to handle KERNEL resolution in dep files.


Robert, can you provide details what does it mean?

This issue came up during alpha5 testing when tce-update tried to update a bluetooth extension.
Since v3.x kernel specifics are not specified in the .dep files. They are referred by the generic name of KERNEL.
During tce-load, and now tce-update, after a successful download, the KERNEL label is replaced with its specific name uname -r and  tce-update is once again successful.

The following .dep files have such a KERNEL specification:
OSS.tcz.dep
alsa-modules-2.6.33.3-tinycore.tcz.dep
alsa-modules-2.6.33.3-tinycore64.tcz.dep
bluez.tcz.dep
cpufrequtils.tcz.dep
filesystems-2.6.33.3-tinycore.tcz.dep
filesystems-2.6.33.3-tinycore64.tcz.dep
graphics-2.6.33.3-tinycore.tcz.dep
graphics-2.6.33.3-tinycore64.tcz.dep
hwmon-2.6.33.3-tinycore.tcz.dep
hwmon-2.6.33.3-tinycore64.tcz.dep
input-tablet-touchscreen-2.6.33.3-tinycore.tcz.dep
input-tablet-touchscreen-2.6.33.3-tinycore64.tcz.dep
ipv6-2.6.33.3-tinycore.tcz.dep
ipv6-2.6.33.3-tinycore64.tcz.dep
irda-2.6.33.3-tinycore.tcz.dep
irda-2.6.33.3-tinycore64.tcz.dep
leds-2.6.33.3-tinycore.tcz.dep
leds-2.6.33.3-tinycore64.tcz.dep
nvidia-glx.tcz.dep
v4l-dvb-2.6.33.3-tinycore.tcz.dep
v4l-dvb-2.6.33.3-tinycore64.tcz.dep
wireless_tools.tcz.dep
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: bmarkus on June 06, 2010, 12:12:35 PM
Robert@

thanks for the explanation, it is a nice feature :)
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: bmarkus on June 06, 2010, 12:25:12 PM
I have thunderbird3.tcz installed. Running cpanel/Update Apss it displays

Updating thunderbird3.tcz Failed

Entry in /tmp/upgrade_erros.lst

Error occurred. thunderbird3.tcz Not updated!

Everything works fine, all other extensions updated as expected. Error message is not informative. Just a guess, without digging ito the code, that the number in the name is causing the problem.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: jur on June 06, 2010, 02:56:53 PM
Posting the contents of your .setbackground will be helpful.
I didn't have a set color, I have an image, I was testing the color setter. I saw this behaviour twice. I started by setting a blue-ish background, going back, yep it worked, went back again, nope green. So I tried again, and the second time after setting to blue-ish, it came up with the green-ish immediately.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: bigpcman on June 06, 2010, 04:31:57 PM
Tiny Core v3.0 Alpha6 is now posted at http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/3.x/release_candidates

Change log for Alpha 6
* Updated libjepg
* Updated libsysfs
* Updated systool
* Updated get_device
* Updated bcrypt
* Updated rungetty
* Updated wallpaper to read current solid background color.
* Updated usbinstall added UUID clause to waitusb option.
* Updated tce-update to handle KERNEL resolution in dep files.
* Updated tce-update to acknowledge when system is up-to-date.
* Updated tce-update to accept tce dir as parameter.
* Fixed bug in tc-functions autoscan.
* Removed unneeded jpegtrans, logsave, and libss*
* New default background color.


Please remind me, is systool what loads the init.d scripts? If so please explain how it works now.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: maro on June 06, 2010, 04:45:25 PM
@bigpcman: AFAIK there is no direct connection between 'systool' and 'init.d'.

I recommend when you come across an "unfamiliar" command you should try first a search via a useful reference (http://linux.die.net/) page. Most things are not unique to TC / MC. In this case this man (http://linux.die.net/man/1/systool) page might provide you with some pointers. Otherwise you could end up with a "RTFM response"  ;).
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: maro on June 06, 2010, 10:42:52 PM
I read that some more system libraries were updated (e.g. 'libjepg'). I assume that base-dev.tcz will soon reflect those changes (if not already done).

With regards to the removed items:
(1) Is it planned to make 'logsave' available via a suitable extension? Not that I'm missing it, but I guess that has been the case in the past for similar cases.
(2) Likewise will 'libss.a' remain in base-dev.tcz after the shared library was removed from Core, or will they all find a "new home"?
(3) I'm not sure which 'logtrans' was removed, but 'logtran' is still in the Core (and another one in the libjpeg-utils.tcz extension):
Code: [Select]
tc@box:~$ version ; which jpegtran
tinycore_3.0alpha6
/usr/bin/jpegtran

Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: maro on June 07, 2010, 01:08:17 AM
To continue with my nit-picking today: I just stumbled over a potential contradiction to "... and libfontenc has not received an update since the 7.4 days. ..." (see post (http://forum.tinycorelinux.net/index.php?topic=6229.msg33208#msg33208)) insofar as according to a certain Xorg 7.5 page (http://www.x.org/wiki/Releases/7.5) libfontenc-1.0.5 is the relevant version for that release.

Looking at some release dates on a log page (http://cgit.freedesktop.org/xorg/lib/libfontenc/log/) I assume that what was build a year ago would most likely be libfontenc-1.0.4. But hey, I could be totally wrong with all my conclusions ...
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: curaga on June 07, 2010, 03:11:54 AM
To continue with my nit-picking today: I just stumbled over a potential contradiction to "... and libfontenc has not received an update since the 7.4 days. ..." (see post (http://forum.tinycorelinux.net/index.php?topic=6229.msg33208#msg33208)) insofar as according to a certain Xorg 7.5 page (http://www.x.org/wiki/Releases/7.5) libfontenc-1.0.5 is the relevant version for that release.

Looking at some release dates on a log page (http://cgit.freedesktop.org/xorg/lib/libfontenc/log/) I assume that what was build a year ago would most likely be libfontenc-1.0.4. But hey, I could be totally wrong with all my conclusions ...

That's correct, I based my assumption on the release date of 1.0.5. Though, looking at the changelog between 1.0.4 and .5 I don't see a need for update ;):

Quote
2009-08-28   libfontenc 1.0.5libfontenc-1.0.5   Peter Hutterer   1   -1/+1
2009-02-03   Add README with pointers to mailing list, bugzilla & git repos   Alan Coopersmith   1   -0/+25
2009-01-28   Janitor: Correct make distcheck and compiler warnings.   Paulo Cesar Pereira de Andrade   8   -29/+25
2007-12-06   Add missing PHONY line for automatic ChangeLog generation   James Cloos   1   -0/+2
2006-12-15   bump to 1.0.4libfontenc-1.0.4
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: Juanito on June 07, 2010, 05:14:36 AM
I read that some more system libraries were updated (e.g. 'libjepg'). I assume that base-dev.tcz will soon reflect those changes (if not already done).
...
Likewise will 'libss.a' remain in base-dev.tcz after the shared library was removed from Core

base-dev is current as of alpha5 - I need to remove libss.a, etc
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: gutmensch on June 07, 2010, 04:14:34 PM
sorry if I'm repeating an error (just in case), but searching for that one is quite hard and revealed nothing in the forum...

testing with 3.0alpha6:

tce-load -w -i mysql.tcz

/tmp/tcloop/mysql.tcz/... instead of /tmp/tcloop/mysql/... will be setup, then additionally the startup script from usr/local/tce.installed/mysql will not start (maybe because mysql.tcz is not mysql?) I'm experiencing the same problem while trying to make a new extension and I'm especially regarding the rights for tce.installed and its files... can anybody verify this or is my tc messed up?

best regards,
robert
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: maro on June 07, 2010, 08:16:16 PM
@gutmensch: I suspect it's your system.

I did a quick test with your command (i.e. tce-load -wi mysql.tcz) and the extension got mounted to the "usual place" with the "usual" directory name:
Code: [Select]
tc@box:~$ ls -l /tmp/tcloop/
total 0
drwxr-xr-x    3 root     root            26 Oct 27  2009 mysql/
drwxr-xr-x    3 root     root            26 Oct 16  2009 perl5/

tc@box:~$ mysql -V
mysql  Ver 14.14 Distrib 5.1.40, for pc-linux-gnu (i686) using  EditLine wrapper

tc@box:~$ ps | grep mysql | grep -v grep
  558 root     /bin/sh /usr/local/bin/mysqld_safe --ledir=/usr/local/libexec/ --socket=/tmp/mysql.sock --port=3306
                     --pid-file=/tmp/hostname.pid --datadir=/usr/local/var/mysql --language=/usr/local/share/mysql/english --user=tc
  657 tc       /usr/local/libexec//mysqld --basedir=/usr/local --datadir=/usr/local/var/mysql --user=tc
                    --language=/usr/local/share/mysql/english --log-error=/usr/local/var/mysql/box.err --pid-file=/tmp/hostname.pid
                    --socket=/tmp/mysql.sock --port=3306
It seem to be running as it probably should.

The one thing which I consider not so "pretty" is the fact the the startup script uses tar xvxf .... That produces a listing of all extracted files, which I personally could do without. I guess tar xzf ... would be "nicer" from an "aesthetic" POV.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: bmarkus on June 07, 2010, 10:36:24 PM
While mysql.tcz installs fine here, it is a rather old extension and deserves and update both in version and TC compatibility. Will I will do it this week.

BTW, installing mysql.tcz Appbrowser displays:

(http://tc.hasix.org/scrcap/mysqlinst30a6a.jpg)

See bottom status line. Is it a bug or feature?
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 07, 2010, 10:39:17 PM
Will likely be corrected when the v flag is removed from the mydsl.tcz mysql.tcz startup script tar extraction command. Startup scripts should not be sending output to the display.

EDIT: Fixed to mysql. Too many years there. Too many times typing that other system.  :-[
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: bmarkus on June 07, 2010, 10:43:32 PM
Will likely be corrected when the v flag is removed from the mydsl.tcz startup script tar extraction command. Startup scripts should not be sending output to the display.

Thanks. Anyhow I will remove tar from the start-up script.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: maro on June 07, 2010, 10:57:16 PM
Gee, I wonder why Robert has typed "... the mydsl.tcz startup  ..."  ;D
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: Arslan S. on June 07, 2010, 11:03:45 PM
i can confirm what gutmensch says

some of the extensions are mounted with .tcz suffix after reboot

add compiletc to onboot list and reboot

tc 3.0a6
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 07, 2010, 11:19:04 PM
I just did and did not get a failure. compiletc mounted normal.
Please post the output of showbootcodes and any other info regarding your setup particulars.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: Arslan S. on June 07, 2010, 11:32:36 PM
boot codes: quiet tce=sda9

i have setup tc on hard drive with backup/restore

http://farm5.static.flickr.com/4017/4681558220_e42a26d771_b.jpg (http://farm5.static.flickr.com/4017/4681558220_e42a26d771_b.jpg)
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: ^thehatsrule^ on June 08, 2010, 12:53:00 AM
From a quick glance, it seems that the problem starts after coreutils is installed
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: gutmensch on June 08, 2010, 01:06:39 AM
I think I could track down one thing...

coreutils.tcz is causing the problem on my system. every extension loaded before coreutils is ok, every extension loaded after coreutils in onboot.lst gets mounted with suffix. Strangely on tc3.0a3 the extension after coreutils (in my case bash.tcz) doesn't load at all although it's in onboot.lst and in the repo. On tc3.0a6 bash.tcz loads but with suffix.

bootcodes: kmap=de-latin1 tce=hda1 home=hda1 restore=hda1 opt=hda1 lang=de_DE quiet

@hats: wow that quick shot came unexpectedly from out of nowhere ;-)
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 08, 2010, 07:48:12 AM
Found it. Fixed it.
Nothing wrong with coreutils, except that its utils are so much more bloated than what I need during boot.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: SvOlli on June 09, 2010, 08:52:39 AM
I bit this isn't a new one, but I wanted to note it anyway:

If you boot with the "user=xxx" option, the directories "/home/xxx/.OnDemand" and "/home/xxx/.wmx" will still be owned by "tc" instead of "xxx".
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 09, 2010, 01:31:22 PM
Got it. Thanks!
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: althalus on June 09, 2010, 02:45:49 PM
Has the code for the app browser changed since 2.11? (And if so, is there a way you could make it available?) I'd like to tinker with it a little, and experiment with a couple of ideas.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: althalus on June 09, 2010, 03:24:19 PM
I'm also curious as to how the TC team managed to compile the mnttool on TC3 - It will only seem to compile for me if I include stdlib.h, which unfortunately blows out it's size monstrously.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: maro on June 09, 2010, 03:27:46 PM
I bet Robert has already squashed this whilst I ran a little loop over all the "usual suspects":
Code: [Select]
tc@box:~$ echo $PATH | tr ':' '\n' | while read DIR ; do sudo grep 'chown ' ${DIR}/* /dev/null ; done
/usr/bin/flwm_topside_initmenu:chown tc.staff -R /home/"$USER"/.wmx
/usr/bin/startx:    sudo chown root.staff "$TCEWBAR"
/usr/bin/tce-setdrive:  sudo chown -R tc.staff "$TCEDIR"
/usr/bin/tce-setup:chown -R "$USER".staff "$TCEINSTALLED"
/usr/bin/tce-setup:chown -R "$USER".staff "$TCEDIR" /opt/.tce_dir 2>/dev/null
/usr/bin/xsetup:sudo chown "$USER" "$HOME"/.xsession
/usr/bin/xsetup.sh:sudo chown "$USER" "$HOME"/.xsession

What stands out are the two occasions where 'tc' is hard coded (i.e. '/usr/bin/flwm_topside_initmenu' and '/usr/bin/tce-setdrive') and the fact that in '/usr/bin/xsetup.sh' no group is specified. I have not checked the other "*_initmenu" scripts for the other legacy WM, but they might be worth a look as well.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: bmarkus on June 09, 2010, 11:15:56 PM
Just a small cosmetics. During boot there is a message:

Quote
Loading Tiny Core Applications Extensions

This would be better:

Quote
Loading Tiny Core Extensions
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: SvOlli on June 11, 2010, 08:35:52 AM
Hello!

There are two things with tce-load I'd call odd:

First, you can run
Code: [Select]
tce-load -w -i extension.tczto download and install an extension, but
Code: [Select]
tce-load -i extension.tczfails, even if the extension has been downloaded.
I've attached a patch that prepends $TCEDIR/optional as a second try, if the extension was not found in the first place.

Second, if you try to install locally an extension that depends on compiletc.tcz, it will fail. To reproduce download only the qt-creator.tcz creator package and install it afterwards locally or via ondemand.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: maro on June 11, 2010, 04:22:38 PM
Due to reading another thread (http://forum.tinycorelinux.net/index.php?topic=6401) I had a quick look at the Wiki page (http://wiki.tinycorelinux.com/Local_appbrowser_server) mentioned and feel now compelled to report a minor annoyance:

Currently the URL in '/opt/tcemirror' has to end with a forward slash (unlike to what the Wiki page might suggest). This is due to the lack of a forward slash between "$MIRROR" and "$(getMajorVer)" in the current implementation of the 'getMirror()' function (in '/etc/init.d/tc-functions'). I believe that changing it to
    MIRROR="${MIRROR%/}/$(getMajorVer).x/tcz"
would make it a more "tolerant" function.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 11, 2010, 08:14:13 PM
Has the code for the app browser changed since 2.11? (And if so, is there a way you could make it available?) I'd like to tinker with it a little, and experiment with a couple of ideas.
The latest source code for 2.x is posted.
http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/2.x/release/src/fltk_projects/
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 11, 2010, 08:16:08 PM
I'm also curious as to how the TC team managed to compile the mnttool on TC3 - It will only seem to compile for me if I include stdlib.h, which unfortunately blows out it's size monstrously.
Since I am still supporting 2.x, and fltk is 1.1.10 on both 2.x and 3.x I have not moved fltk compiles to 3.x.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 11, 2010, 08:16:37 PM
Just a small cosmetics. During boot there is a message:

Quote
Loading Tiny Core Applications Extensions

This would be better:

Quote
Loading Tiny Core Extensions
OK. Done.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 11, 2010, 08:18:40 PM
Hello!

There are two things with tce-load I'd call odd:

First, you can run
Code: [Select]
tce-load -w -i extension.tczto download and install an extension, but
Code: [Select]
tce-load -i extension.tczfails, even if the extension has been downloaded.
I've attached a patch that prepends $TCEDIR/optional as a second try, if the extension was not found in the first place.

Second, if you try to install locally an extension that depends on compiletc.tcz, it will fail. To reproduce download only the qt-creator.tcz creator package and install it afterwards locally or via ondemand.
Patch accepted. Thanks. I will look into the other before I comment.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 11, 2010, 08:19:35 PM
Due to reading another thread (http://forum.tinycorelinux.net/index.php?topic=6401) I had a quick look at the Wiki page (http://wiki.tinycorelinux.com/Local_appbrowser_server) mentioned and feel now compelled to report a minor annoyance:

Currently the URL in '/opt/tcemirror' has to end with a forward slash (unlike to what the Wiki page might suggest). This is due to the lack of a forward slash between "$MIRROR" and "$(getMajorVer)" in the current implementation of the 'getMirror()' function (in '/etc/init.d/tc-functions'). I believe that changing it to
    MIRROR="${MIRROR%/}/$(getMajorVer).x/tcz"
would make it a more "tolerant" function.
Suggested change accepted. Thanks!
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: roberts on June 12, 2010, 08:12:26 PM
Hello!

There are two things with tce-load I'd call odd:

First, you can run
Code: [Select]
tce-load -w -i extension.tczto download and install an extension, but
Code: [Select]
tce-load -i extension.tczfails, even if the extension has been downloaded.
I've attached a patch that prepends $TCEDIR/optional as a second try, if the extension was not found in the first place.

Second, if you try to install locally an extension that depends on compiletc.tcz, it will fail. To reproduce download only the qt-creator.tcz creator package and install it afterwards locally or via ondemand.
Patch accepted. Thanks. I will look into the other before I comment.
Re: Second part
Found it. Fixed. Thanks. That was a subtle one.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: MikeLockmoore on June 13, 2010, 10:42:01 AM
Hello all.  I've done a little testing with Alpha 6 on my Dell Inspiron 5100 (P4) laptop.  No real problems, besides maybe a couple of hung shutdowns reboot or shutdown from the FLWM menu.  It does not seem to happen consistently or in any particular situation that I can figure out.  If I do see a more repeatable example, I'll post it.

I'd like to build the kernel module for my ACX chipset WiFi adapter, but the linux-headers extension is not ready yet.  I downloaded the Linux 2.6.33.3 source tree, but I don't know how to set up a /lib/modules/.../build/ tree, which I need to build the acx.ko module.  Is a copy of the /lib/modules/.../build tree in the Linux source tree somewhere?  Or does anyone know how I can set up the build tree?  Thanks for any advice.
--
Mike L.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: curaga on June 13, 2010, 10:56:10 AM
build is just a symlink to the extracted kernel source. If .config is there, "make modules_prepare" in the three is enough to make external modules compile.
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: Arslan S. on June 13, 2010, 11:15:06 AM
this should do it for you
Code: [Select]
cp -f ../configure-2.6.33.3-tinycore .config
make oldconfig
make modules_prepare
ln -s /path/to/linux-source /usr/src/linux
ln -s /usr/src/linux /lib/modules/2.6.33.3-tinycore/build
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: batnas on June 13, 2010, 01:12:06 PM
While 3.x is still in alpha, i have a suggestion:
Shoudn't libc be upgraded to 2.11.2?
it is currently 2.11.1

Ref.: http://forum.tinycorelinux.net/index.php?topic=6427.msg34103#msg34103 (http://forum.tinycorelinux.net/index.php?topic=6427.msg34103#msg34103)

\\Batnas
Title: Re: Tiny Core 3.0 Alpha 6 Testing
Post by: Juanito on June 13, 2010, 08:22:53 PM
Do you know for sure that your problem is something to do with glibc-2.11.1 or could it be something to do with xtdesk?