Tiny Core Linux

Tiny Core Extensions => TCE Q&A Forum => Topic started by: SamK on February 16, 2010, 01:33:23 AM

Title: ntpclient Blanks Screen
Post by: SamK on February 16, 2010, 01:33:23 AM
In bootlocal.sh the following command sets the system time correctly then blanks the screen:
Code: [Select]
# Set the system time (use with bootcode tz=GMT)
ntpclient -s -h pool.ntp.org
The behaviour is consistently displayed in FLWM and LXDE.

Any keystroke cancels the screen-blank and returns to the GUI interface.  Moving the mouse, stopping the movement, then moving again also cancels the screen-blank.

Any suggestions on how to remove the unwanted screen-blank?
 
Title: Re: ntpclient Blanks Screen
Post by: bmarkus on February 16, 2010, 01:48:33 AM
Try this:

Quote
ntpclient -s -h pool.ntp.org &
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 16, 2010, 01:53:20 AM
Try this:

Quote
ntpclient -s -h pool.ntp.org &
Symptoms remain unchanged.  Also tried reordering other bootlocal.sh commands again symptoms remain unchanged.
Title: Re: ntpclient Blanks Screen
Post by: vitex on February 16, 2010, 07:28:25 AM
In bootlocal.sh the following command sets the system time correctly then blanks the screen:
Code: [Select]
# Set the system time (use with bootcode tz=GMT)
ntpclient -s -h pool.ntp.org
The behaviour is consistently displayed in FLWM and LXDE.

Any keystroke cancels the screen-blank and returns to the GUI interface.  Moving the mouse, stopping the movement, then moving again also cancels the screen-blank.

Any suggestions on how to remove the unwanted screen-blank?
 

Does your configuration normally blank the screen after a period of inactivity?  The behavior that you describe could possibly be caused by the screen saver kicking in when ntpclient makes a large adjustment in the time.  (I have been unable to duplicate the behavior that you describe, so this is just a guess.)  I suggest that you insert calls to "date >>/path/to/some/file" before and after the call to ntpclient in bootlocal.sh so you can see how much of a step ntpclient is making.

You can also try chrony instead of ntpclient to set the time.  Chrony will slew (adjust incrementally) instead of step the time if the offset is less than 30 seconds; that default can be adjusted in /usr/local/etc/chrony/chrony.conf .
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 16, 2010, 07:51:00 AM
Does your configuration normally blank the screen after a period of inactivity?  The behavior that you describe could possibly be caused by the screen saver kicking in when ntpclient makes a large adjustment in the time. (I have been unable to duplicate the behavior that you describe, so this is just a guess.) [...]
Your guess gave me an idea.  Configuring the bios date and time to the correct settings at boot up prevents the screen-blanking.  The bios time was some hours out of sync with ntp server time.  Your guess was both inspired and correct. 

Many thanks
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 16, 2010, 10:52:40 PM
Having established that the screen-blanking is canceled by any keystroke, it may be possible to use this to cater for situations where the PC BIOS is subject to 'cumulative drift'.  In such circumstances the inaccuracy of the local time will become out of sync to the point where the threshold is reached that triggers the screen-blanking when the time is reset by the ntp server.

Is it possible to append a simulated carriage return keystroke to the end of the command in bootlocal.sh which runs ntpclient?  If yes, how is the keystroke command constructed?
 
Title: Re: ntpclient Blanks Screen
Post by: roberts on February 16, 2010, 11:00:59 PM
You could, as I have already provided in Core, by using the TZ boot code and the getTime.sh script, the command hwclock to set your BIOS time.

Since you have chosen instead to use an extension to set the time, you still could call hwclock to write the time to BIOS.  See hwclock --help
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 17, 2010, 12:28:53 AM
Does your configuration normally blank the screen after a period of inactivity?  The behavior that you describe could possibly be caused by the screen saver kicking in when ntpclient makes a large adjustment in the time. (I have been unable to duplicate the behavior that you describe, so this is just a guess.) [...]
Your guess gave me an idea.  Configuring the bios date and time to the correct settings at boot up prevents the screen-blanking.  The bios time was some hours out of sync with ntp server time.  Your guess was both inspired and correct. 

Many thanks
Some additional information from further testing in FLWM with a large discrepancy between the BIOS time and the ntp server time:
   
Title: Re: ntpclient Blanks Screen
Post by: curaga on February 17, 2010, 12:44:58 AM
Likely because of mouse moving, or the last enter press registering as an event.
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 17, 2010, 12:59:00 AM
Likely because of mouse moving...
I am reasonably sure it is not attributable to mouse movement.

...the last enter press registering as an event.
This may well be the case - hence my question on how to append a simulated carriage return keystroke to the end of the command in bootlocal.sh which runs ntpclient
   
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 17, 2010, 01:09:16 AM
You could, as I have already provided in Core, by using the TZ boot code and the getTime.sh script, the command hwclock to set your BIOS time.
Thanks for this information, I am already using the bootcode "tz=GMT" but was unaware of the availability of getTime.sh

A couple of questions...

I have attempted to run this from bootlocal.sh
Code: [Select]
/usr/bin/getTime.shbut the date and time are not reset to the correct values.  Entering the same command in a terminal does reset the values.

At a future point I may wish to direct TC to a LAN based time server.  Is this possible using getTime.sh?
  
Edit: corrected typo in command
Title: Re: ntpclient Blanks Screen
Post by: curaga on February 17, 2010, 01:12:45 AM
xvkbd should be able to send simulated key events to the current window. Just might not work from bootlocal due to X security, other users can't access your display.
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 17, 2010, 04:59:02 AM
xvkbd should be able to send simulated key events to the current window. Just might not work from bootlocal due to X security, other users can't access your display.
I could not get it to work from bootlocal.sh.  Thanks anyway for the suggestion.
   
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 17, 2010, 05:12:21 AM
Reporting success...
Both getTime.sh and ntpclient work in conjunction with hwclock running from bootlocal.sh without blanking the screen.  The bootcode tz=GMT is used in both cases.

Code: [Select]
sleep 3 ; /usr/bin/getTime.sh ; /sbin/hwclock -w

Code: [Select]
sleep 3 ; ntpclient -s -h pool.ntp.org ; /sbin/hwclock -w

Both examples obtain the date and time is retrieved from an internet based server and used to set the BIOS date and time of the local PC.

The sleep command is used to ensure the network is available before attempting to get the date and time.  I would prefer to replace this with while...   but I don't know what to test for.  Can anyone suggest a valid while command?

At a future point I may wish to direct TC to a LAN based time server.  Is this possible using getTime.sh?

   
Title: Re: ntpclient Blanks Screen
Post by: curaga on February 17, 2010, 06:31:24 AM
while ! ping -c1 google.com; do sleep 1; done

I think getTime.sh could be pointed to a local time server, but it would require a remaster. IIRC it also uses some other time protocol than ntp, not sure about that though.
Title: Re: ntpclient Blanks Screen
Post by: roberts on February 17, 2010, 06:39:48 AM
For how to use Tiny Core's built time support see:
http://www.gnu.org/software/libtool/manual/libc/TZ-Variable.html

Your BIOS needs to be set UTC not local. You need to use boot code of tz=
See: http://www.tinycorelinux.com/faq.html#timezone

The getTime script accepts a parameter, which should be a local time server in your area. Remaster not necessary.
See: http://tf.nist.gov/tf-cgi/servers.cgi
Title: Re: ntpclient Blanks Screen
Post by: vitex on February 17, 2010, 06:42:41 AM

The sleep command is used to ensure the network is available before attempting to get the date and time.  I would prefer to replace this with while...   but I don't know what to test for.  Can anyone suggest a valid while command?
 

I use
Code: [Select]
while ! nslookup pool.ntp.org >/dev/null 2>&1 ; do sleep 1 ; done ; sleep 2
to wait for the network to come up before initializing Chrony.  I am not sure that the "sleep 2" is needed.

The Chrony extension has the ability to keep the BIOS hardware clock synchronized to ntp time; that capability is not enabled in the default TC configuration. See the RTC commands in the Chrony documentation http://chrony.tuxfamily.org/manual.html (http://chrony.tuxfamily.org/manual.html).

Chrony can also be configured to serve ntp time to other computers on the local network.
Title: Re: ntpclient Blanks Screen
Post by: maro on February 17, 2010, 04:42:42 PM
Isn't it kind of funny that the default DAYTIME server in the getTime.sh script turns out to be hosted by M$?
(see: http://www.robtex.com/ip/131.107.13.100.html)

I'm not suggesting for a moment to change anything, and I'm afraid I'm getting off-topic now ...
Title: Re: ntpclient Blanks Screen
Post by: bmarkus on February 17, 2010, 11:15:49 PM
Isn't it kind of funny that the default DAYTIME server in the getTime.sh script turns out to be hosted by M$?
(see: http://www.robtex.com/ip/131.107.13.100.html)

I'm not suggesting for a moment to change anything, and I'm afraid I'm getting off-topic now ...

This is good. Increase their load and leave others free :)
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 18, 2010, 12:42:32 AM
Many thanks for the suggested while commands.  I now have one which works as I require.
   
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 18, 2010, 01:55:11 AM
My objective in this topic is to use a remote timeserver to set the system-time and BIOS time of a local PC in the United Kingdom of Great Britain which uses Daylight Saving Time (DST).

The advice and references you have been good enough to provide have led to some confusion about the use of the bootcode tz.  I would welcome some clarification on this matter.

For how to use Tiny Core's built time support see:
http://www.gnu.org/software/libtool/manual/libc/TZ-Variable.html
Abstracts from the document
Quote
"You should not normally need to set TZ. If the system is configured properly, the default time zone will be correct. You might set TZ if you are using a computer over a network from a different time zone, and would like times reported to you in the time zone local to you, rather than what is local to the computer. "

"In POSIX.1 systems the value of the TZ variable can be in one of three formats. With the GNU C library, the most common format is the last one, which can specify a selection from a large database of time zone information for many regions of the world. The first two formats are used to describe the time zone information directly, which is both more cumbersome and less precise."

"The first format is used when there is no Daylight Saving Time (or summer time) in the local time zone:..."

"The second format is used when there is Daylight Saving Time: ..."

"The third format looks like this:

     :characters

Each operating system interprets this format differently; in the GNU C library, characters is the name of a file which describes the time zone.

If the TZ environment variable does not have a value, the operation chooses a time zone by default. In the GNU C library, the default time zone is like the specification ‘TZ=:/etc/localtime’ (or ‘TZ=:/usr/local/etc/localtime’, depending on how GNU C library was configured; see Installation). Other C libraries use their own rule for choosing the default time zone, so there is little we can say about them. "

Your BIOS needs to be set UTC not local. You need to use boot code of tz=
See: http://www.tinycorelinux.com/faq.html#timezone
Abstract from the document
Quote
"How To Timezone?

If you live where in an area that has DST then you need to use the full specific ation for the tz variable. Indicating both the begin and end of DST.

For example mine tz boot code is: tz=PST+8PDT,M3.2.0/2,M11.1.0/2

In the above DST clause PDT,M3.2.0/2,M11.1.0/2

M3 = month nbr (1-12)
2 = week nbr (1-5)
0 = day of week (0-7)
/2 = time

So for PDT it begins March second Sunday at 2AM and end November first Sunday at 2AM. "

QUESTIONS
01 In light of the the guidance from the gnu manual and roberts, does the bootcode tz=  (I.e. blank) need to be specified?  Is there a difference between using a blank value and not using this bootcode?

02 If the bootcode is required to account for DST in the UK, how is it constructed using the example given in the TC FAQ?  I can understand the month, week, day and time elements but what is the meaning of PST+8PDT?  What are the equivalent values for the UK?

03 As the timezone example given in the TC FAQ corresponds to second format given in the gnu manual is this the only method used by TC?  If so what is seen to be the disadvantage of using "the most common format" - method 3?
   
Title: Re: ntpclient Blanks Screen
Post by: curaga on February 18, 2010, 06:06:15 AM
We use the TZ var because it saves space. If you wish to have DST automatically without having tz set to anything, just grab your timezone file from tzdata.tcz, copy as /etc/localtime, add /etc/localtime to backup.
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 18, 2010, 08:37:44 AM
We use the TZ var because it saves space. If you wish to have DST automatically without having tz set to anything, just grab your timezone file from tzdata.tcz, copy as /etc/localtime, add /etc/localtime to backup.
It is not that I am trying to avoid configuring tz manually, rather it is the difficulty of using the information available to establish a suitable setting. 

A further indication of this is that tzdata.tcz contains no description of what the extension does or how to use it.  This is eased by the guidance you provided in your previous post, without which it would be difficult to use the extension even though it it marked with a status of testing.

Thanks for the advice.
   
Title: Re: ntpclient Blanks Screen
Post by: curaga on February 18, 2010, 10:47:11 AM
It's true that we lack documentation in many areas.
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 18, 2010, 11:25:20 AM
...just grab your timezone file from tzdata.tcz, copy as /etc/localtime, add /etc/localtime to backup.
When this has been done is it then safe to delete /usr/share/zoneinfo and all the files it contains or should tzdata.tcz be uninstalled via Apps Audit?  Uninstalling will presumably also remove the dependencies it installed (bash.tcz and gawk.tcz).  Are these required for use by the timezone file when changing due to Daylight Saving Time triggering?
   
Title: Re: ntpclient Blanks Screen
Post by: curaga on February 18, 2010, 12:16:01 PM
tzdata.tcz can be removed after that. You can keep or remove the dependencies, doesn't matter.
AFAIK nothing special is needed for libc to use that file.

When it's there, all DST changes will be automatic. This is assuming though that the bios clock is set to UTC, as per the linux recommendation.
Title: Re: ntpclient Blanks Screen
Post by: SamK on February 20, 2010, 03:59:43 AM
As a result of the many posts in this thread I thought a summary might be useful.

The objective is to use a remote timeserver to set the system time and date, and BIOS time and date, of a local PC in the United Kingdom of Great Britain which uses Daylight Saving Time (DST).

During testing screen-blanking occurred if the system and BIOS clocks were sufficiently out-of-sync hence the setting of both clocks to counter an unreliable BIOS clock.



SET SYSTEM AND BIOS DATE AND TIME
in /opt/bootlocal.sh

if using ntpclient
Code: [Select]
# Set the system and BIOS date and time
#   Timezone (tz) must be UTC
#   Daylight Saving Time (DST) must be provided by the London timezone file from tzdata.tcz copied as /etc/localtime
while ! nslookup pool.ntp.org &>/dev/null ; do sleep 1 ; done ; ntpclient -s -h pool.ntp.org ; hwclock -w


if using getTime.sh
Code: [Select]
# Set the system and BIOS date and time
#   Timezone (tz) must be UTC
#   Daylight Saving Time (DST) must be provided by the London timezone file from tzdata.tcz copied as /etc/localtime
while ! nslookup time-nw.nist.gov &>/dev/null ; do sleep 1 ; done ; getTime.sh ; hwclock -w


DAYLIGHT SAVING TIME


Create a backup and reboot the PC.
   
Title: Re: ntpclient Blanks Screen
Post by: maro on February 20, 2010, 06:38:45 PM
Nice summary, SamK!!

I'd just like to expand a bit on the use of the 'tz' boot code to specify the local time zone (including the provision of daylight saving information). Please note that this is an alternative to copying a file to '/etc/localtime' and not to be used in conjunction with that approach. The following is merely my way of describing what is defined in the first link of Robert reply #15 (see above):

(1) In the case of no daylight saving the boot code simply needs the name of the timezone and the offset to UTC. Example India:
    tz=IST-5:30    i.e. India is 5h30 "ahead" of UTC, AFAIK 'IST' stands for "India Standard Time"

(2) Things get a bit more varied with daylight saving. The TZ definition now also adds the name of the timezone during daylight saving and the details when daylight saving starts and ends. Example France:
    tz=CET-1CEST,M3.5.0,M10.5.0/3  with the following components:
       CET                          timezone name during standard time (i.e. "Central European Time")
          -1                        offset during standard time (i.e. 1h "ahead")
            CEST                    timezone name during daylight saving (i.e. "Central European Summer Time")
                  3                start of daylight saving: the month (i.e. March)
                    5              the week (i.e. last)
                      0            the day (i.e. Sunday)
                         10        end of daylight saving: the month (i.e. October)
                            5      the week (i.e. last)
                              0    the day (i.e. Sunday)
                                3  the time (i.e. 03:00:00)
Please note: Since no time is specified for the start of CEST the default value of 02:00:00 will be used.

I hope this breakdown makes it easier to understand the specification mentioned above. It's actually less intimidating once you got the general idea.

If your are still not keen to create your very own TZ string you can cheat by taking a peek in the (binary) zoneinfo files of the tzdata.tcz extension. Please note that in the following steps (using London as an example) the extension gets merely downloaded (to the home directory), extracted and right away removed again. So nothing remains afterwards. Let's face it, you probably need to find out your local TZ definition only a few times in your life (e.g. when you move or your daylight saving timeframe changes):
Code: [Select]
tc@box:~$ tce-fetch.sh tzdata.tcz
tc@box:~$ mkdir ext
tc@box:~$ sudo mount tzdata.tcz ext -t squashfs -o loop,ro,bs=4096
tc@box:~$ find ext/usr/local/share/zoneinfo -type f -name London | xargs tail -1
GMT0BST,M3.5.0/1,M10.5.0
tc@box:~$ umount ext
tc@box:~$ rm -rf ext tzdata.tcz
If you are not sure about the city to specify in the 'find' command, have a look around the files in the 'zoneinfo' directory (and it's sub-directories) and just use 'tail -1 FILE' for the FILE that best fits your needs.
Title: Re: ntpclient Blanks Screen
Post by: grisxa on August 11, 2010, 03:15:09 AM
BTW, Sun Java (I use version 1.6.0-20) doesn't understand such syntax. It only takes first part from $TZ (CET in the example) and omits the daylight saving part. So, i've unset TZ and returned to /etc/localtime file.
Then Java compares /etc/localtime against files in /usr/share/zoneinfo/ and if a match was found it looks for a file with the same name in it's own zoneinfo database - jre/lib/zi/.
Title: Re: ntpclient Blanks Screen
Post by: Guy on June 06, 2011, 01:56:39 AM
I copied time zone info to wiki

http://wiki.tinycorelinux.net/wiki:time_zone
Title: Re: ntpclient Blanks Screen
Post by: Rich on June 06, 2011, 09:17:03 AM
Hi Guy
You might want to remove the following line from the wiki

Quote
The following is merely my way of describing what is defined in the first link of Robert reply #15 (see above):

What, no colored text? (Just kidding).

Title: Re: ntpclient Blanks Screen
Post by: Guy on June 06, 2011, 09:31:02 AM
Removed that line. I had previously just copied the page as it was.

At some time in the future, the entire page could be edited, to look like a wiki page.

Only a small proportion of people contribute to the wiki. It would be nice if more did.

When useful info comes along, it is a good idea to put it on the wiki.

I have also found that some people improve pages that are there, but do not create new ones. So just by putting that page there, someone is likely to try to improve it.
Title: Re: ntpclient Blanks Screen
Post by: tinypoodle on June 06, 2011, 12:13:16 PM
Removed that line. I had previously just copied the page as it was.

At some time in the future, the entire page could be edited, to look like a wiki page.

Only a small proportion of people contribute to the wiki. It would be nice if more did.

When useful info comes along, it is a good idea to put it on the wiki.

I have also found that some people improve pages that are there, but do not create new ones. So just by putting that page there, someone is likely to try to improve it.

+1

Or should I have said:"Guilty as charged!"?   :P

Reminder: At current, forum login credentials can be used for wiki login.
Title: Re: ntpclient Blanks Screen
Post by: redwolf on November 02, 2011, 10:10:40 PM
We use the TZ var because it saves space. If you wish to have DST automatically without having tz set to anything, just grab your timezone file from tzdata.tcz, copy as /etc/localtime, add /etc/localtime to backup.

I realize this is an older thread, and I apologize ahead of time if this is not the most appropriate place to post, but I have just tried exactly what you've described here, yet date still outputs UTC time rather than my local time zone's time after backing up and rebooting.

1. cp /usr/local/share/zoneinfo/US/Pacific /etc/localtime
2. add etc/localtime to /opt/.filetool.sh
3. backup
4. reboot
5. date outputs UTC rather than Pacific time
Title: Re: ntpclient Blanks Screen
Post by: curaga on November 03, 2011, 06:43:00 AM
I think I was missing one step, a bootcode of "tz=/etc/localtime". It should work without, but I confirm this is needed.

edit: our bug. Until we have a fix, either set the tz bootcode like that, or add "unset TZ" to your .profile.
Title: Re: ntpclient Blanks Screen
Post by: roberts on November 03, 2011, 07:03:04 AM
@Redwolf, if you are in Pacific Time Zone why bloat up your system with tzdata when using the simple version of TZ works !

The specific example for the Pacific Time Zone has been in the FAQ since day 1.
http://distro.ibiblio.org/tinycorelinux/faq.html#timezone (http://distro.ibiblio.org/tinycorelinux/faq.html#timezone)

tz=PST+8PDT,M3.2.0/2,M11.1.0/2
Title: Re: ntpclient Blanks Screen
Post by: roberts on November 03, 2011, 07:28:18 AM
Not a bug.  The tzdata.tcz extension's info file explains how to set the TZ boot option for use with this extension.
Title: Re: ntpclient Blanks Screen
Post by: redwolf on November 03, 2011, 10:46:26 AM
Thank you both for clarifying.  Setting TZ=/etc/localtime was all that was needed. 

@roberts, the only reason I tried doing it with tzdata was because of this excerpt from manual/libc/TZ-Variable.html.

Quote
In POSIX.1 systems the value of the TZ variable can be in one of three formats. With the GNU C library, the most common format is the last one, which can specify a selection from a large database of time zone information for many regions of the world. The first two formats are used to describe the time zone information directly, which is both more cumbersome and less precise.

Specifying via tz=PST+8PDT,M3.2.0/2,M11.1.0/2 certainly doesn't seem any more cumbersome; it was the bit about being less precise that led me to try the tzdata approach.  Honestly, I'm not even sure how or why or how significant it is. Though, it sounds like part of it may have to do with dates/times in the past.

Quote
The schedule of Daylight Saving Time in any particular jurisdiction has changed over the years. To be strictly correct, the conversion of dates and times in the past should be based on the schedule that was in effect then. However, this format has no facilities to let you specify how the schedule has changed from year to year. The most you can do is specify one particular schedule—usually the present day schedule—and this is used to convert any date, no matter when. For precise time zone specifications, it is best to use the time zone information database

Maybe I'm making a mountain out of a mole hill? 
Title: Re: ntpclient Blanks Screen
Post by: roberts on November 03, 2011, 11:46:33 AM
FWIW. Using the boot code with specifics, e.g.,  tz=PST+8PDT,M3.2.0/2,M11.1.0/2
is not only much much smaller, it empowers the user to change when needed the Daylight Savings offset.

Using the tzdata means if the DST offset is changed, the user will either have to create/update their corresponding data file, or, worse wait for an update from the extension maker. zic comes to mind!

That is two benefits of using the default, i.e., avoiding the extension.

It is understandable if a user is located which is not well served by TZ specifics, although I can't think of any.

But as with most things tinycore it is your decision on what works best for you.

Glad to hear that you have it working.
Title: Re: ntpclient Blanks Screen
Post by: Greg Erskine on May 31, 2014, 04:55:16 PM
Nice summary, SamK!!

If your are still not keen to create your very own TZ string you can cheat by taking a peek in the (binary) zoneinfo files of the tzdata.tcz extension. Please note that in the following steps (using London as an example) the extension gets merely downloaded (to the home directory), extracted and right away removed again. So nothing remains afterwards. Let's face it, you probably need to find out your local TZ definition only a few times in your life (e.g. when you move or your daylight saving timeframe changes):
Code: [Select]
tc@box:~$ tce-fetch.sh tzdata.tcz
tc@box:~$ mkdir ext
tc@box:~$ sudo mount tzdata.tcz ext -t squashfs -o loop,ro,bs=4096
tc@box:~$ find ext/usr/local/share/zoneinfo -type f -name London | xargs tail -1
GMT0BST,M3.5.0/1,M10.5.0
tc@box:~$ umount ext
tc@box:~$ rm -rf ext tzdata.tcz
If you are not sure about the city to specify in the 'find' command, have a look around the files in the 'zoneinfo' directory (and it's sub-directories) and just use 'tail -1 FILE' for the FILE that best fits your needs.

Hi,

I was just using this code that I found in the Timezone wiki.
http://wiki.tinycorelinux.net/wiki:time_zone

I have a couple of questions.

1. Should I be appending to this old thread. It makes sense to me but the forum warns me about it being greater than 120 days old? (Oops, just saw the title once I posted, I got there via search)
2. Should I edit the wiki directly?
3. Are 4, 5, 6 piCore specific?
4. ext/usr/local/share/zoneinfo should be ext/usr/local/etc/zoneinfo
5. umount ext should be sudo umount ext
6. tzdata.tcz contains all the Australian capital cities except Sydney

regards
Greg