Tiny Core Linux

Tiny Core Base => TCB News => Release Candidate Testing => Topic started by: roberts on November 22, 2009, 06:50:18 AM

Title: tinycore_v2.6rc4
Post by: roberts on November 22, 2009, 06:50:18 AM
The Fourth Release Candidate of v2.6 (tinycore_2.6rc4.iso), is now posted and ready for testing only.
http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/2.x/release_candidates

tinycore_2.6rc4.iso
tinycore_2.6rc4.iso.md5.txt

Change log for v2.6rc4:

* Updated rebuildfstab to reflect removals and better handle reported race condition.
* Updated tc-restore.sh. restore boot option overrides default backup location fixed bug in rc3.

Notes:
You must have your tcz collection updated, i.e., all squashfs and all with 4096 block size.

Be sure to update your kernel..

The distribution files are also availble:
http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/2.x/release_candidates/distribution_files

Please check md5sums after downloading..
Title: Re: tinycore_v2.6rc4
Post by: philip on November 22, 2009, 07:56:06 AM
My two issues have been resolved:
 (1) waitusb boot code is no longer needed to boot from netbook's built-in SSD
 (2) information in backup file mydata.tgz is correctly restored
Now I'll just use 2.6rc4 as usual. If anything else comes up, I'll write back.
Thank You.
Title: Re: tinycore_v2.6rc4
Post by: roberts on November 22, 2009, 09:42:12 AM
Great to hear. Thanks for the feedback and your help testing the coming new release.
Title: Re: tinycore_v2.6rc4
Post by: thane on November 22, 2009, 11:03:54 AM
OK, I booted TC 2.6 rc4 with waitusb=5 (same as I've done for all previous TC versions). As above I'm booting off a CD with TCE and mydata.tgz on a USB stick directly under root (sda1).

Extensions loaded correctly and settings were restored, even though I have the mydata file under sda1 rather than in the tce directory.

Looks good. Will follow philip's example and try my normal usage.
Title: Re: tinycore_v2.6rc4
Post by: bmarkus on November 22, 2009, 11:25:00 AM
It looks good. HAL works fine with the new blkid, libblkid, and libuuid without the former hal_support extension. Till now I did not find any problem. Good work!
Title: Re: tinycore_v2.6rc4
Post by: jur on November 22, 2009, 11:40:25 PM
in this rc, 'mount' no longer accepts the -L flag.
Title: Re: tinycore_v2.6rc4
Post by: roberts on November 22, 2009, 11:54:22 PM
True, we are no longer using the GNU mount. If that feature is needed use an extension.
Title: Re: tinycore_v2.6rc4
Post by: thane on November 23, 2009, 01:24:21 AM
When booting TC 2.6 rc4 I got an error when loading extensions:

mount: mounting /dev/loop27 on /tmp/tcloop/flash10 failed: Invalid argument occured while loading flash10.tcz

The boot continued and backup restored, but some of the extensions were not loaded.

The extensions load correctly under 2.5, and I had no problems running 2.6 with another set of extensions that doesn't include flash10.tcz.

edit: also did an appsaudit and sudo tce-update under 2.5, and as far as I can tell from this my extensions are up to date and have all needed dependencies.
Title: Re: tinycore_v2.6rc4
Post by: bmarkus on November 23, 2009, 01:35:33 AM
I have seen this testing 2.6rc2x and 2.6rc3 but never with 2.6rc4
Title: Re: tinycore_v2.6rc4
Post by: thane on November 23, 2009, 02:04:57 AM
OK, it's apparently resolved. Booted TC 2.5, deleted flash10.tcz and re-ran getflash10.tcz, recreating the flash10.tcz extension.This now boots correctly under TC 2.6 rc4.

Should fiddle with things a little more before I post...
Title: Re: tinycore_v2.6rc4
Post by: bmarkus on November 23, 2009, 02:30:44 AM
When I'm testing an rc, always format an USB drive, install the rc and download extensions from the repo. And do not copy anything from another source :) At least in the beginning...
Title: Re: tinycore_v2.6rc4
Post by: meo on November 23, 2009, 06:33:35 AM
Hi guys!

First of all I want to make clear that this isn't a major issue, since tinycore 2.6 rc4 boots properly. It is mostly an annoying thing that occurs at the final of the boot process. I get this message:  cat: can't open '/etc/sysconfig/icons': no such file or directory . I just wonder what may cause that message since it doesn't prevent tinycore to boot properly. I use noicons as boot code.

Have fun and thank you for this nice cut of tinycore,
meo
Title: Re: tinycore_v2.6rc4
Post by: roberts on November 23, 2009, 07:30:12 AM
meo, I don't see that message booting with "base norestore noicons"

I suspect that perhaps you need to check two files in yor home directory for possible update

.profile
.xsession
Title: Re: tinycore_v2.6rc4
Post by: meo on November 23, 2009, 10:01:45 AM
Hi Robert!

Everything is made from scratch so I don't think any change in those files would matter. I have a pretty strange multiboot setup (hacked beyond recognition with 25 boot options), so I think that might explain things. I just wanted to see if it was something simple I could do about it but it doesn't affect the system so it's no big deal. Thanks for responding!

Have fun and keep up the progressive work on tinycore,
meo
Title: Re: tinycore_v2.6rc4
Post by: jpeters on November 23, 2009, 11:46:25 AM
'/etc/sysconfig/icons': no such file or directory . I just wonder what may cause that message since it doesn't prevent tinycore to boot properly. I use noicons as boot code.

.xsession removes errors, but you'll see the message whenever you load an extension given that you booted noicons, so no icons folder exists.


Title: Re: tinycore_v2.6rc4
Post by: roberts on November 23, 2009, 12:53:22 PM
OIC. Thanks. Will clean up that up.