Tiny Core Linux

Tiny Core Extensions => TCE News => TCE 1.x => Topic started by: curaga on December 31, 2008, 12:43:13 PM

Title: Wine
Post by: curaga on December 31, 2008, 12:43:13 PM
Wine with 3d support uploaded, both tce and tcz, and a dev extension too.

It's the latest dev build, 1.1.11. On base TC you can run 2d windows apps, to get 3d you'll need to properly configure and run Xorg. Sound is working with OSS. Did not test networking.

I tested with Chip's Challenge, ogldemo.exe, and some small DX9 games. All worked great. Now, let's all go download C&C: Red Alert because it's a great game, freeware, and platinum rated in Wine ;)

If anyone's interested in why even software 3d is not possible in Xvesa, it's because in Mesa 7.2 the software driver is no longer just the Mesa xlib renderer, it's a DRI driver and needs X server support (swrast_dri.so). Mesa still has the lib-only software-only OpenGL renderer, but it must be built separately. No one has yet done this, as the benefits are quite small.
Title: Re: Wine
Post by: tobiaus on December 31, 2008, 03:08:49 PM
ohh, this is weird. not only can i still not find gimp2 (gimp.tce is there) in appbrowser (unless i reboot, presumably) but i can't find wine in appbrowser or, here http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/tce/

i tried closing the browser, and i did a text search on the page for everything by "curaga" and "wine" itself. i've also looked for a place that configures the mirror used in appbrowser, is it not coded in some kind of config like mydsl?
Title: Re: Wine
Post by: curaga on December 31, 2008, 03:20:30 PM
D'oh. Sorry, we're all still adjusting to the new server at ibiblio; we have to manually generate the web page now. I'll go do it right away :)

I'm not sure if regenerating the web page will help the appbrowser.

BTW to have a direct view of the extensions use ftp instead of http, ie ftp://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/tce/
Title: Re: Wine
Post by: tobiaus on December 31, 2008, 04:18:12 PM
i found /opt/.tcrc and changed protocol to ftp. appbrowser still worked but still no gimp2 or wine so i found /usr/bin/tce-fetch.sh and changed the awk line that gets the protocol from .tcrc and changed it to `ftp` but then appbrowser didn't work. i changed `ftp` to just ftp and appbrowser worked again.

so now it's downloading from ftp instead of http (and still no wine or gimp!) this is bizarre. i'm going to know how to recompile the kernel before i figure out why i can't see wine.tcel. edit: i booted from usb, they're still not in appbrowser. i try things like tce and tcz, can't find gimp or wine, but it's not something rebooting seems to change. ftp://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/tce/wine-gl.tcel.info does not list the deps... do all the wine packages (i can get them from ff) start "wine-" something?
Title: Re: Wine
Post by: curaga on January 01, 2009, 12:53:06 AM
Yeah, they all start wine- and there are only standard and -dev (I'm not even sure if -dev is usable to anyone but those wanting to link their win app with winelib). See the .dep file for the dependencies (only openssl for wine; xorg has it's own if you need 3d)
Title: Re: Wine
Post by: tobiaus on January 01, 2009, 11:31:04 AM
thanks so much for this, i don't use wine for many things, but my install of wine in xubuntu is borked. i can use wine on that machine from the usb tinycore :) and i'm using it in ram right now.

as for the mystery with appbrowser (http://forum.tinycorelinux.net/index.php?topic=351.0), edit: nevermind :) "the ones you create yourself" and occasionally the ones on the server ;)
Title: Re: Wine
Post by: alex on September 14, 2009, 01:29:45 PM
To Curaga:

Hi would you please upload a WINE tcz extension complied against TC2.x I have issues with the actual version in TC2.x


Title: Re: Wine
Post by: curaga on September 27, 2009, 10:41:42 AM
I'm afraid I don't have the time right now.

What issues are you having?
Title: Re: Wine
Post by: alex on October 03, 2009, 07:06:04 PM
Hi, please see this post:

http://forum.tinycorelinux.net/index.php?topic=2809.0 (http://forum.tinycorelinux.net/index.php?topic=2809.0)

Now I compiled WINE 1.1.30 under TC2.4_rc3 but the same error message remains.