Tiny Core Linux

Tiny Core Base => Corepure64 => Topic started by: reg on May 13, 2022, 09:41:01 PM

Title: Library issue with samba
Post by: reg on May 13, 2022, 09:41:01 PM
When I try and run smbclient I get:

smbclient: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory

I have looked over the net and at the packages people suggest provide libtinfo.so.6 and so far I have not been able to find one with tce-ab.  Any help would be appreciated, and the dependency should probably be added.
Title: Re: Library issue with samba
Post by: gadget42 on May 14, 2022, 12:48:34 AM
this was one of the results when i searched the forum for libtinfo.so.6:

http://forum.tinycorelinux.net/index.php/topic,23670.msg148408.html#msg148408
Title: Re: Library issue with samba
Post by: Juanito on May 14, 2022, 01:00:15 AM
I'll take a look at recompiling the samba extension - in the meantime you could probably use this: http://tinycorelinux.net/10.x/x86_64/tcz/ncurses.tcz
Title: Re: Library issue with samba
Post by: reg on May 14, 2022, 08:30:47 AM
Thank you all.  If you rebuild samba please let me know.  I am a bit shy about adding stuff from past releases because I have this fear that I will need something later on that requires the current release version and there will be a mess  It may be from playing with python as of late but I am now paranoid of version tangles.
Title: Re: Library issue with samba
Post by: Juanito on May 14, 2022, 08:37:48 AM
Samba is built, I’ll package it tomorrow.
Title: Re: Library issue with samba
Post by: Juanito on May 15, 2022, 01:06:06 AM
Updated samba posted - not extensively tested
Title: Re: Library issue with samba
Post by: reg on May 15, 2022, 12:49:29 PM
Thank you!  I see it got quite a bit heavier and I had to add /usr/local/lib/samba to /etc/ld.so.conf but so far it seems happy.  Thank you!
Title: Re: Library issue with samba
Post by: Juanito on May 15, 2022, 01:16:21 PM
Unfortunately an update usually means an increase in size, but you shouldn’t have to modify ld.so.conf