Tiny Core Linux

Tiny Core Base => TCB Tips & Tricks => Topic started by: diode84 on September 11, 2020, 02:44:43 AM

Title: Having problems installing
Post by: diode84 on September 11, 2020, 02:44:43 AM
Hello
Has anyone on easy way to install TC base to HDD. I have installed it from USB before but now am having no luck.
Help appreciated.
Thanks
diode84
Title: Re: Having problems installing
Post by: Juanito on September 11, 2020, 04:45:50 AM
The tc-install extension works equally well for hd as usb stick installations - you need to be careful that you specify the correct hd/partition though.
Title: Re: Having problems installing
Post by: tinycorelinux on September 11, 2020, 05:11:16 AM
Can you explain your problems in detail?
Title: Re: Having problems installing
Post by: diode84 on September 11, 2020, 06:38:56 AM
I am installing to a 10ZIG thinclient, Intel atom E3825, 1.33 ghz, dual core, 2gb mem, 4gb flash drive,
I get as far as boot and am given options core or unknown os, neither do anything.
What am I doing wrong.
Title: Re: Having problems installing
Post by: jazzbiker on September 11, 2020, 07:17:31 AM
Hi, diode84!

Are You sure You are running legacy BIOS boot? As far as I understand, tc-install don't deal with UEFI...
Title: Re: Having problems installing
Post by: diode84 on September 11, 2020, 07:21:10 AM
I didn't think I was on uefi.
I have checked and it is set to legacy bios. It is a very strange bios anyway.
Title: Re: Having problems installing
Post by: tinycorelinux on September 11, 2020, 07:46:52 AM
Your system has been installed on the hard disk via USB, but it can't boot properly, right? Or is your system not installed at all, but only booted from USB? Just going to install it on your hard drive?
Title: Re: Having problems installing
Post by: diode84 on September 11, 2020, 08:00:12 AM
It should be installed on the hdd from the usb key.
Title: Re: Having problems installing
Post by: tinycorelinux on September 11, 2020, 08:16:09 AM
Have you installed the system on your hard drive, but the boot menu doesn't appear when you boot?
....
But so far, I don't know if you have a problem with the installation, or if you have a problem with your system boot. Because you provide so little information, it is difficult to get useful and timely help from others.
...
Title: Re: Having problems installing
Post by: diode84 on September 11, 2020, 08:40:31 AM
I need to ask a question:
In the boot option list I have put in:
vga=791
Question is what is correct next option exactly, install x gui or what.
And do I need TCE/CDE directory.
Title: Re: Having problems installing
Post by: diode84 on September 11, 2020, 10:24:56 AM
Answered that Myself. Also got a perfect install to another thinclient, single core.
There is definitely a problem installing to the 10ZIG dual core.
Next question.
Can I get an image file of Tiny Core that I could transfer to the 10ZIG directly. I did this with DietPi and it was fine.
Title: Re: Having problems installing
Post by: diode84 on September 12, 2020, 07:19:43 AM
Found the problem, the 10ZIG was failing and will not boot anything at all now. Its a bin job.
I have no problems with anything else so thanks for the help.
All the best
diode84