Tiny Core Linux

Tiny Core Base => CorePlus => Topic started by: uppi on October 09, 2019, 01:37:37 AM

Title: No network connection
Post by: uppi on October 09, 2019, 01:37:37 AM
what am i trying to do is to load coreplus on bochs. it loads fine. athough no ethX appears. ifconfig shows only lo interface.
i've also tried wait 5 seconds, it does not help.
damn small linux with the same config of bochs has connection.
what should i do to make it work in tinycore, coreplus?
Title: Re: No network connection
Post by: neonix on October 11, 2019, 08:55:06 AM
Hello, uppi

What exactly Tiny Core Plus version you use, and what version of  Bochs you use?
What do you get after this commands?
Code: [Select]
dmesg | grep net
dmesg | grep eth0

If you don't get anything you can also use this commands in Damn Small Linux.
Title: Re: No network connection
Post by: uppi on October 14, 2019, 10:12:01 AM
Thank you for you reply!

I've downloaded current CorePlus. I would like to mention that I've also tried Core, dCore-Xenial and dCore-stretch with the same result.
The only Bochs is able to start on my android device is Lyubomyr Lisen's Bochs from Google Play Store. Network card is set to Realtek RTL8029 (PCI). CorePlus commands results
Code: [Select]
dmesg | grep net
usbcore: registered new interface driver ums-onetouch
Initializing XFRM netlink socket

Code: [Select]
dmesg | grep eth0does not give anything

I see a bunch of /sbin/modprobe kills messages during the CorePlus loading process, including
Code: [Select]
udevd[122]: timeout: killing '/sbin/modprobe -bv dmi:bvnTheBochProject:bvrBochs:bd01/01/2007:svn:pn:pvr:cvn:ct1:cvr:' [202]
udevd[122]: '/sbin/modprobe -bv dmi:bvnTheBochProject:bvrBochs:bd01/01/2007:svn:pn:pvr:cvn:ct1:cvr:' [202] terminated by signal 9 (Killed)
Might it be connected with network inaccessibility?

Does CorePlus inform me about discovered network device, the way it DSL does?
DSL says "Network device eth0 detected, DHCP broadcasting for IP."
DSL output:
Code: [Select]
dmesg | grep net
<4>Initializing RT netlink socket
<6> http://www.scyld.com/network/ne3k-pci.html

dmesg | grep eth0
<4>eth0: RealTek RTL-8029 found at 0xc020 IRQ 11, D0:C4:00:00:00:00.
Title: Re: No network connection
Post by: uppi on October 20, 2019, 10:03:36 PM
Is it possible, that the Bochs i am using is too old? I have also tried alpine, there are no network connection either.
Does anybody start CorePlus in Bochs?
Title: Re: No network connection
Post by: vinceASPECT on October 21, 2019, 06:24:46 AM

iT WILL  be some hardware abstraction
issue and the Host OS  Layers through
to the drivers emulations.

You didn't say what the host OS is.

always check all basic compatibility(s).

BOCHS of  wealth on google  (always worth a try)