Tiny Core Linux

dCore Import Debian Packages to Mountable SCE extensions => General dCore Talk => Topic started by: A Guy on August 30, 2019, 07:39:59 AM

Title: Strange Ethernet Question
Post by: A Guy on August 30, 2019, 07:39:59 AM
So let me start with , I am booting dcore 64 bit using PXE boot.
So right off the bat I am in the weeds, but I will throw this out in case there are smarter people out there.

So the issue is I can get to my boot prompt LONG before the network is working.
Now , of course, I know the network exists and everything because I am booting from it. PXE needs a DHCP resource to get an ip address and transfer the lpxelinux.0 boot image and such.

So, after the PXE boot, then Linux comes up , grabs control of the same Ethernet controller and gets an IP address (again) and then DNS information. This seems to happen 12 seconds after I am already booted (at an ash prompt)

So I guess my question is , can I get the Ethernet to come up faster? This is a fairly esoteric request, but I am just wondering if I can somehow push network init earlier in the boot process perhaps.
Maybe in a boot script I need to execute a PCI reset to the controller, so there is no old configuration info hanging around from PXE boot.

Anyone?
Tony
Title: Re: Strange Ethernet Question
Post by: neonix on August 30, 2019, 10:59:30 AM
Hi A Guy

Yes, I also noticed that getting ip address through DHCP in TinyCore is quite long. I don't know is it only with TinyCore or other systems.

You can use static ip address if your router (or other device you use for  PXE boot) allow you for this.