Tiny Core Linux

Tiny Core Base => Raspberry Pi => piCore Test Releases => Topic started by: bmarkus on March 20, 2016, 02:23:23 PM

Title: piCore-7.1beta3 released
Post by: bmarkus on March 20, 2016, 02:23:23 PM
piCore-7.1beta3 released. Changes:

- kernel updated to 4.1.20
. micropython updated
. glibc updated to 2.23
- libstdc++ rebuilt

alsa and wireless kernel moduls added to repo, others will follow depending on test result.

Please try and report your findings here.

Download:

http://www.tinycorelinux.net/7.x/armv6/test_releases/
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 20, 2016, 05:39:37 PM
I can get this to boot.

get a VFS:Unable to mount root fs on unknown-block(1,0)

I had never booted my rpi3, so I dumped Raspbian on this card, and the system booted fine.

Title: Re: piCore-7.1beta3 released
Post by: jncl on March 21, 2016, 07:47:36 AM
Hi Béla,

   I can confirm that all my previously mentioned WiFi dongles now work with this beta version.

   I can confirm that the image boots on the following RPi's: A/B/B+/2B. It doesn't boot on a Zero.
 
   I can confirm that all the dmesg lines
Code: [Select]
disagrees about version of symbol module_layouthave now gone on all booting RPi's.
 
HTH
   Jon
Title: Re: piCore-7.1beta3 released
Post by: jncl on March 21, 2016, 07:50:04 AM
Hi Béla,

    Can I request the Kernel sources etc for 4.1.20, I need them to build a Kernel module for a WiFi dongle I have, which uses the 8192eu chipset.

Thanks
    Jon
Title: Re: piCore-7.1beta3 released
Post by: bmarkus on March 21, 2016, 09:08:47 AM
Hi Jon

thanks for feedback. Regarding Zero boot issue, edit config.txt and change [PI1] to [PI0]. Just guessing, it may help.

Béla
Title: Re: piCore-7.1beta3 released
Post by: jncl on March 21, 2016, 09:49:59 AM
Hi Béla,

    Using [PI0] works  :). I also moved the cmdline cmdline.txt line after [ALL], removing it from the other entries, and that works as well.

Thanks

    Jon
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 21, 2016, 10:13:14 AM
I can get this to boot.

get a VFS:Unable to mount root fs on unknown-block(1,0)

I had never booted my rpi3, so I dumped Raspbian on this card, and the system booted fine.

This was supposed to say "can't"   I did check that we are using the same sdcard driver(default).   And I did try the other dtoverlays for selecting a different driver.   I normally don't use 32G UHS-1 cards for my pis, but I used up all my smaller/slower cards.    I'll try a different card tonight.

jncl.....did you test on a PI3?
Title: Re: piCore-7.1beta3 released
Post by: jncl on March 21, 2016, 10:45:35 AM
Hi Paul_123,

  I don't yet have a Pi3 to test.

Jon
Title: Re: piCore-7.1beta3 released
Post by: Gerrelt on March 21, 2016, 11:20:33 AM
Hi Béla,

I've just installed piCore7.1beta3 as a squeezelite player using my tutorial, and everything works perfectly!
The previous WiFi problems with beta2 are gone.

Thanx!  8)

Greetings,
   Gerrelt.
Title: Re: piCore-7.1beta3 released
Post by: bmarkus on March 21, 2016, 11:23:07 AM
New piCore-7.1beta3 SD card image uploaded, boot issue on Zero fixed.
Title: Re: piCore-7.1beta3 released
Post by: bmarkus on March 21, 2016, 11:37:03 AM

    Can I request the Kernel sources etc for 4.1.20, I need them to build a Kernel module for a WiFi dongle I have, which uses the 8192eu chipset.


Done
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 21, 2016, 04:37:00 PM
Bela,

I downloaded the latest image and burned......still won't boot on a rpi3.   I can't believe I missed this, I had looked at it 10 times last night.    This is the config.txt

Code: [Select]
# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

[PI0]
initramfs 7.1beta3.gz followkernel
kernel kernel4120.img

[PI1]
initramfs 7.1beta3.gz followkernel
kernel kernel4120.img

[PI2]
initramfs 7.1beta3v7.gz followkernel
kernel kernel4120v7.img

[PI3]
initramfs 7.1beta2v7.gz followkernel
kernel kernel4120v7.img

The initramfs for the PI3 is wrong.    Fixed and it boots on a pi3.....now checking the rest.


Edit: Buitin wifi connects.....   iperf3 shows about 25Mbit transfer rate, which seems about par for the coarse for this broadcomm chipset/driver.

Title: Re: piCore-7.1beta3 released
Post by: bmarkus on March 21, 2016, 11:04:05 PM
Quote
The initramfs for the PI3 is wrong.    Fixed and it boots on a pi3.....now checking the rest.


Thanks, fixed. New image uploaded.
Title: Re: piCore-7.1beta3 released
Post by: bmarkus on March 22, 2016, 12:55:13 AM
beta3 looks ok, I will add kernel module TCZ's to repo in next days.
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 23, 2016, 08:14:28 AM
Bela,

Not sure if you saw

https://github.com/raspberrypi/linux/issues/1355

Also,

Might want to check this issue related the the License for the Broadcom Firmware files
https://github.com/raspberrypi/linux/issues/1325


Title: Re: piCore-7.1beta3 released
Post by: bmarkus on March 24, 2016, 12:59:58 AM
Thanks Paul, it is an upstream issue, not our :)
Title: Re: piCore-7.1beta3 released
Post by: gavinmc42 on March 24, 2016, 02:06:35 AM
Tried wifi stuff on Pi3 again
Got beta3, wrote it to USB.
Used gparted to increase the 12MB second partition up to 40MB.
Booted it, waited for ssh key stuff, opensshed in and ran this
tce-load -wi firmware-brcmfmac43430.tcz
filetool.sh -b
rebooted then tried to install wifi.tcz

Code: [Select]
tce-load -wi wifi.tcz
wifi.tcz.dep OK
wireless_tools.tcz.dep OK
wpa_supplicant.tcz.dep OK
Downloading: wireless-4.1.20-piCore_v7+.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wireless-4.1.20-piCo 100% |***************************************************|  2560k  0:00:00 ETA
wireless-4.1.20-piCore_v7+.tcz: OK
Downloading: wireless_tools.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wireless_tools.tcz   100% |***************************************************| 49152   0:00:00 ETA
wireless_tools.tcz: OK
Downloading: libnl.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wget: server returned error: HTTP/1.1 416 Requested Range Not Satisfiable
libnl.tcz: FAILED
md5sum: WARNING: 1 of 1 computed checksums did NOT match
Error on libnl.tcz

Same message Gerrelt got, so I installed libnl.tcz

Code: [Select]
tce-load -wi libnl.tcz
Downloading: libnl.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
libnl.tcz            100% |***************************************************|   292k  0:00:00 ETA
libnl.tcz: OK

then this again
tce-load -wi wifi.tcz
........
wifi.tcz: OK

Much better now

Code: [Select]
lsmod
Module                  Size  Used by    Not tainted
i2c_dev                 6020  0
brcmfmac              178947  0
brcmutil                5731  1 brcmfmac
cfg80211              436630  1 brcmfmac
rfkill                 16625  1 cfg80211
bcm2835_rng             1816  0
regmap_mmio             2969  0
bcm2835_gpiomem         3023  0
spi_bcm2835             7252  0
i2c_bcm2708             5002  0
uio_pdrv_genirq         2966  0
uio                     8340  1 uio_pdrv_genirq

Now to test it.

    [EDIT]: Added code tags.  Rich
Title: Re: piCore-7.1beta3 released
Post by: gavinmc42 on March 24, 2016, 03:19:04 AM
Pi 3 wireless working.

sudo iw wlan0 scan  reports stuff

Not exactly sure what did it, tried lots of stuff
http://askubuntu.com/questions/138472/how-do-i-connect-to-a-wpa-wifi-network-using-the-command-line

Something to do with wpa.conf or wpa_supplicant


Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 24, 2016, 02:05:24 PM
Pi 3 wireless working.

sudo iw wlan0 scan  reports stuff

Not exactly sure what did it, tried lots of stuff
http://askubuntu.com/questions/138472/how-do-i-connect-to-a-wpa-wifi-network-using-the-command-line

Something to do with wpa.conf or wpa_supplicant

I didn't have problems

tce-load -w wifi.tcz
wifi.sh
Added wifi.sh -a  to /opt/bootlocal.sh                                                   
filetool.sh -b

Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 24, 2016, 03:16:07 PM
Forgot that you also needed to load

The-load -w firmware-brcmfmac43430.tcz
Title: Re: piCore-7.1beta3 released
Post by: gavinmc42 on March 24, 2016, 05:33:18 PM
wifi.sh did not work for me, maybe because I have a wireless router?

Had to edit /etc/sysconfig/wifi-wpadrv, used nl880211 instead of wext
Made a wpa.conf and used this
wpa_supplicant -B -iwlan0 -c/home/tc/wpa.conf -Dnl80211

Have not done wifi on piCore before.
To many other things to learn, but now that Pi 3's are around it got bumped up the list.
Still much more to learn re command line wifi.
Basically fumbling around in the dark, trying things from google.
Might have fire up a X11 version of piCore and try to see how GUI's do it.

Is there a wifi GUI?
Time to read up
https://en.wikipedia.org/wiki/Wireless_tools_for_Linux#wpa_supplicant.2Fhostapd

wpa_supplicant for client
hostapd for server
So if I want to make a Pi3 lawnmower controlled via wifi I need to learn hostapd?
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 24, 2016, 08:11:58 PM
if you are trying to use hostapd....then that is a whole different beast.

wext driver worked fine for me.

Title: Re: piCore-7.1beta3 released
Post by: gavinmc42 on March 24, 2016, 09:47:56 PM
Yep wext works too.
Not sure what the difference is anyway yet.

I used the wifi to scan local access points
sudo iw wlan0 scan | grep SSID

https://wireless.wiki.kernel.org/en/users/Documentation/iw
iw better than iwconfig?

Probably should move this to a Pi3 wifi post, getting off track?
Title: Re: piCore-7.1beta3 released
Post by: bmarkus on March 24, 2016, 11:11:08 PM
Probably should move this to a Pi3 wifi post, getting off track?

Good idea, it is not really a piCore issue.
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 25, 2016, 02:42:00 PM
Bela,,

When does /opt/shutdown.sh get called?  I was expecting to find it in /etc/init.d/rc.shutdown but it's not there.

I'm back on trying to fix reboot hangs when I'm running on wifi, and have a network share mounted.

I believe what happens is that the wifi connection gets killed before the drive is unmounted......when the system tries to unmount all drives, it has to wait for a timeout to move on.
Title: Re: piCore-7.1beta3 released
Post by: Rich on March 25, 2016, 06:01:29 PM
Hi Paul_123
Take a look in  /usr/bin/exitcheck.sh
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on March 26, 2016, 08:38:00 AM
Hi Paul_123
Take a look in  /usr/bin/exitcheck.sh

Sure enough.....

running "exitcheck.sh reboot" does the trick
Title: Re: piCore-7.1beta3 released
Post by: jncl on March 30, 2016, 08:00:59 AM
Hi Béla,

  I have been trying to use a modified /etc/hosts file and found that it kept reverting after a reboot.

  I eventually tracked down the issue to the /usr/bin/sethostname script which overwrites this file when it is run.

  I have modified the /usr/bin/sethostname script to only change the hostname value in the /etc/hosts file, which works to my satisfaction, and I attach a diff file of these changes.

  If they are acceptable, could the modified /usr/bin/sethostname script be incorporated into the next beta or release candidate build please.

Jon
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on April 12, 2016, 11:08:55 AM
Rpi has moved to Kernel 4.4.y

Is the plan to stay at 4.1.20 for a little bit?
Title: Re: piCore-7.1beta3 released
Post by: bmarkus on April 12, 2016, 11:34:07 AM
Is the plan to stay at 4.1.20 for a little bit?

Good question. In the latest 7.1beta editions GCC, GLIBC was updated to latest upstream and I just updated BusyBox for the not yet released beta4. I will travel in the rest of the month so no new release in April. In May I will make a new release with the current 4.4.x kernel .
Title: Re: piCore-7.1beta3 released
Post by: Paul_123 on April 12, 2016, 12:16:45 PM
Is the plan to stay at 4.1.20 for a little bit?

Good question. In the latest 7.1beta editions GCC, GLIBC was updated to latest upstream and I just updated BusyBox for the not yet released beta4. I will travel in the rest of the month so no new release in April. In May I will make a new release with the current 4.4.x kernel .

Sounds good,  4.1.20 seems stable enough for the moment, and I would suspect that with 4.4.x going default on the rpi, any odd bugs will get resolved in a couple of weeks.
Title: Re: piCore-7.1beta3 released
Post by: bzfrp on April 29, 2016, 10:23:07 AM
Hi,

I can't compile libupnpp from http://www.lesbonscomptes.com/upmpdcli/downloads.html:

tc@box:/mnt/mmcblk0p2/compile/libupnpp-0.14.1$ ./configure --prefix=/usr/local
checking for curl_easy_init in -lcurl... no
configure: error: libcurl not found

curl and curl-dev installed:
$ ls /usr/local/include/curl/
curl.h           curlver.h        multi.h
curlbuild.h      easy.h           stdcheaders.h
curlrules.h      mprintf.h        typecheck-gcc.h

$ ls /usr/local/lib/libcurl.*
/usr/local/lib/libcurl.a         /usr/local/lib/libcurl.so.4
/usr/local/lib/libcurl.la        /usr/local/lib/libcurl.so.4.4.0
/usr/local/lib/libcurl.so

I have compiled it on rpi 1 without problem.

Thanks for your help.
Title: Re: piCore-7.1beta3 released
Post by: curaga on April 29, 2016, 12:47:59 PM
In these situations, you'd look in config.log for detailed reports of why it failed.
Title: Re: piCore-7.1beta3 released
Post by: bzfrp on April 29, 2016, 01:39:53 PM
I found this
Code: [Select]
configure:15503: checking for curl_easy_init in -lcurl
configure:15528: gcc -o conftest -Os -pipe   conftest.c -lcurl  -lixml -lupnp -l
pthread -lrt  >&5
/usr/local/lib/libcurl.so: undefined reference to `libssh2_scp_recv2'
collect2: error: ld returned 1 exit status
Title: Re: piCore-7.1beta3 released
Post by: bzfrp on April 29, 2016, 02:46:52 PM
I recompiled libssh2 and that has solved the problem. Thanks !