Tiny Core Linux

Tiny Core Base => CorePlus => Topic started by: Capodastro on May 24, 2015, 05:23:36 PM

Title: Skype login error by german keyboard layout
Post by: Capodastro on May 24, 2015, 05:23:36 PM
Due to the Optimus technology in my laptop I am forced to use for graphic the Xorg server.
The only way I found to get a german keyboard layout in graphic mode is the line

cp 10-keyboard.conf /usr/local/share/X11/xorg.conf.d

in my bootlocal.sh, where 10-keyboard.conf looks like:

Section "InputClass"
   Identifier       "Keyboard Defaults"
   MatchIsKeyboard  "yes"
   Option           "XkbLayout"   "de"
   Option           "XkbVariant"  "nodeadkeys"
   Option           "XkbOptions"  "terminate:ctrl_alt_bksp"
EndSection

what is clssic xorg.conf section.
Wen I start Skype from the console I get:

QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv_open failed
QIconvCodec::convertToUnicode: using Latin-1 for conversion, iconv_open failed

Then opens the normal "Skype Terms of Use" window. I select as language english or german, there is no difference in the following error:
"Server connect failed" and the password field is again blank.

I tested all Skype versions, the last one would be 4.

Any idea about?
Thanks!



Title: Re: Skype login error by german keyboard layout
Post by: curaga on May 25, 2015, 12:45:15 AM
You want the glibc-gconv extension for the iconv conversion maps.
Title: Re: Skype login error by german keyboard layout
Post by: Capodastro on May 27, 2015, 04:26:03 AM
Hi curaga!

I am sorry for putting you on the wrong path. After installing the package you said the error warning disappeared but Skype failed again with "Server connect failed"
While I tried both versions 4 and 2, I think that rather some required library is missed. Any idea?
In any case grateful for what you do!
 
Title: Re: Skype login error by german keyboard layout
Post by: curaga on May 27, 2015, 05:02:11 AM
Perhaps Microsoft has blacklisted old versions?
Title: Re: Skype login error by german keyboard layout
Post by: Rich on May 27, 2015, 08:40:15 AM
Hi curaga
Quote
Perhaps Microsoft has blacklisted old versions?
That might very well be true. Last year I got a call from my mom telling me Skype wanted to update to a newer version. I went
to her house figuring I'd see if I could set a preference to just stop that notification since Skype was running quite nicely. I
remember there was a note in the notification stating that the current version would cease to function after a certain date.
Title: Re: Skype login error by german keyboard layout
Post by: Capodastro on May 27, 2015, 03:28:24 PM
under Mint I have version 4.3.0.37, working
I have also a SuSE installation which I don't use any more because too buggy. but I have a "local repo" with many rpm packages, by Skype 2.2.0.35, 4.0.0.7 and 4.3.0.37.
Let me take a look.
I would like so much get rid of Skype but the alternatives from google and firefox are too complicate for people with no computer skill.
Title: Re: Skype login error by german keyboard layout
Post by: Capodastro on May 28, 2015, 10:44:23 AM
I have nothing to report: Skype 2.2 and 4.0 do not start any more under suse 12.2, Version 4.3 works. All that under Opensuse, locally: I can't tell if really Microsoft stops older versions!
Title: Re: Skype login error by german keyboard layout
Post by: bmarkus on May 28, 2015, 12:17:14 PM
A while ago Microsoft stopped supporting older versions, when they changed encryption scheme.
Title: Re: Skype login error by german keyboard layout
Post by: Capodastro on May 29, 2015, 03:51:53 AM
OK, that would explain everything. Like I already wrote, for the moment Skype can't be replaced.
I assume that subsequently the steps would be:
- Decompress skype 4.5 and skype.tgz
- Substitute the old tgz files for the new one keeping intact the folder structure.
- Adjust the install script
- Pray

Wait a minut, by googling I discovered a fellow who did it already a couple of times taking also care for the dependencies.
it was gerald_klark isn't ? May I ask him for help?