Tiny Core Linux

Tiny Core Base => CorePlus => Topic started by: newguy1280 on December 31, 2014, 08:14:58 AM

Title: cant open apps after installation
Post by: newguy1280 on December 31, 2014, 08:14:58 AM
when i install an app (on boot, on demand etc) it says it installed, but when i click it to open it...nothing happens. help would be appreciated.
Title: Re: cant open apps after installation
Post by: Juanito on December 31, 2014, 08:32:31 AM
which app?
Title: Re: cant open apps after installation
Post by: newguy1280 on December 31, 2014, 08:42:19 AM
any app i try....but the one i need is rdesktop
Title: Re: cant open apps after installation
Post by: Juanito on December 31, 2014, 08:43:46 AM
if you open a terminal window and type "rdesktop", what do you get?
Title: Re: cant open apps after installation
Post by: newguy1280 on December 31, 2014, 08:47:04 AM
rdesktop options and settings etc
Title: Re: cant open apps after installation
Post by: core-user on December 31, 2014, 09:57:29 AM
I believe you need to reboot if you used 'on boot' to have it loaded.
Title: Re: cant open apps after installation
Post by: newguy1280 on December 31, 2014, 09:59:20 AM
i've tried on demand as well
Title: cant open apps after installation
Post by: coreplayer2 on December 31, 2014, 01:44:50 PM
If typing rdesktop results in the help menu etc then the application is opening, you simply need to supply the parameters for rdesktop to use is all


Sent from my iPhone using Tapatalk
Title: Re: cant open apps after installation
Post by: coreplayer2 on January 01, 2015, 05:19:17 AM
a basic rdesktop command might be for example
rdesktop 134.5.64.21

Or a little more specific
rdesktop -u Administrator -g 1600x1050 -a 16 134.5.64.21:4727

Title: Re: cant open apps after installation
Post by: newguy1280 on January 02, 2015, 06:01:12 AM
i've learned that I need rdesktop 1.8.3 to use with server 2012....the version of rdesktop via the apps program is 1.7.1....can anyone tell me how to upgrade it?
Title: Re: cant open apps after installation
Post by: Juanito on January 02, 2015, 06:34:01 AM
Send the extension maintainer a pm requesting an update.
Title: Re: cant open apps after installation
Post by: coreplayer2 on January 02, 2015, 07:32:11 PM
i've learned that I need rdesktop 1.8.3 to use with server 2012....the version of rdesktop via the apps program is 1.7.1....
This information is not correct.
rdesktop Version 1.7.1 works fine with both Server 2008R2 and Server 2012  in both tc-5.x and tc-6 x86.  however there have been a few minor fixes related to server 2012 in recent releases


What is the command you're using?
Title: Re: cant open apps after installation
Post by: newguy1280 on January 05, 2015, 09:01:50 AM
my apologies, i did manage to update it to the latest version 1.8.3 and it fixed some mouse issues etc...now if I could create a rdesktop shortcut so end users don't have to enter the command i'd be in business
Title: Re: cant open apps after installation
Post by: coreplayer2 on January 06, 2015, 09:15:51 AM
I'm guessing you're using tc-5.x because the iconv change in tc-6 causes other issues and might warrant a recompile for tc-6

Also iDesk might be what you're looking for..

Alternatively (as i have done) is make an extension which provides a list of servers you may select to connect to;  complete with resolution and user arguments all from the desktop right click menu.   all that I leave out is the password.  could you be more specific? then we might have more suggestions

Title: Re: cant open apps after installation
Post by: mebius on April 05, 2015, 03:55:09 AM
I install firefox "OnBoot" but cannot open it. After reboot cannot open too. However, then I install opera9, this application started successfully. I have 300MB RAM in my system. How many RAM is required for start firefox?
Title: Re: cant open apps after installation
Post by: bmarkus on April 05, 2015, 04:01:24 AM
Start FF in a terminal window. What are the messages?
Title: Re: cant open apps after installation
Post by: mebius on April 05, 2015, 05:19:21 AM
"Invalid command" sorry "illegal instruction"
Title: Re: cant open apps after installation
Post by: Juanito on April 05, 2015, 05:28:24 AM
did you type "FF" or "firefox"?
Title: Re: cant open apps after installation
Post by: mebius on April 05, 2015, 05:31:41 AM
I type firefox. If I type FF then "sh:FF: not found"
Title: Re: cant open apps after installation
Post by: Juanito on April 05, 2015, 05:37:45 AM
what sort of cpu are you using (i486, i686, etc)?

what does "uname -a" give?
Title: Re: cant open apps after installation
Post by: mebius on April 05, 2015, 05:46:25 AM
tc@box:~$ uname -a
Linux box 3.16.6-tinycore #777 SMP Thu Oct 16 90:42:42 UTC 2014 i686 GNU/Linux

I use VIA EPIA-5000A MiniATX
Title: Re: cant open apps after installation
Post by: Juanito on April 05, 2015, 05:55:09 AM
firefox say:
Quote
Intel Pentium II or AMD K6-III+ 233 MHz CPU

..perhaps that is the source of the illegal instruction message?

does the controlpanel gui "system stats" cpu tab give any more info on your cpu?
Title: Re: cant open apps after installation
Post by: mebius on April 05, 2015, 06:10:53 AM
processor: 0
vendor_id: CentaurHauls
cpu family: 6
model: 7
model name: VIA Samuel 2
stepping: 3
cpu MHz: 533.315
cache size: 64KB
physical id: 0
siblings: 1
core id: 0
cpu cores: 1
apicid: 0
initial apicid: 0
fdiv_bug: no
f00f_bug: no
coma_bug: no
fpu: yes
fpu_exception: yes
cpuid level: 1
wp: yes
flags: fpu de tsc msr cx8 mtrr pge mmx 3dnow
bogomips: 1067.07
clflush size: 32
cache_alignment: 32
address sizes: 32 bits physical, 32 bits virtual
power management:
Title: Re: cant open apps after installation
Post by: Juanito on April 05, 2015, 06:33:27 AM
It's difficult to know exactly, but I'd guess firefox expects one or more cpu functions to be available that your cpu doesn't have...
Title: Re: cant open apps after installation
Post by: mebius on April 05, 2015, 06:55:17 AM
Thank you, Juanito. It's maybe true.