Tiny Core Linux

General TC => Programming & Scripting - Unofficial => Topic started by: dspence on October 31, 2014, 10:07:01 AM

Title: [Solved] Trying to build Qt Creator on TC 5.4
Post by: dspence on October 31, 2014, 10:07:01 AM
Hi,

I'm trying to build Qt-Creator on Tiny Core 5.4.  I've followed the instructions found here:
http://www.m-opensolutions.com/?p=600 (http://www.m-opensolutions.com/?p=600)
http://www.m-opensolutions.com/?p=622 (http://www.m-opensolutions.com/?p=622)
with updates to the scripts to use newer versions of the sources (qt-everywhere-opensource-src-5.3.2.tar.gz and qt-creator-opensource-src-3.2.1.tar.gz).

After building, Qt Creator won't run without "-noload Welcome" on the command line.  Which is fine.  But the keyboard doesn't work.

Output in the terminal looks like this:
Code: [Select]
tc@box:~/build/qt-creator-opensource-src-3.2.1/bin$ ./qtcreator.sh -noload Welcome
xkbcommon: ERROR: failed to add default include path auto
Qt: Failed to create XKB context!
Use QT_XKB_CONFIG_ROOT environmental variable to provide an additional search path, add ':' as separator to provide several search paths and/or make sure that XKB configuration data directory contains recent enough contents, to update please see http://cgit.freedesktop.org/xkeyboard-config/ .
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
tc@box:~/build/qt-creator-opensource-src-3.2.1/bin$

Does anyone know how to solve the keyboard issue?

Thanks!
Title: Re: Trying to build Qt Creator on TC 5.4
Post by: bmarkus on October 31, 2014, 11:10:05 AM
Read the error message.
Title: Re: Trying to build Qt Creator on TC 5.4
Post by: dspence on October 31, 2014, 12:06:27 PM
Lol!  Thanks.

I guess I just needed to figure out that the config is in /usr/local/share/X11/xkb.  Looks like it's installed with the xkeyboard-config.tcz extension.  Setting the environment variable to that path and starting qtcreator again made it work.