Tiny Core Linux

dCore Import Debian Packages to Mountable SCE extensions => dCore X86 => dCore x86 Imported Extensions => Topic started by: netnomad on October 02, 2014, 09:27:10 AM

Title: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 02, 2014, 09:27:10 AM
hi jason,

i use a working alsa-environment, vlc and youtube in the browser are working fine.

my freshly imported minitube shows no icons, i get no sound, no video and in the terminal following errors appear:

Phonon::GStreamer::Backend: Failed to initialize GStreamer
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::VideoWidget ( no objectName ).

under 4.7.7 i use flawless the phonon-backend-vlc.

the phonon-backend-vlc is installed and the stand-alone-vlc works fine for streamed music and videos.

do you have any hints?
thank you for your help and commitment :)
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 02, 2014, 09:58:00 AM
I've never used minitube, and it probably needs startup script functions to get it working.  I will look at it tonight.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 02, 2014, 10:53:17 AM
minitube is really worth to use, really great... youtube without ads and google-services... :)

thank you for your help.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 03, 2014, 04:23:11 AM
hi jason,

video is working in minitube now, but i have still no sound and no icons in the minitube-control-panel:

[b8037680] pulse audio output error: PulseAudio server connection failure: Connection refused
[b8064b68] pulse audio output error: PulseAudio server connection failure: Connection refused
[b8064b68] core audio output error: no suitable audio output module
[b80f7130] vdpau_avcodec generic error: Xlib is required for VDPAU
[b27036a8] pulse audio output error: PulseAudio server connection failure: Connection refused
[b27036a8] core audio output error: no suitable audio output module
[af20ad50] core decoder error: failed to create audio output

vlc still works fine with sound and video, although there is the same PluseAudio-error:

tc@box:~$ vlc
VLC media player 2.2.0-pre3 Weatherwax (revision 2.2.0-pre3-0-ga15bef7)
[093f6058] pulse audio output error: PulseAudio server connection failure: Connection refused
[0934f0d0] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.


thank you for your help and support.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 03, 2014, 07:47:42 AM
Pulseaudio needs some dependencies added in Jessie.  Also, there is some startup script actions needed.  I will hopefully finish it tonight.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 03, 2014, 12:49:39 PM
hi jason,

i get still no sound :(

[b8193430] pulse audio output error: PulseAudio server connection failure: Connection refused
[b82522e8] core audio output error: no suitable audio output module
[b073ef00] mp4 demux error: cannot create chunks index
[b82f2150] vdpau_avcodec generic error: Xlib is required for VDPAU
[b07a7430] core decoder error: failed to create audio output

do you see or have more hints?
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 03, 2014, 02:02:55 PM
I haven't got home yet to work on it.    Have you re-imported pulseaudio?  I added consolekit to it's deps last night and it should be working but I will retest when I get in.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 03, 2014, 02:51:56 PM
Have you re-imported pulseaudio?

i did it twice without any luck or different result :(
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 03, 2014, 07:48:08 PM
On dCore-jessie, I imported the below 2 packages in a package list file, in addition to my standard icewm/iceweasel/leafpad/etc desktop:

minitube
pulseaudio

I launched minitube, without having to start pulseaudio first, and it is working fine, watching it now. 
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 03, 2014, 11:46:10 PM
hi jason,

although i added pulseaudio to my package-file (it was loaded before by dependency), i have no luck :(

after loading pulseaudio in a terminal, i get following error messages:

tc@box:~$ pulseaudio
W: [pulseaudio] authkey.c: Failed to open cookie file '/home/tc/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/home/tc/.config/pulse/cookie': No such file or directory
E: [pulseaudio] module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

tc@box:~$ sudo pulseaudio --system
W: [pulseaudio] main.c: Running in system mode, but --disallow-exit not set!
W: [pulseaudio] main.c: Running in system mode, but --disallow-module-loading not set!
N: [pulseaudio] main.c: Running in system mode, forcibly disabling SHM mode!
N: [pulseaudio] main.c: Running in system mode, forcibly disabling exit idle time!
E: [pulseaudio] main.c: Failed to find user 'pulse'.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 04, 2014, 04:14:32 AM
Do you have any other sce's installed?  If so, you likely have old versions of packages that are getting loaded first.

Either import all of your sce's again, or put minitube and pulseaudio at the beginning of your sceboot.lst or load them first before any others.  I see a dbus error in your output that was fixed a while back.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 04, 2014, 05:00:25 PM
hi jason,

the problem was perhaps the missing user "pulse".
does it makes sense that you add "pulse" to the standard users?

after adding pulse to the users and restarting the dbus the sound works fine in minitube.
now my alsa-mixer shows only two devices: master and capture.
before i had at least ten different devices.
i this normal, after starting pulseaudio?
do i need another mixer for controling more devices?

do have an idea how i get the icons in the minitube control-panel?
.... there are five buttons in the upper left corner (left of the time-stamp) that have no icons.

thank you for your help and patience.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 04, 2014, 06:32:15 PM
You're right, I had mistranslated the Debian startup script.  Now creates the user pulse and adds it to the audio group as well as creating groups pulse and pulse-access as in Debian.  Also, added alsa-utils to the list of dependencies of pulseaudio as it is needed for sound, or else it errors like you listed earlier.  Tested here by loading kernel-all-3.8.13-tinycore and pulseaudio, then testing sound.

It seems that the one or two sound channels is normal for pulseaudio, I have one on my machine.  Also, the icons are probably meant in Debian to be provided by a desktop environment.  But I will look into it.

Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: curaga on October 05, 2014, 01:52:57 AM
Try installing any icon theme such as gnome-icon-theme.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 05, 2014, 10:00:49 AM
Thanks, but that does not work either.  But using the command "DESKTOP_SESSION=gnome minitube" does give it a gtk2 appearance.

I googled images of minitube and see several screenshots where there are no icons in the menu, even on the Ubuntu standard gnome desktop.  So in this case I am not going to pursue the icon issue further.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 05, 2014, 11:57:36 PM
hi jason,

with the command "DESKTOP_SESSION=gnome minitube" everything works fine:
the buttons show icons and the volume bar works, too.

wrapped in an one-line-script it's a quick and dirty solution, that should be o.k.

thank you for your help.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 06, 2014, 07:32:38 AM
Put "export DESKTOP_SESSION=gnome" in your ~/.ashrc and back it up and that variable will be set for all your apps, whether launched from the menu or terminal.   Makes VLC look like gtk2 as well.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 06, 2014, 12:11:22 PM
Put "export DESKTOP_SESSION=gnome" in your ~/.ashrc and back it up and that variable will be set for all your apps, whether launched from the menu or terminal.   Makes VLC look like gtk2 as well.

hi jason,

works smooth and fine.
now only the menue-entry of fluxbox doesn't start properly and has an odd entry:

[exec](StopAfterThisVideo){minitube --stop-after-this}

the option --stop-after-this prevents minitube from a correct start.
would you mind to change the name to minitube and remove --stop-after-this?

thank you for your kind support and help.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 06, 2014, 02:50:16 PM
The the .desktop files in /usr/share/applications/ are from Debian, and I don't really want to start providing custom ones.  But for packages that are basically broken in their menu items I will consider it.  I will make one for minitube.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 15, 2014, 09:05:56 AM
The the .desktop files in /usr/share/applications/ are from Debian, and I don't really want to start providing custom ones.  But for packages that are basically broken in their menu items I will consider it.  I will make one for minitube.

hi jason,

i guess that the .desktop files in /usr/share/applications/ are o.k.,
but the menue-file /usr/local/tce.fluxbox provided for fluxbox is malformed :(

tc@box:/usr/local$ cat tce.fluxbox
[submenu] (Applications)
...
exec](StopAfterThisVideo){minitube --stop-after-this}
...
[end] TCE
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 15, 2014, 09:53:06 AM
Ok, will look into it tonight.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: Jason W on October 16, 2014, 12:41:51 PM
Added a more small WM compatible .desktop entry for minitube, simply runs minitube.  Works with fluxbox.
Title: Re: minitube - no icons in menues, problem with phonon-backend and no icon in wbar
Post by: netnomad on October 16, 2014, 01:44:48 PM
hi jason,

thanks a lot, now it works fine :)

such a great, clean program, now so easy to use :)

thank you for your help and commitment.