Tiny Core Linux

Tiny Core Base => Raspberry Pi => piCore Test Releases => Topic started by: bmarkus on March 10, 2014, 02:46:13 PM

Title: piCore-5.2.1rc1
Post by: bmarkus on March 10, 2014, 02:46:13 PM
Team Tiny Core is pleased to announce the availability of piCore-5.2.1rc1:

http://tinycorelinux.net/5.x/armv6/release_candidates/

Change log for 5.2.1rc1:

* kernel updated to 3.13.6
* added kernel modules required to connect WiFi AP with SHA encryption
* added ntpserver=<serveraddress> boot option to define ntp server (default pool.ntp.org)
* added /etc/sysconfig/ntpserver config file to define ntp server address
* fixed issued that modules were not found in /usr/local/lib
* USB CLASS modules are not built into the kernel but real modules part of base

Please note, alsa-modules-3.13.6-piCore+.tcz has no startup script to avoid conflicts with DACS, necessary modules must be loaded by user, including on-chip sound device.

Images with preinstalled SSH for headless operation and with GUI also available.

For support visit http://forum.tinycorelinux.net/index.php/board,57.0.html
Title: Re: piCore-5.2.1rc1
Post by: Gerrelt on March 11, 2014, 11:59:59 AM

Hi Béla,

I've installed it, but I cannot connect to my wifi anymore. It keeps on discovering..

I installed it on a different (older) 1 Gb SD card, but the card seems to work fine. And I see in your releasenotes that there is something different regarding WiFi.

When I inserted my old install, version 5.2rc2, again, it is working fine.

I will investigate more tomorrow. If you want log-files or anything, just say so.
The WiFi adapter is a RTL8188CUS.

Greetings,
   Gerrelt.
Title: Re: piCore-5.2.1rc1
Post by: bmarkus on March 11, 2014, 12:05:53 PM
Thanks for testing. dmesg output after trying and failing connect welcome as well as lsmod. In my case with 5.2 the problem comes when 802.11n mode and SHA encryption used, TKIP was OK. It is fixed adding two crypto module to rc1 base. In dmesg adapter was authenticated and immediately deautenthicated. Now it works fine here. Let's see your adapter.
Title: Re: piCore-5.2.1rc1
Post by: DanW on March 11, 2014, 06:21:45 PM
FWIW  I have been having no luck setting up a wifi with the  5.2 release using a ralink wifi adapter and a WPA2-PSK [AES] network- symptoms as Gerrelt describes above: discovering followed by deauthorization.  I tried wifi.sh to do the setup, and also followed the guide in the wiki for manual wireless setup with same symptoms/no success. A Debian Pi install worked no problem.

So the good news: this rc1 works like a champ!  Wifi.sh ran fine and the Pi is on the wireless network.  I'm going to continue setting up a squeezelite on this system (thanks again for the squeezelite primer, Gerrelt! :-)
Title: Re: piCore-5.2.1rc1
Post by: bmarkus on March 12, 2014, 12:18:10 AM

So the good news: this rc1 works like a champ!  Wifi.sh ran fine and the Pi is on the wireless network.  I'm going to continue setting up a squeezelite on this system (thanks again for the squeezelite primer, Gerrelt! :-)

Thanks for the feedback.
Title: Re: piCore-5.2.1rc1
Post by: bmarkus on March 12, 2014, 07:08:38 AM
Please do not test this image. Found a strange issue, investigating.
Title: Re: piCore-5.2.1rc1
Post by: Gerrelt on March 12, 2014, 09:44:19 AM
OK, I will put it on hold.
Title: Re: piCore-5.2.1rc1
Post by: bmarkus on March 12, 2014, 01:51:57 PM
Images removed, look for 5.2.1rc2