Tiny Core Linux

Off-Topic => Archive / Obsolete => SCM EXtensions => Topic started by: Jason W on September 05, 2012, 09:50:53 PM

Title: opera-12.scm
Post by: Jason W on September 05, 2012, 09:50:53 PM
Opera 12 seems to have solved the issues of the 11 release.  Please let me know here if it has not.
Title: Re: opera-12.scm
Post by: AbNoRMiS on September 07, 2012, 05:02:07 AM
i worked with opera-11.scm and it seems had no issues
now already comes third day since i installed opera-12.scm
currently there is no issues found in new version, many thanks :)
Title: Re: opera-12.scm
Post by: Jason W on September 07, 2012, 10:23:14 PM
Thanks for testing and reporting.
Title: Re: opera-12.scm
Post by: AbNoRMiS on September 13, 2012, 02:02:18 PM
now i rarely watch youtube therefore only today i found
that flash player does not work in opera-12.scm
in opera-11.scm and others it works
Title: Re: opera-12.scm
Post by: Jason W on September 13, 2012, 02:08:33 PM
Ok, I will check it out tonight.
Title: Re: opera-12.scm
Post by: Jason W on September 15, 2012, 10:56:53 AM
Flash and youtube is working for me in opera-12.scm.
Title: Re: opera-12.scm
Post by: AbNoRMiS on September 15, 2012, 01:02:56 PM
(http://forum.tinycorelinux.net/index.php?action=dlattach;topic=13984.0;attach=3617)
Title: Re: opera-12.scm
Post by: Jason W on September 26, 2012, 04:24:54 PM
I have read a lot about opera 12 and it not playing flash.  Many reports on the web.  It seems to be an opera or adobe issue, and with adobe's halting support for future flash versions on linux outside of chrome, I think we will see more of this kind of issue to come. 

I did read of using a previous version of flash to make it work with opera 12, but I tried  version 11.1.102.55 to no avail, as well as the current.
Title: Re: opera-12.scm
Post by: uggla on October 16, 2012, 12:26:09 PM
Since Flash isn't working I tried to use html5 for Youtube but... Loading Gstreamer codecs makes webm work in opera-11.tcz but not opera-12.scm.  :(
Title: Re: opera-12.scm
Post by: Jason W on October 16, 2012, 02:36:34 PM
Ok I will look into it, but it may just be another issue with opera 12.
Title: Re: opera-12.scm
Post by: uggla on November 14, 2012, 09:03:34 AM
Tried 12.10 but it still doesn't recognize any of my plugins  :(
Title: Re: opera-12.scm
Post by: Jason W on November 19, 2012, 12:53:59 PM
Yeah, I still notice the same.   I will look more into it shortly.
Title: Re: opera-12.scm
Post by: risto3 on November 20, 2012, 05:09:27 AM
I get on opera-12 (and firefox as well, for that matter) the following:

tc@box:~$ opera-12
Instruction non permise

this is on a Vortex86MX (i586 with mmx)

apparently the compiler settings are for i686 or higher... (with cmov and/or sse* and so on)
Title: Re: opera-12.scm
Post by: Jason W on November 20, 2012, 08:24:01 AM
Yeah, the major web browsers are now built i686 compatible, I remember this being brought up about operay.  But the minefield extensions should work, they are built i486 compatible.
Title: Re: opera-12.scm
Post by: curaga on November 20, 2012, 10:33:22 AM
Opera is binary software, so please take that up with them. (unless it's in a lib and not Opera - check with gdb).
Title: Re: opera-12.scm
Post by: nick65go on November 20, 2012, 01:15:26 PM
Tried 12.10 but it still doesn't recognize any of my plugins  :(

sorry for noise; but did you try the latest flashplugin 11.2.202.251 ?
it is working for me with opera-next 12.50 (Opera/9.80 (X11; Linux x86_64) Presto/2.12.378 Version/12.50)
Title: Re: opera-12.scm
Post by: tinypoodle on November 20, 2012, 01:27:14 PM
Hmm, the download binaries on opera's ftp server contain "i386" in their name...
Title: Re: opera-12.scm
Post by: nick65go on November 20, 2012, 02:14:55 PM
I did not find anymore all the opera-next packages on their ftp;
but here is a hole collection to chose from: http://arc.opera.com/snapshot/linux-freebsd/
just extract the main (big) file, replace it over yours, (chmod +x) and enjoy
so test until you find one which works for you (you could keep many operaX tcz in your bag)
btw: I mostly use x64 linux >3.5 because Xorg drv for my ATI X1400 (else quick fans run/noise in linux 3.2x)
Title: Re: opera-12.scm
Post by: Jason W on November 20, 2012, 06:54:28 PM
I have the current opera-12.scm working with a couple versions of flash, opera requires either libcurl.so* to be in the standard path, or for it to be loaded with LD_PRELOAD, which I added to the opera-12 wrapper.  Uploading now, hopefully fixes the issue.
Title: Re: opera-12.scm
Post by: uggla on November 20, 2012, 10:12:56 PM
Still no plugins detected  :(
Title: Re: opera-12.scm
Post by: tinypoodle on November 20, 2012, 10:35:24 PM
Still no plugins detected  :(

Any output when running with option "-debugplugin"?
Title: Re: opera-12.scm
Post by: Jason W on November 20, 2012, 10:41:59 PM
I notice the same when booting bare bones, will look into tomorrow.
Title: Re: opera-12.scm
Post by: Jason W on November 21, 2012, 06:38:22 PM
Ok, no LD_PRELOAD  needed, just needed to export LD_LIBRARY_PATH to the operapluginwrapper script.   Hopefully all works now.
Title: Re: opera-12.scm
Post by: uggla on November 22, 2012, 08:07:19 AM
Yes, now it works fine. Big thanks!