Tiny Core Linux

Tiny Core Extensions => TCE Bugs => Topic started by: AbNoRMiS on April 27, 2012, 03:05:36 PM

Title: xfonts-unifont.tcz installing problem
Post by: AbNoRMiS on April 27, 2012, 03:05:36 PM
revealed the following error when installing xfonts-unifont.tcz
Quote
tc@box:~$ tce-load -wi xfonts-unifont.tcz
Downloading: xfonts-unifont.tcz
Connecting to distro.ibiblio.org (152.19.134.43:80)
xfonts-unifont.tcz   100% |*****************************************************************************************|   948k  0:00:00 ETA
xfonts-unifont.tcz: OK
./fonts.dir: fopen(w): Read-only file system
tc@box:~$
and then this error occurs during every system startup
i think this occurs because unifont can not be written to
/usr/lib/X11/fonts/misc/fonts.dir which is symlinked
Title: Re: xfonts-unifont.tcz installing problem
Post by: solorin on April 27, 2012, 07:58:03 PM
most fonts with bitmap fonts don't work properly out of the box.
it is a well made little script tho.

The workaround is manual.

sudo rm the symlink.
run mkfontdir an mkfontscale in the directory your fonts are in (from Xorg-7.x-bin)

then manually set the font path
xset +fp /path/to/fonts
xset fp rehash

does anybody have experience with bitmap fonts working out of the box  for them?

if not, maybe you should also pm the maintainer

cheerio,
solorin
Title: Re: xfonts-unifont.tcz installing problem
Post by: AbNoRMiS on April 27, 2012, 08:36:19 PM
dear solorin
pm has already been sent
thanks for exhaustive response
i think it will help to correct the initialization script
meanwhile i will try do it from bootlocal.sh