General TC > Tiny Core on Virtual Machines

open-vm-tools for VMware

<< < (2/6) > >>

maro:
I can only provide you with an answer to your first problem:

As the '/etc/X11/xorg.conf.vesa' file is actually a symbolic link into a RO filesystem (of the squashFS "flavour") you stand no chance of chainging the content of this file directly. Furthermore you need to edit '/etc/X11/xorg.conf', so
(1) copy the file (e.g. via sudo cp /etc/X11/xorg.conf.vesa /etc/X11/xorg.conf) and then
(2) edit the "proper" configuration file (e.g. via sudo vi /etc/X11/xorg.conf). If things are working to your satisfaction you might want to
(3) include it in your backup (e.g. via echo etc/X11/xorg.conf >> /opt/.filetool.lst).

athouston:
Thank you Maro - that makes sense now that its explained to me.

danielibarnes:

--- Quote from: athouston on April 25, 2011, 08:58:23 PM ---Also thank you Daniel. I am a long time user of the other operating system and have been using TC to teach myself about the rest of the It world. I've decide to jump from v2 to v3 but I'm still learning Linux. Hence a couple of stupid questions if I may

--- End quote ---

These are good questions, as any new user is going to have the same concerns.


--- Quote ---Apparently the vmtools is running OK because I now don't get an message to load it when I start the session. But the mouse still stays stuck in the session screen unless I manually release it (control-command). I see your reference to the xorg.conf being modified with the mouse "driver=vmmouse" line. My system has an xorg.conf.vesa file. I assume this is what needs modifying (it says "driver=mouse"). Problem is it is R/O. I ran sudo su before starting vi but it is persistently R/O. Is this the correct file and how can I get around the R/O please.

--- End quote ---

You need to tell Xorg to auto-detect the VMware video device and create a new xorg.conf with the appropriate settings. You also need to create a backup of these files so they will be restored the next time you boot up. The backup file is stored in your tce directory, so this means your tce directory must be on persistent storage like a hard drive or usb flash drive.

tc@box:~$ sudo Xorg -configure
tc@box:~$ sudo mv /home/tc/xorg.conf.new /etc/X11/xorg.conf
tc@box:~$ echo etc/X11/xorg.conf >> /opt/.filetool.lst
tc@box:~$ echo /usr/local/etc/init.d/open-vm-tools-x start >> /opt/bootsync.sh
tc@box:~$ filetool.sh -b

Notes:
1) 'Xorg -configure" will auto-detect the proper settings and create a xorg.conf.new file in your home directory.
2) You must move it to the proper location for backup.
3) Add the xorg.conf file to you backup list.
4) Include the startup script in your bootsync.sh script for convenience.
5) Perform the backup.


--- Quote ---Secondly, in system stats I see the vmxnet loaded but no reference to flexible drive. I assume I don't need to worry about the "blacklist=..." option on startup.

--- End quote ---

You only need the "blacklist=pcnet32" option if you see the module loaded:
tc@box:~$ lsmod|grep pcnet32


--- Quote ---Can you clarify that the nodhcp option is for open-vm-tools-x and that I should modify this to include nodhcp on my dhcp server (because it is static).

--- End quote ---

If you aren't sure that you need it, then you don't. The nodhcp option is for users which need to configure the interface with a static IP address. Typical users have a DHCP server or use the one provided by VMware for NAT and host-only networking.

athouston:
Thanks Daniel, I'll work through that over the next couple of days.

One of the VM's that I want to create is a database and DHCP / DNS server, hence the nodhcp question. I can set the IP address under VM for testing but will need to set it under TC when I build the actual server ( I have an old Dell server with a bucket load of SCSI disk space).

My next two challenges will then be getting aoetools working ( I see the thread) and install CouchDB (which I don't see anywhere).

Cheers and be well.

danielibarnes:

--- Quote ---My next two challenges will then be getting aoetools working ( I see the thread) and install CouchDB (which I don't see anywhere).
--- End quote ---

I use couchdb in a VM, and I have a few tips. I presume you know or can find out how to customize and preserve files using a cpio archive or a backup tgz.

1) Customize /etc/couchdb/local.ini to store your databases on a virtual HDD. By default, they are stored in tmpfs (which is really just memory).

database_dir = /mnt/hda1/couchdb
view_index_dir = /mnt/hda1/couchdb
uri_file = /mnt/hda1/couchdb/couch.uri

2) Set your bind address to 0.0.0.0 in local.ini, otherwise connections will only be accepted from localhost:

bind_address = 0.0.0.0

3) Start couchdb in /opt/bootlocal.sh for convenience:

/etc/init.d/couchdb start &>/dev/null

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version