WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Acer Aspire One with AMD C50 - no internet connection or audio available  (Read 14657 times)

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
2) No sound
I used VLC to watch a movie and all I got back was the video with no audio. I did have OSS installed. VLC did give me a warning message stating that if I were to update alsa-lib to version 1.0.23-2-g8d80d5f that it may help with the audio issue.

Perhaps there are no Linux drivers for these items yet?

Any solution to address these issues would be greatly appreciated. Thanks!

Have you tried to particularly specify OSS audio output?

FWIW, Mplayer(-nodeps) works fine with OSS.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Juanito:
I ran the script without the modprobe code and it worked. However, I noticed that the first time I ran the script after I made the code change I did not get connect. Some error about "fork" and "no lease". I then re-ran the script right after and I got a connection. Any thoughts why this would happen? Perhaps a timeout issue?

Thanks!

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
tinypoodle:
No luck with MPlayer(-no deps) with OSS. Still no sound. I do get sound when watching videos on YouTube via Flash though so I know that it's not an issue with my sound card.

Thanks!

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Hmm, Mplayer-nodeps always worked for me out of the box with OSS, while I could not say the same for flashplayer...
If you get neither sound with vlc nor mplayer, that might lead to conclusion that you might have more general issues with OSS...

Have you tried installing OSS_alsa.tcz ?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
tinypoodle:
I tried downloading OSS_alsa extension earlier but I was getting a download error. I was connected to the internet at the time so I know it's not a connection issue. I will try downloading it again.

Thanks!

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
As OSS_alsa is a metaextension, you could alternatively just download all its deps as seen here:
http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/3.x/tcz/OSS_alsa.tcz.dep
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
tinypoodle:
Thanks for the link but it didn't work for me after I installed it. However, after playing around with some other extensions I was able to get sound. The extensions I used;

1) alsaconf.tcz
2) alsa-oss.tcz

Although it's great to have sound now, two more issues have come up;
1) When I use headphones the sound still comes out of my internal speaker
2) I have to run the alsaconf.tcz extension to reconfigure my sound card every time I reboot. A bit of a nuisance. I saved the /etc/modprobe.conf to my backup/restore but this did not help

Thanks!

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4248
Hi rizzim3
Open AppBrowser and select alsa.tcz, then read what's in the info tab, it tells you how to
make you settings persistent.

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Rich:
Not having any luck as per the instructions in the alsa extension page. I ran alsaconf, saved all the necessary files for recovery/backup, created a script to run alsasound and upon next reboot, no sound. However, when I run alsaconf, go through the entire process then load alsa then it works. I will just stick with this process until I figure out a better way.

Thanks!

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
1) When I use headphones the sound still comes out of my internal speaker

Is that with OSS or alsa running?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
tinypoodle:
That is with alsa running. The only way I was able to get any sound was via alsaconf and then loading alsa. OSS never worked for me.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6476
Quote
However, I noticed that the first time I ran the script after I made the code change I did not get connect. Some error about "fork" and "no lease". I then re-ran the script right after and I got a connection. Any thoughts why this would happen?

The udhcpc daemon runs in the background, so if you need to run the script again, you would need to kill the daemon.

To kill the daemon you first need to find its PID, which can be then used to kill it:
Code: [Select]
$ ps aux | grep udhcpc
[shows PID]
$ sudo kill PID

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4248
 Hi rizzim3
These go in filetool.lst

etc/modprobe.conf
etc/asound.state
opt/alsa

and these go in bootlocal.sh

# Start the alsa sound driver
/usr/local/etc/init.d/alsasound start
# Restore the mixer volume levels
/usr/local/sbin/alsactl restore

After you have sound working execute this to create the /etc/asound.state file.

alsactl store

I think one or two of the above steps might be missing from the info tab.
[EDIT] I could never get OSS to work either.
« Last Edit: March 09, 2011, 07:41:04 PM by Rich »

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
tinypoodle:
That is with alsa running. The only way I was able to get any sound was via alsaconf and then loading alsa. OSS never worked for me.

I asked because there is a known issue with jacksensing under OSS, has always worked out of the box though with alsa for me.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
tinypoodle:
I briefly read somewhere about this issue. Was hoping it wouldn't impact me. Oh well...