WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Acer Aspire One with AMD C50 - no internet connection or audio available  (Read 14818 times)

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Juanito:
I noticed in my boot script there is the following code:

pkill udhcpc
udhcpc -H box -b -i eth0

Perhaps this is the reason why it fails to establish the wireless connection the first time I try via a script (similar to yours)? However, when I immediately rerun the script I get a wireless connection without having to kill anything.

Perhaps this is the code I need to edit in order to get my wired connection working? Your thoughts?

I've been researching the udhcpc command. What is the flag -b for? It's not listed in any documentation that I can find.

Thanks!

Online gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3476
udhcpc --help

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Rich:
Your instructions were similar to what I did. Instead of putting the code in bootlocal.sh I just kept it in another script to run on an "as need basis" (I did do another test with the code in bootlocal.sh, no success either). I would get errors complaining that the files as per the code;

/usr/local/etc/init.d/alsasound start
/usr/local/sbin/alsactl restore

could not be found. Before shutting down they were there, just lost on reboot. So I added them to the filetool.lst thinking that would save them. Well, they were saved but they were also empty and hence the code could not run. The other three files;

etc/modprobe.conf
etc/asound.state
opt/alsa

were there. Maybe I'm just missing something, who knows...

Thanks!

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4261
Hi rizzim3
Sounds like you may need to change  alsa.tcz  to OnBoot, possibly  alsaconf.tcz  too.

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Rich:
You may be right. I will give that a try to test it out. My goal was to reduce the number of extensions from boot up to make the boot process quicker and to not load extensions if they weren't going to be used during a login session. Just trying to keep RAM use under control.

Thanks!

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4261
Hi rizzim3
You're welcome, and let us know how it works out.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6573
pkill udhcpc
udhcpc -H box -b -i eth0

Perhaps this is the reason why it fails to establish the wireless connection the first time I try via a script (similar to yours)? However, when I immediately rerun the script I get a wireless connection without having to kill anything.

It would be better to make the pkill line conditional, i.e. if udhcpc is running, then pkill udhcpc, else go to next command

Quote
I've been researching the udhcpc command. What is the flag -b for? It's not listed in any documentation that I can find.

-b = backgrounded

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Rich:
Just tested the OnBoot method... it didn't work. I guess for the next little while I will have to proceed with the manual alsaconf. Not a deal breaker though, just a bit of a nuisance but thankfully the process doesn't take long. Here's hoping that the next release will take care of this issue.

Thanks for all your help.

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Juanito:
I will look at adding a conditional statement even though I'm not very familiar with Linux coding. Something new to learn! But first I need to get my wired connection up and running... still haven't figured that issue out. Frustrating.

Thanks!


Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4261
Hi rizzim3
Try adding  sleep 2  to bootlocal.sh right above the alsasound command.
Check the following

/opt/alsa/.alsaconf  should contain the number 1
etc/asound.state  should start out with state.PCI { followed by a bunch of control, comment, etc stuff.

Are the file not found errors gone?

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Rich:
Still not working.

Added sleep 2 to bootlocal.sh
I did not see any of the "file not found" errors on boot up.
/opt/alsa/.alsaconf  does contain the number 1
etc/asound.state     starts out with state.Generic and then further down state.SB

When I ran my "as needed basis" script (not in bootlocal.sh but the code is similar) I get a bunch of modprobe errors such as;

modprobe: can't load module snd_mixer_oss (kernel.tclocal/sound/core/oss/snd-mixer-oss.ko.gz): Operation not permitted


I did not see these errors when running the code in bootlocal.sh

Maybe I need to start fresh again, go through the process one more time to make sure I haven't missed anything, whatever that may be.

Thanks!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6573
When I ran my "as needed basis" script (not in bootlocal.sh but the code is similar) I get a bunch of modprobe errors such as;

modprobe: can't load module snd_mixer_oss (kernel.tclocal/sound/core/oss/snd-mixer-oss.ko.gz): Operation not permitted

bootlocal.sh runs as root, it is possible that your script is running as user tc, which does not have the appropriate permissions to modprobe. If this is the case, you can preface the modprobe command with "sudo" in your script.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4261
Hi rizzim3
My machine has the following installed

alsa
alsa-modules-2.6.33.3-tinycore
alsa-plugins
alsaconf

Lose the OSS stuff, it caused me nothing but trouble.

Get sound working again, remember to run  alsactl store  and see if works.
I have to hit the sack, I'll pick it up tomorrow if you need more help.

Offline rizzim3

  • Newbie
  • *
  • Posts: 33
Rich:
I went through the process one more time but still no luck. Maybe you can spot whether or not I'm missing a step. They are as follows;

1) run alsaconf to configure alsa
2) run alsactl store
3) verified that all the files were created
4) added lines to bootlocal.sh
           /usr/local/etc/init.d/alsasound start
           /usr/local/sbin/alsactl restore
5) exit system with backup/restore and reboot
6) reconfirm that all alsa files are there
7) load all alsa extensions
           alsa
           alsa-modules-2.6.33.3
           alsa-plugins
           alsaconf

Thanks!
« Last Edit: March 10, 2011, 08:39:20 AM by rizzim3 »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4261
Hi rizzim3
After you get the sound working you need to tell alsa to save it's configuration with

alsactl store

otherwise the  /usr/local/sbin/alsactl restore  command in your bootlocal.sh won't have anything
to restore.