General TC > Tiny Core Netbooks

Toshiba Satellite T215D

(1/8) > >>

MikeLockmoore:
The ASUS eeePC 1000 I had been using at work died several months back.  :'( Motherboard got a little flaky... some trace seemed cracked or something... if you pressed on part of the motherboard a little, it would shut down.

Anyway, I was assigned a Toshiba Satellite T215 as a replacement.  Here are some specs:

CPU: 1.7-GHz AMD Athlon II Neo Processor K125
RAM/Upgradeable to: 2GB/8GB
Hard Drive Size/Speed: 250GB/5,400 rpm
Display Size/Resolution: 11.6 inches / 1366 x 768 native resolution
Graphics/Video Memory: ATI Mobility Radeon HD 4225/256MB
Wireless: 802.11b/g/n

This has about 50% to 100% better CPU performance to the Atom in the eeePC 1000, but a shorter battery life. A bit bigger than most netbooks, a bit smaller than most small laptops.  ::)

I shrunk the Windows 7 partition and installed both Fedora 14 and (of course!) TinyCore.  At first, the display was badly stretched by the xvesa graphics (xvesa seems to top out at 1024x768).  I installed Xorg 7.5 "confless" and it was able to open up in the native 1366x768 resolution.  However, there are some issues related to X:

1) I don't have any visible text if I leave X and go to the bare console (black screen).  I can blindly type "startx" and get back into X, but that kind of makes it hard to run a text-only app, such as the xconfig utility.  Adding a vga boot code in my grub menu.lst entry didn't help.  Other ideas?

2) The synaptic touchpad works at a basic level, but in Windows 7 and Fedora 14, if you swipe along the right edge or bottom, you will get vertical and horizontal scrolling, respectively (like two-finger scrolling in the eeePC).  I'd like to get that touchpad feature working in Tinycore.

3) I think the full hardware acceleration is not working:


--- Code: ---[drm] failed to load kernel module "radeon"
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.
(II) RADEON(0): using shadow framebuffer

--- End code ---

Another issue: battery life in TC is pretty short... not much more than 3 hours.  I think I can get over 4 in Fedora and Windows.  Those other OSes probably use CPU speed management automatically.  I need to try to install the TC extensions to better manage the CPU speed and power consumption.  

If anyone has advice in any of these areas, I'd appreciate hearing about it. Thanks!
--
Mike Lockmoore

jls_legalize:
for the touchpad search synaptics in the forum
for the video card try loading firmware.tcz

MikeLockmoore:
@jls_legalize: The firmware.tcz did not help, but thanks for suggesting something.

So, I tried the ati-fglrx.tcz driver.  It requires installation of source, building a required component, then installing the ati-fglrx.tcz and running a command-line configuration tool.  Since I could not see any text in my pure text console, that was a little tricky. :P  But I put the command-line into a little script with a short name that would be easier to type blindly.  That worked!  ;D  But don't forget the last step in the instructions provided in the ati-fglrx.tcz info file... you need to make the /etc/X11/xorg.conf file persistent.  I forgot and needed to backtrack and redo most of it a second time.  :-[

Now I have the ati-fglrx driver running, scrolling in Firefox seems pretty smooth and flash video seems smoother.  I ran glxgears and was getting more than 1600 frames/sec in the default small window, and about 220 frames/sec when the animation window was maximized (1366 x 768 pixels).  I have not benchmarked many other setups, but that seems OK to me.

Next up... see if I can get the edge-scrolling working with the Synaptics touchpad.

MikeLockmoore:
OK, I got the touchpad edge scrolling to work!  :D

I tried running Xorg -configure outside of X, but that crashed.  I tried to check my Fedora 14 installation, but it is also running confless (no xorg.conf file to reveiw).  I could not get X to _stop_ running in Fedora.  If you kill X, it comes right back, and if you try "telinit 3" is does not seem to work either....

Anyway, I just decided to plow ahead with some generic synapics setup, hoping mine would be fairly standard.  This worked:


--- Code: ---Section "InputDevice"
Identifier "Touchpad"
Driver   "synaptics"
Option "Device"   "/dev/psaux"
Option "Protocol" "auto-dev"
Option "SHMConfig" "true"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
Option "VertEdgeScroll"    "1"
Option "VertScrollDelta"  "45"
Option "HorizEdgeScroll"   "1"
Option "HorizScrollDelta" "45"
EndSection

--- End code ---


I'll attach my entire xorg.conf in case it is useful to anyone in the future.

I saw some notes in various web pages I saw about how to disable the touchpad while typing, or completely if there is a mouse plugged in. I'd like to get those to work too, but I think it requires some additional daemon(s) running with who knows what dependencies, so that is not a real high priority right now.

Next, maybe I can try some power management stuff.  I wonder if my AMD Neo is well supported.  :-\

EDIT: The xorg.conf I first posted here only recognized the touchpad, not a USB mouse plugged in. The attached xorg.conf now works with a plugged-in mouse.

tinypoodle:
Umm, at the risk of stating the obvious, but have you excluded that disabling the touchpad could be achieved with buttons (e.g. Fn+F?)?

Navigation

[0] Message Index

[#] Next page

Go to full version