WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Toshiba Satellite T215D  (Read 9007 times)

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 501
  • Good software needn't be big!
Toshiba Satellite T215D
« on: January 21, 2011, 02:23:17 PM »
The ASUS eeePC 1000 I had been using at work died several months back.  :'( Motherboard got a little flaky... some trace seemed cracked or something... if you pressed on part of the motherboard a little, it would shut down.

Anyway, I was assigned a Toshiba Satellite T215 as a replacement.  Here are some specs:

CPU: 1.7-GHz AMD Athlon II Neo Processor K125
RAM/Upgradeable to: 2GB/8GB
Hard Drive Size/Speed: 250GB/5,400 rpm
Display Size/Resolution: 11.6 inches / 1366 x 768 native resolution
Graphics/Video Memory: ATI Mobility Radeon HD 4225/256MB
Wireless: 802.11b/g/n

This has about 50% to 100% better CPU performance to the Atom in the eeePC 1000, but a shorter battery life. A bit bigger than most netbooks, a bit smaller than most small laptops.  ::)

I shrunk the Windows 7 partition and installed both Fedora 14 and (of course!) TinyCore.  At first, the display was badly stretched by the xvesa graphics (xvesa seems to top out at 1024x768).  I installed Xorg 7.5 "confless" and it was able to open up in the native 1366x768 resolution.  However, there are some issues related to X:

1) I don't have any visible text if I leave X and go to the bare console (black screen).  I can blindly type "startx" and get back into X, but that kind of makes it hard to run a text-only app, such as the xconfig utility.  Adding a vga boot code in my grub menu.lst entry didn't help.  Other ideas?

2) The synaptic touchpad works at a basic level, but in Windows 7 and Fedora 14, if you swipe along the right edge or bottom, you will get vertical and horizontal scrolling, respectively (like two-finger scrolling in the eeePC).  I'd like to get that touchpad feature working in Tinycore.

3) I think the full hardware acceleration is not working:

Code: [Select]
[drm] failed to load kernel module "radeon"
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.
(II) RADEON(0): using shadow framebuffer

Another issue: battery life in TC is pretty short... not much more than 3 hours.  I think I can get over 4 in Fedora and Windows.  Those other OSes probably use CPU speed management automatically.  I need to try to install the TC extensions to better manage the CPU speed and power consumption.  

If anyone has advice in any of these areas, I'd appreciate hearing about it. Thanks!
--
Mike Lockmoore
« Last Edit: January 22, 2011, 08:03:31 PM by MikeLockmoore »

Offline jls_legalize

  • Hero Member
  • *****
  • Posts: 1329
    • Core17
Re: Toshiba Satellite T215
« Reply #1 on: January 21, 2011, 06:18:25 PM »
for the touchpad search synaptics in the forum
for the video card try loading firmware.tcz
legalize them                                     ThisIsNotlYnuCsfrOmscR-Etch

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 501
  • Good software needn't be big!
Re: Toshiba Satellite T215
« Reply #2 on: January 22, 2011, 01:02:10 PM »
@jls_legalize: The firmware.tcz did not help, but thanks for suggesting something.

So, I tried the ati-fglrx.tcz driver.  It requires installation of source, building a required component, then installing the ati-fglrx.tcz and running a command-line configuration tool.  Since I could not see any text in my pure text console, that was a little tricky. :P  But I put the command-line into a little script with a short name that would be easier to type blindly.  That worked!  ;D  But don't forget the last step in the instructions provided in the ati-fglrx.tcz info file... you need to make the /etc/X11/xorg.conf file persistent.  I forgot and needed to backtrack and redo most of it a second time.  :-[

Now I have the ati-fglrx driver running, scrolling in Firefox seems pretty smooth and flash video seems smoother.  I ran glxgears and was getting more than 1600 frames/sec in the default small window, and about 220 frames/sec when the animation window was maximized (1366 x 768 pixels).  I have not benchmarked many other setups, but that seems OK to me.

Next up... see if I can get the edge-scrolling working with the Synaptics touchpad.

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 501
  • Good software needn't be big!
Re: Toshiba Satellite T215
« Reply #3 on: January 22, 2011, 08:03:04 PM »
OK, I got the touchpad edge scrolling to work!  :D

I tried running Xorg -configure outside of X, but that crashed.  I tried to check my Fedora 14 installation, but it is also running confless (no xorg.conf file to reveiw).  I could not get X to _stop_ running in Fedora.  If you kill X, it comes right back, and if you try "telinit 3" is does not seem to work either....

Anyway, I just decided to plow ahead with some generic synapics setup, hoping mine would be fairly standard.  This worked:

Code: [Select]
Section "InputDevice"
Identifier "Touchpad"
Driver   "synaptics"
Option "Device"   "/dev/psaux"
Option "Protocol" "auto-dev"
Option "SHMConfig" "true"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
Option "VertEdgeScroll"    "1"
Option "VertScrollDelta"  "45"
Option "HorizEdgeScroll"   "1"
Option "HorizScrollDelta" "45"
EndSection


I'll attach my entire xorg.conf in case it is useful to anyone in the future.

I saw some notes in various web pages I saw about how to disable the touchpad while typing, or completely if there is a mouse plugged in. I'd like to get those to work too, but I think it requires some additional daemon(s) running with who knows what dependencies, so that is not a real high priority right now.

Next, maybe I can try some power management stuff.  I wonder if my AMD Neo is well supported.  :-\

EDIT: The xorg.conf I first posted here only recognized the touchpad, not a USB mouse plugged in. The attached xorg.conf now works with a plugged-in mouse.
« Last Edit: January 24, 2011, 09:17:21 AM by MikeLockmoore »

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3795
Re: Toshiba Satellite T215D
« Reply #4 on: January 22, 2011, 10:24:50 PM »
Umm, at the risk of stating the obvious, but have you excluded that disabling the touchpad could be achieved with buttons (e.g. Fn+F?)?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 501
  • Good software needn't be big!
Re: Toshiba Satellite T215D
« Reply #5 on: January 24, 2011, 09:01:06 AM »
@tinypoodle: Well, for one thing, the key combo (Fn + F9) does not work in TinyCore 3.4, at least with my current configuration.  Plus, it would be nice if it was more automatic.  It's not so bad if you plug in the mouse and can just press the key combo once to disable the touchpad.  But it would be very annoying to be switching it on and off all the time if I need to use the trackpad for pointing, but also need to type often; say, when participating in this forum, or programming.  Just fer instances.  ;)

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 501
  • Good software needn't be big!
Re: Toshiba Satellite T215D
« Reply #6 on: January 24, 2011, 09:14:08 AM »
I have the power management working.  ;D  Now I should be able to squeeze 4+ hours out of this little guy, as I can with Fedora. (Quick update: From a fully charged battery, screen at its dimmest but still-visible setting, not running any active programs besides one aterm, the estimated battery life from Flit is about 5 1/2 hours! Under more realistic scenarios, I'd be happy with a solid 4+ hours.)

I installed cpufreqd.tcz + deps.  For the AMD Athlon II Neo Processor K125, I need to use the "powernow-k8.ko" driver to monitor and adjust the frequency.  I added the following to my /opt/bootlocal.sh file:

Code: [Select]
sudo modprobe /home/tc/bin/powernow-k8.ko
sudo modprobe cpufreq_conservative
sudo modprobe cpufreq_ondemand
sudo modprobe cpufreq_powersave
sudo modprobe cpufreq_userspace
sudo /usr/local/etc/init.d/cpufreqd start

The default cpufreqd.conf file is fairly complex, so I used the following version (I think it was from a Gentoo wiki) :
Code: [Select]
[General]
pidfile=/var/run/cpufreqd.pid
poll_interval=3
enable_plugins=acpi_ac, acpi_battery
enable_remote=1
remote_group=wheel
verbosity=5
[/General]

[Profile]
name=ondemand
minfreq=0%
maxfreq=100%
policy=ondemand
[/Profile]

[Profile]
name=conservative
minfreq=0%
maxfreq=100%
policy=conservative
[/Profile]

[Profile]
name=powersave
minfreq=0%
maxfreq=100%
policy=powersave
[/Profile]

[Profile]
name=performance
minfreq=0%
maxfreq=100%
policy=performance
[/Profile]

[Rule]
name=battery
ac=off
profile=conservative
[/Rule]

[Rule]
name=battery_low
ac=off
battery_interval=0-10
profile=powersave
[/Rule]

[Rule]
name=ac
ac=on
profile=ondemand
[/Rule]

Now, when running with light loads (most of the time), the CPU runs at 800 MHz, but will ramp up to 1.7 GHz when needed.
« Last Edit: January 24, 2011, 09:22:49 AM by MikeLockmoore »

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 501
  • Good software needn't be big!
Re: Toshiba Satellite T215D
« Reply #7 on: January 28, 2011, 09:47:40 PM »
Touchpad:  The suggestion I read to set up udev rules to handle managing the touchpad when a mouse plug/unplug event is detected did not work for me.  :P  So I wrote my own script.   ;D  At least the udev suggestion gave me the awareness of the synclient (Synaptics Client) utility so I can better manage this stuff.

Here is the script:
Code: [Select]
#!/bin/sh

old_have_mouse=0
while [ 1 ]; do
have_mouse=`cat /proc/bus/input/devices | grep -c "USB Optical Mouse"`
echo "have_mouse=$have_mouse"
if [ $have_mouse -eq 1 ]; then
if [ $old_have_mouse -ne $have_mouse ]; then
echo "Disabling touchpad"
# Disable the touchpad now, since there is now a mouse
synclient TouchpadOff=1
fi
else
if [ $old_have_mouse -ne $have_mouse ]; then
echo "Enabling touchpad"
# Re-enable the touchpad now, since the mouse is gone
synclient TouchpadOff=0
fi
fi
old_have_mouse=$have_mouse
sleep 3
done

Offline andriscom

  • Newbie
  • *
  • Posts: 32
Re: Toshiba Satellite T215D
« Reply #8 on: March 05, 2011, 06:00:16 AM »
Hi,

 I have a similar problem. When I try to load the kernel module for my CPU:

sudo /sbin/modprobe powernow-k8
modprobe: can't load module powernow-k8 (kernel.tclocal/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko.gz): No such device

 So actually it's not in the kernel.
 Where did you get the powernow-k8.ko from? I have a remastered MicroCore with 64bit kernel, so I think I cannot use the x86 version of this driver.

Edit: I have found out that hwmon-2.6.33.3-tinycore64.tcz should be the solution. I have extracted the file:
/usr/local/lib/modules/2.6.33.3-tinycore64/kernel/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko.gz

And tried to modprobe it:
sudo modprobe powernow-k8.ko
modprobe: can't load module powernow-k8.ko (kernel.tclocal/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko.gz): No such file or directory

What am I missing here?
« Last Edit: March 05, 2011, 06:38:53 AM by andriscom »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7611
Re: Toshiba Satellite T215D
« Reply #9 on: March 05, 2011, 06:30:15 AM »
The module message is very clear, the module is there, but you don't have such hardware.

edit: Maybe it's disabled in the bios. Maybe it's not supported by your bios. There are a lot of reasons why it would not detect a supported device.
« Last Edit: March 05, 2011, 06:31:52 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3795
Re: Toshiba Satellite T215D
« Reply #10 on: March 05, 2011, 06:32:49 AM »
Use microcore64.gz with 64bit kernel?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline andriscom

  • Newbie
  • *
  • Posts: 32
Re: Toshiba Satellite T215D
« Reply #11 on: March 05, 2011, 06:43:09 AM »
The CPU Freq scaling is working under Ubuntu, so it's supported and enabled in BIOS.

I have the proper CPU for powernow-k8 driver:

cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 107
model name      : AMD Athlon(tm) Dual Core Processor 5050e

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3795
Re: Toshiba Satellite T215D
« Reply #12 on: March 05, 2011, 06:54:36 AM »
I have extracted the file:
/usr/local/lib/modules/2.6.33.3-tinycore64/kernel/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko.gz

And tried to modprobe it:
sudo modprobe powernow-k8.ko
modprobe: can't load module powernow-k8.ko (kernel.tclocal/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko.gz): No such file or directory

What am I missing here?

depends:        freq_table?
'depmod -a'?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline andriscom

  • Newbie
  • *
  • Posts: 32
Re: Toshiba Satellite T215D
« Reply #13 on: March 05, 2011, 07:21:48 AM »
I have extracted the file:
/usr/local/lib/modules/2.6.33.3-tinycore64/kernel/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko.gz

And tried to modprobe it:
sudo modprobe powernow-k8.ko
modprobe: can't load module powernow-k8.ko (kernel.tclocal/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko.gz): No such file or directory

What am I missing here?

depends:        freq_table?
'depmod -a'?


Oh... you were right. freq_table was missing.
Now I have modprobed freq_table and I've got the No Such device again for powernow-k8... :(

sudo /sbin/modprobe powernow-k8
modprobe: can't load module powernow-k8 (kernel.tclocal/arch/x86/kernel/cpu/cpufreq/powernow-k8.ko): No such device

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6129
Re: Toshiba Satellite T215D
« Reply #14 on: March 05, 2011, 08:25:39 AM »
you don't need to extract powernow-k8.ko.gz, it will modprobe as it is