WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: nfs "server" problems  (Read 3354 times)

Offline Mork

  • WikiUser
  • *
  • Posts: 6
nfs "server" problems
« on: November 27, 2010, 10:51:43 AM »
I just kicked out my "freenas" and trying to get TCL 3.3 to do the work instead.
I'm using mdadm to create a stripe ext4 mounted on /mnt/md0.

Installed the nfs-utils and created the folder /mnt/md0/Dreambox did a chmod 777 on the folder to gain acces for everybody.

My /etc/exports is as follows

# /etc/export

/mnt/md0/Dreambox *(rw,insecure,all_squash,anonuid=65534,anongid=65535)

this should give when trying to mount the share as root on the client a nobody user and group at the server

At the client
root@dm800:~# mount -t nfs 192.168.2.222:/mnt/md0/Dreambox /media/nfs

gives :

mount: 192.168.2.222:/mnt/md0/Dreambox failed, reason given by server: Permission denied
mount: nfsmount failed: Bad file descriptor
mount: Mounting 192.168.2.222:/mnt/md0/Dreambox on /media/nfs failed: Invalid argument

What I'm I doing wrong ?

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: nfs "server" problems
« Reply #1 on: November 27, 2010, 11:28:20 AM »
Did you run "/usr/local/etc/init.d/nfs-server start" on the server after mounting your RAID?

Offline Mork

  • WikiUser
  • *
  • Posts: 6
Re: nfs "server" problems
« Reply #2 on: November 27, 2010, 12:28:14 PM »
Yes, runing that after mdadm and after smb even ;-)

 I'm thinking if it might be some problems with nfsd but I'm to much of a novice in nfs to be sure

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: nfs "server" problems
« Reply #3 on: November 27, 2010, 12:34:47 PM »
Did you install the filesystems-2.6.33.3-tinycore.tcz extension?  Since it is not needed to mount as a client, it is not installed by default when nfs-utils is installed but instead mentioned in the info file since it is only required for use as an nfs server.  It has the needed nfsd module.

Offline Mork

  • WikiUser
  • *
  • Posts: 6
Re: nfs "server" problems
« Reply #4 on: November 27, 2010, 11:31:59 PM »
Thanks Jason!

I should stand in the RTFM corner.

Now it works

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: nfs "server" problems
« Reply #5 on: November 28, 2010, 03:38:12 AM »
Actually, I had almost forgotten that another package outside of nfs-utils is needed for the server use, and probably every other distro has all it needs for nfs serving contained in the nfs-utils package (with deps) and the default kernel.  Easy to overlook.

Glad to hear it works now.

Nanu-nanu.