Tiny Core Extensions > TCE Q&A Forum

Configure Mplayer display?

(1/2) > >>

paulfxh:
I'm running TC in PPI/TCE mode on an Asus EeePC 901.
Mplayer works fine in playing video with sound other than I cannot seem to be able to increase the video screen size. This seems to be stuck at something like 200x120.
Right-clicking on the Settings button does however allow me to choose various screen sizes. However, the actual video display size remains the same. Only the surrounding black area increases in size even up to fullscreen.
I can find nothing in the Mplayer preferences that would allow me  to specify a default display screen size and there are no ~/.mplayer/config or /etc/mplayer/mplayer.conf files.
I should mention that I installed the Mplayer-svn-gtk2.tce

Jason W:
That Mplayer as well as the gtk1 version uses the X11 driver and not XV so the behavior you see is normal.  You can start mplayer by the command line and use the -zoom and/or -fs option to be able to view the video at full screen size.  I am on Windows at work now but will try those commands later but I think they are correct. 

Also, this would belong in the TCE extensions area instead of base.

paulfxh:

--- Quote from: Jason W on February 17, 2009, 03:52:33 PM ---That Mplayer as well as the gtk1 version uses the X11 driver and not XV so the behavior you see is normal.  You can start mplayer by the command line and use the -zoom and/or -fs option to be able to view the video at full screen size.  I am on Windows at work now but will try those commands later but I think they are correct. 
--- End quote ---
Thank you for the reply.
I used the command

--- Code: ---mplayer -zoom myvideo.avi
--- End code ---
and indeed this allowed me to drag the display size to whatever I wanted. Certainly, this is a lot better but not ideal as I would prefer that the display just went immediately to my preferred size. BTW, using the -fs switch as in

--- Code: ---mplayer -fs myvideo.avi
--- End code ---
just gave me the same tiny 160x120 display (undraggable) in the middle of fullscreen black. Not good  :(
When you say that this behaviour is normal for the gtk versions of Mplayer, does this mean that I should try the Xorg version?


--- Quote from: Jason W on February 17, 2009, 03:52:33 PM ---Also, this would belong in the TCE extensions area instead of base.

--- End quote ---
Uh-oh  :-[ Perhaps you or another mod might want to move it to the correct section.

Jason W:
To have full Mplayer functionality then the Xorg Mplayer is best.  I have tried three times to update the GTK Mplayers and incorporate Xorg functionality into them but they are too buggy to be useful.  The underlying Mplayer that results from the build works fine at the command line though.  Perhaps when there is a stable release the GTK part will be less buggy. 

I am testing some TCL/TK front ends to Mplayer that are a little buggy but could be useful.  I don't mind using the command line but at the end of the day when I just want to watch video or hear music I like to point and click as much as anyone else.

As for moving the topic I don't seem to have the ability, but Hats usually takes care of that well enough.

curaga:
You'll need to use both -zoom and -fs to have a zoomed full screen display.
And to automate these, you would create the file ~/.mplayer/config with something like
--- Quote ---# Write your default config options here!
fs=yes
zoom=yes
framedrop=yes
--- End quote ---
Adding framedrop is a good choice, because it allows smooth playback even when your system is too slow to play a video (say, fullHD h.264)

Navigation

[0] Message Index

[#] Next page

Go to full version