Tiny Core Extensions > TCE Bugs

installed realvnc - needs perl and vncpasswd in PATH


I installed realvnc.tce and tried to start it per the man page. I looked around for it but could not find where it was installed. Looks like it needs environment variables set among other things.

edit: Ok realvnc installs vnc4xxxxx programs in /usr/local/bin. Looks like there is an unresolved dependency with perl so I installed the perl extension which then enabled "vnc4server start" to run and complain vncpasswd must be run to setup the password which is what the man page says will happen so that's good. However, after I set the password the vnc4server would not start due to an error about "couldn't find "vncpasswd" on your PATH. Not sure how to fix this so will try this another day.


--- Quote ---couldn't find "vncpasswd" on your PATH.
--- End quote ---
I see what you are talking about...this is because there is no "vncpasswd" file, it is called vnc4passwd. The vnc4server script is calling for vncpasswd instead of vnc4passwd. You can create a symlink of vncpasswd to vnc4passwd to work around this or you can set the password before running vnc4server....but the script should be changed to look for the correct file. I can get to this either later today or tomorrow. Though once that is done Xvnc4 will complain about not being able to find fonts because it is looking in the wrong place again. Xvnc4 is not using the fontpath and is looking in /usr/share/fonts/X11. Again for a work around you can create a symlink of /usr/share/fonts/X11 to /usr/lib/X11/fonts...though this will need to take a little thought on the best way to fix this.

Edit: forgot to address the perl issue
This package is dependent upon perl_xml.tce. I will need to create a .dep file for it.

I edited the vnc4server file so it will look in the correct places. I tested this with "base norestore" options and loaded perl5.tcel and it worked. I submitted the new extension with the proper .dep and these edits to the script.


[0] Message Index

Go to full version