WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: gimp2 installs but does not run  (Read 3804 times)

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
gimp2 installs but does not run
« on: January 21, 2009, 05:00:40 PM »
Installed the gimp2.tczl extension. It created an icon and menu entry but would not run from either place.

---------------------
edit: Tried gimp(1) works great!
« Last Edit: January 21, 2009, 05:09:55 PM by bigpcman »
big pc man

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14622
Re: gimp2 installs but does not run
« Reply #1 on: January 21, 2009, 11:44:01 PM »
I tested this booting "tc base norestore nolocal", creating a folder /tmp/test and copying gimp2.tczl, gimp2.tczl.dep, glib2.tczl, gtk+-2.tczl, expat2.tczl, fontconfig.tczl, graphics-libs-1.tczl, libxml2.tczl, ttf-bitstream-vera.tcz, gegl.tczl, librsvg.tczl & libwmf.tczl to the folder.

Note that I should also have copied libxslt.tczl, lcms.tczl, libmng.tczl & poppler.tczl to /tmp/test, but I couldn't find them from the command line, so I removed them from the local copy of gimp2.tczl.dep for the purposes of the test.

I loaded gimp2.tczl from /tmp/test using the app browser and, although it complained about the missing libs, it worked:
Code: [Select]
$ gimp &
 LibGimpModule-Message: Module '/usr/local/lib/gimp/2.0/modules/libdisplay-filter-proof.so' load error: liblcms.so.1: cannot open shared object file: No such file or directory
 LibGimpModule-Message: Module '/usr/local/lib/gimp/2.0/modules/libdisplay-filter-lcms.so' load error: liblcms.so.1: cannot open shared object file: No such file or directory
 LibGimpModule-Message: Module '/usr/local/lib/gimp/2.0/modules/libcolor-selector-cmyk.so' load error: liblcms.so.1: cannot open shared object file: No such file or directory
 /usr/local/lib/gimp/2.0/plug-ins/file-jpeg: error while loading shared libraries: liblcms.so.1: cannot open shared object file: No such file or directory
 
 (gimp:4552): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
 /usr/local/lib/gimp/2.0/plug-ins/file-mng: error while loading shared libraries: libmng.so.1: cannot open shared object file: No such file or directory
 
 (gimp:4552): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
 /usr/local/lib/gimp/2.0/plug-ins/file-pdf: error while loading shared libraries: libpoppler-glib.so.4: cannot open shared object file: No such file or directory
 
 (gimp:4552): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
 /usr/local/lib/gimp/2.0/plug-ins/lcms: error while loading shared libraries: liblcms.so.1: cannot open shared object file: No such file or directory

..but now I see the problem - lcms.tczl and libmng.tczl do not exist, and libxslt-1.1.24.tczl needs to be renamed to libxslt.tczl (or I need to rename it in the dep file).
« Last Edit: January 23, 2009, 10:13:30 PM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14622
Re: gimp2 installs but does not run
« Reply #2 on: January 23, 2009, 10:45:10 PM »
OK, so lcms and libmng are now included in graphics-libs-1 (thanks Jason) and libxslt-1.1.24 is re-named to libxslt (thanks Curaga) and I have adjusted the dep file for gimp2 to suit.

In local testing, booting "tc boot norestore nolocal"  gimp2.tczl loads the new dependency list and works.