Tiny Core Extensions > TCE Bugs

(solved) getflash.tce does not work with minefield-as-tcz

(1/5) > >>

i usually install the getflash tce but don't run it, then copy the two *fl* files needed to /usr/local/firefox/plugins then flash is installed.

that's fine for minefield as tce, but as tcz, while it creates that path in the usual place, it only uses the path under the read-only /tmp/tcloop path.

attempting to create a symlink made no difference, as you cannot create a symlink in a read-only path. so i tried unmounting the minefield loop, creating the path under /tmp/tcloop, then remounting the tcz. (remounting the tcz is its own adventure.)

not surpisingly, this also did not work. right now, i'm trying to see if it's possible (i'm experimenting, more than i am asking) to get minefield installed as tce, despite it already being installed as a tcz. then perhaps i can use flash. the way you trick the tce system into loading tce's it's already loaded as tcz is to rename the tce you're trying to load to another name, like ff.tce.

i believe the way to fix this is simple. in the tcz version of minefield, do not create the plugins directory in the loop. it already (somehow) creates the proper plugins directory under /usr/local, so create a plugins symlink in the loop to the actual /usr/local/firefox/plugins directory.

as i said i tried it already, but it must be done in the plugin when it is created, once opened it is read-only. the way it is at the moment ought to prevent any plugins from being installed... probably less than desirable.

no longer applicable: the closest thing to a fix (not 100% tcz) is to download minefield.tce, rename to ff.tce, then install local ff.tce. even if you installed the rest of the extension from tcz this should let you get flash working, but i still think a symlink for plugins would be better for the next version of the minefield tcz if there is one.

Another option is to install the plugin in your home directory.  I don't know how close Minefield is to Firefox, but it should still create a configuration directory. You can try  to create a plugins directory there.

With Firefox: $HOME/.mozilla/plugins
I'm just assuming it should work the same with Minefield.

I thought you don't need to install getflash if you've already generated the flash9 tce extension?

For now, if you still want a system-wide workaround, you should be able to remove the first symlink that points to /tmp/tcloop because it is on a RW fs, and then create the directory.

mikshaw: Minefield is fx, but unbranded (only official builds get the name afaik)

[MOVED thread to TCE Bugs]

sorry, i was sure i posted this in tce bugs, i meant to.

there's nothing rw about the plugins folder in the minefield tcz. if it was that simple, i would just copy the files there. that was the first thing i tried to do, as root. actually if you mount | grep loop | grep rw you get nothing.

there is no removing or symlinking i can do. the closest thing to a solution is to install most of minefield as a tcz, then i have to use renaming to trick tc into letting me install the single minefield.tce file. but that means i can't uninstall it without a reboot.

as for why install getflash, i ran that to see if it helped, but it didn't. as for just copying the two *fl* files to plugins (when it's tce anyway...) i know that's supposed to be enough, but at the very least, i get no sound that way (even with sound on from the oss menu.) installing but not running the getflash tce seems to help, i've never taken it apart to find out why.

edit: thanks mikshaw, i'll try that, even though the getflash plugin still isn't going to work for tcz users. they're going to need to use your manual solution, but it's far preferable to what i'm doing, and more resource efficient. i'll reboot before i attempt it.

thought you were trying to do something else.. didn't think you were trying to write directly on /tmp/tcloop

As for getflash, I have no idea why that would change things, but the generated flash9.tce extension should probably be flash9.tcel to (auto)run ldconfig after.

The only problem for ~/.mozilla/plugins is that it will be only there for that user (and not for the whole system).


[0] Message Index

[#] Next page

Go to full version