WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: No booting with fbdev  (Read 110 times)

Online wysiwyg

  • Full Member
  • ***
  • Posts: 122
No booting with fbdev
« on: January 26, 2015, 06:48:55 AM »
Good morning everyone!  This post is to work on a specific issue mentioned from another post:

http://forum.tinycorelinux.net/index.php/topic,17906.0.html

I was having problems booting the x86_64 using FBDev instead of X.  I would like to get this working as there are several projects that can utilize the more efficient framebuffer instead of full X.

Basically I was left with a missing /dev/fb0 file.  Any thoughts?

Thanks,
Dave

Offline core-user

  • Jr. Member
  • **
  • Posts: 67
  • Linux since 1999
Re: No booting with fbdev
« Reply #1 on: January 26, 2015, 07:27:59 AM »
Found here - http://lists.mplayerhq.hu/pipermail/mplayer-users/2003-September/037832.html

Code: [Select]
mknod /dev/fb0 c 29 0as root often helps.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6789
Re: No booting with fbdev
« Reply #2 on: January 26, 2015, 07:30:57 AM »
You could try booting to a console (boot code "text"), checking that Xfbdev is loaded and then using the first line of ~/.xsession to start X, rather than "startx" - this might come up with an error message that would give a clue to the problem.

Online wysiwyg

  • Full Member
  • ***
  • Posts: 122
Re: No booting with fbdev
« Reply #3 on: January 26, 2015, 08:07:08 AM »
@core-user thanks for the info.  I actually looked in the /dev directory and see the correct fb0 file being created...

@Juanito I adjusted the boot parameters per your suggestion and this is what I get:

$ ./.xsession
./.xsession: line 1: /usr/local/bin/Xorg: not found
Giving up.
failed in waitforX

I have confirmed that no such file or directory exists.  Why would it be looking for Xorg if it should be using XFBDev?

Dave

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6789
Re: No booting with fbdev
« Reply #4 on: January 26, 2015, 08:10:36 AM »
normally when you load the Xvesa, Xfbdev or Xorg-* extensions the first line of ~/.xsession is modified to suit.

Perhaps you need to try startx once and then check ~/.xsession

..but what I meant was to manually type and execute the first line of ~/.xsession, not to execute ~/.xsession itself.
« Last Edit: January 26, 2015, 08:12:54 AM by Juanito »

Online wysiwyg

  • Full Member
  • ***
  • Posts: 122
Re: No booting with fbdev
« Reply #5 on: January 26, 2015, 08:28:03 AM »
@Juanito sorry for the misunderstanding, here's what I got...


$ head -1 .xsession
/usr/local/bin/Xfbdev -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null 2>&1
$/usr/local/bin/Xfbdev -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null
Error opening framebuffer /dev/fb0: No such device

Fatal server error:
no screens found
$ ls /dev/fb0
/dev/fb0

It looks like the device file is there, but is unable to be used for some reason.  Permissions are 622 and ownership is root:staff.

Dave

Online wysiwyg

  • Full Member
  • ***
  • Posts: 122
Re: No booting with fbdev
« Reply #6 on: January 26, 2015, 04:47:47 PM »
Is there a reason why Xfbdev wouldn't be able to use the /dev/fb0 file?  I don't think there's a permissions issue...  Any logs that I can see that might provide a clue as to where the problem is occurring?  Could it be a driver issue?  I'm loading the firmware-radeon extension first in the onboot.lst file.

Dave

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 8088
Re: No booting with fbdev
« Reply #7 on: Today at 01:44:50 AM »
Please post your dmesg (pastebin.com, etc). Are you loading graphics- onboot?
The only barriers that can stop you are the ones you create yourself.

Online wysiwyg

  • Full Member
  • ***
  • Posts: 122
Re: No booting with fbdev
« Reply #8 on: Today at 06:37:47 AM »
Please post your dmesg (pastebin.com, etc). Are you loading graphics- onboot?

http://pastebin.com/jcVPCe5s

No sure what you mean regarding the loading of graphics onboot?  Here's my current onboot.lst for that boot option:

firmware-radeon.tcz
Xfbdev.tcz
Xlibs.tcz
Xorg-fonts.tcz
Xprogs.tcz
aterm.tcz
fltk-1.3.tcz
flwm.tcz
freetype.tcz
glib2.tcz
harfbuzz.tcz
imlib2-bin.tcz
imlib2.tcz
libICE.tcz
libSM.tcz
libX11.tcz
libXau.tcz
libXdmcp.tcz
libXext.tcz
libXfont.tcz
libXi.tcz
libXmu.tcz
libXpm.tcz
libXrandr.tcz
libXrender.tcz
libXt.tcz
libffi.tcz
libfontenc.tcz
libjpeg-turbo.tcz
libpng.tcz
libxcb.tcz
pcre.tcz
wbar.tcz

Each of those files are also located in the 'optional' directory.

Thanks,
Dave

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3541
Re: No booting with fbdev
« Reply #9 on: Today at 07:25:44 AM »
AGP: Checking aperture...
AGP: No AGP bridge found
AGP: Node 0: aperture [bus addr 0x00000000-0x01ffffff] (32MB)
AGP: Your BIOS doesn't leave a aperture memory hole
AGP: Please enable the IOMMU option in the BIOS setup
AGP: This costs you 64MB of RAM
AGP: Mapping aperture over RAM [mem 0x84000000-0x87ffffff] (65536KB)

Online wysiwyg

  • Full Member
  • ***
  • Posts: 122
Re: No booting with fbdev
« Reply #10 on: Today at 08:29:21 AM »
I enabled IOMMU support in the BIOS, rebooted, but no changes.  Doing a quick look on IOMMU, it appears that it is related to virtual hardware for VM's.  I'm not running anything like that, just one simple OS. :)

Dave