WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: HOWTO: set keymaps in rdesktop  (Read 7212 times)

Offline flopsymopsy

  • Newbie
  • *
  • Posts: 3
HOWTO: set keymaps in rdesktop
« on: October 09, 2009, 05:17:24 PM »
Save some pain.....discovered that kmaps.tce loaded and bootlocal.sh containing loadkmap......etc worked ok within a terminal and Opera but rdesktop still using en-us keymap.

Solution = rdesktop needs -k en-gb, or appropriate keymap ( list found in /usr/local/share/rdesktop/keymaps/ ) passed to it.

eg. rdesktop -k en-gb ip/address/of/windoze/box

PS. I love this distro......thanks Robert !!!
« Last Edit: October 09, 2009, 05:19:38 PM by flopsymopsy »

Offline Güney Koreli

  • Newbie
  • *
  • Posts: 2
Re: HOWTO: set keymaps in rdesktop
« Reply #1 on: April 02, 2011, 06:42:39 AM »
I have a problem Rdesktop with Turkish keymap. I am pressing "ı", Windows is writing "y". While Caps Lock is on, I am pressing "Ğ" and "Ş" , Windows is writing "ğ", "ş".



Offline Pats

  • Full Member
  • ***
  • Posts: 172
Re: HOWTO: set keymaps in rdesktop
« Reply #2 on: April 09, 2011, 04:45:55 AM »
1)Change the keyboard itself ( may be from a friend ), and ee if the problem is solved.
2)Try lang=  option with appropriate bootcode keymap.
3)Try proper keyboard extension.
Maybe it helps !

~ Pats