WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: mc 2.3R2 ossxmix issue  (Read 3253 times)

Offline alu

  • Sr. Member
  • ****
  • Posts: 429
mc 2.3R2 ossxmix issue
« on: August 28, 2009, 10:27:55 AM »
loading ossmix, get the following error

tc@box:~$ ossxmix
ossxmix: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory

as well, the following command don't work:

tc@box:~$ ossmix vol +25
Bad mixer control name(765) 'vol'

don't find the ossvol file in order to change the parameters

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 525
  • Good software needn't be big!
Re: mc 2.3R2 ossxmix issue
« Reply #1 on: August 28, 2009, 10:39:53 AM »
My new app Flit uses ossmix to get and set the volume, in a way similar to your commandline example (but in absolute percentage, not relative).  Is the failure because ossmix was updated?  Or TC?  I'd like to know if I need to make Flit work differently re. ossmix.
--
ML

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: mc 2.3R2 ossxmix issue
« Reply #2 on: August 28, 2009, 10:41:23 AM »
No base libraries have been changed in TC or MC.
10+ Years Contributing to Linux Open Source Projects.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: mc 2.3R2 ossxmix issue
« Reply #3 on: August 28, 2009, 10:58:55 AM »
loading ossmix, get the following error

tc@box:~$ ossxmix
ossxmix: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory

as well, the following command don't work:

tc@box:~$ ossmix vol +25
Bad mixer control name(765) 'vol'

don't find the ossvol file in order to change the parameters

This is an extension issue and not a Core issue.

ossxmix I believe is a gtk2 application.
OSS does not list any dependencies, however it would seem that ossxmix would require gtk2 as your missing file libgobject.... comes from glib2.tcel

However, I would certainly not want to see OSS require gtk2 simply for this one X  program.

If what I suspect is true, it would be better to offer ossxmix as a separate extension with OSS and Gtk2 as dependenices.
« Last Edit: August 28, 2009, 11:17:01 AM by roberts »
10+ Years Contributing to Linux Open Source Projects.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10959
Re: mc 2.3R2 ossxmix issue
« Reply #4 on: August 28, 2009, 12:36:58 PM »
However, I would certainly not want to see OSS require gtk2 simply for this one X  program.

If what I suspect is true, it would be better to offer ossxmix as a separate extension with OSS and Gtk2 as dependenices.
It is mentioned in the info file as the only part needing gtk2, and was included because it comes with the same source. I'm ok with it being separated as well.
The only barriers that can stop you are the ones you create yourself.

Offline alu

  • Sr. Member
  • ****
  • Posts: 429
Re: mc 2.3R2 ossxmix issue
« Reply #5 on: August 29, 2009, 04:13:51 AM »
thanks, i have added glib2 for now