WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: What do I need to do to get hifiberry DAC working on piCore14.1?  (Read 583 times)

Offline xdemy

  • Newbie
  • *
  • Posts: 7
RpiZero2W, piCore 14.1 (6.1.68) aarch64;

I use Pimoroni Audio DAC Shim (based on PCM5100A DAC chip);
On RaspbianOS its working fine and visible as:

aplay -l:
Code: [Select]
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac],
device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

This is what I see on my piCore :/
Code: [Select]
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: b1 [bcm2835 HDMI 1], device 1: bcm2835 HDMI 1 [bcm2835 HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I want to disable the hdmi audio and use DAC only :/
« Last Edit: January 09, 2024, 03:23:13 AM by xdemy »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: What do I need to do to get hifiberry DAC working on piCore14.1?
« Reply #1 on: January 09, 2024, 09:56:48 AM »
Hi xdemy
Go to this page:
https://forum.tinycorelinux.net/index.php?action=search
Set  Search order:   to   Most recent topics first.
Enter   hifiberry   in   Search for:

You should get about 2 dozen topics that mention  hifiberry.
See if any of those provide any useful information.

Offline xdemy

  • Newbie
  • *
  • Posts: 7
Re: What do I need to do to get hifiberry DAC working on piCore14.1?
« Reply #2 on: January 09, 2024, 11:30:08 AM »
I wouldn't ask this question if I could find any info which works in my case.
Mentioning "hifiberry" on other posts did not help me so far.
Any particular information I have missed? Perhaps you could direct me to a relevant one, or answer my question instead of writing the instruction how to use the search page and telling me that there are posts containing "hifiberry" word  :(

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 1078
Re: What do I need to do to get hifiberry DAC working on piCore14.1?
« Reply #3 on: January 09, 2024, 11:43:36 AM »
tinycore/picore is a toolkit.  Why don't you start by telling us what you have done.  If you have just burned an image, then you are a long way off.   

For configuration, you probably need to understand everything here

https://www.raspberrypi.com/documentation/computers/configuration.html


Offline xdemy

  • Newbie
  • *
  • Posts: 7
Re: What do I need to do to get hifiberry DAC working on piCore14.1?
« Reply #4 on: January 10, 2024, 04:22:03 PM »
The answer is:
Edit config.txt file on boot partition:
remove line:
Code: [Select]
dtparam=audio=onadd line:
Code: [Select]
dtoverlay=hifiberry-dac
That's all that has to be done to get it visible in "aplay -l" output and working.