WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: LAMP environment  (Read 15219 times)

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #60 on: April 27, 2022, 05:14:31 AM »
Hi Rich,

After I run php7.config I get an error that libmcrypt was not found so I compiled the extension using this link ( http://www.tinycorelinux.net/8.x/armv7/tcz/src/libmcrypt/)
and then I get some error from openssl using php7.config  so I put the result in build.txt .
It's fine

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: LAMP environment
« Reply #61 on: April 27, 2022, 01:50:56 PM »
Hi MrToga
... I get an error that libmcrypt was not found so I ...
Copy  libmcrypt.tcz , libmcrypt-dev.tcz , and  libmcrypt-dev.tcz.dep  from:
http://tinycorelinux.net/8.x/armv7/tcz/

Then:
Code: [Select]
tce-load -i libmcrypt-dev
This is the same version being used in the TC13 x86 and x86_64 repositories.

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #62 on: April 28, 2022, 04:59:53 AM »
Hi,
After I have dowloaded libmcrypt.tcz libmcrypt-dev.tcz and libmcrypt-dev.tcz.dep and add it in /mnt/mmblk0p2/tce/optional directory I tried to use the php7.config script but I get a bunch of error from openssl.c.
Here is the php7.config script and the build.txt (the return of the sript).

Any thougths ?
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14544
Re: LAMP environment
« Reply #63 on: April 28, 2022, 05:29:49 AM »
Did you load the libmcrypt-dev extension?

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #64 on: April 28, 2022, 05:33:47 AM »
Hi juanito,

Yes libmcrypt-dev is loaded
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14544
Re: LAMP environment
« Reply #65 on: April 28, 2022, 05:54:48 AM »
You could try loading coreutils to remove some of the errors.

Which version of openssl are you using - it looks like php is looking for a newer version?

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #66 on: April 28, 2022, 05:56:03 AM »
I'm currently using openssl 1.1.1
It's fine

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #67 on: April 28, 2022, 06:22:26 AM »
Hi,

After searching I found out that in the ./configure help openssl need to be in version 0.9.8 but the problem is that I need this version of openssl for my apache

Here the file from ./configure --help
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14544
Re: LAMP environment
« Reply #68 on: April 28, 2022, 07:03:40 AM »
Which version of php are you trying to compile - the versions in the x86_64 repo use openssl-1.1.1

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: LAMP environment
« Reply #69 on: April 28, 2022, 07:05:15 AM »
Hi MrToga
After I have dowloaded libmcrypt.tcz libmcrypt-dev.tcz and libmcrypt-dev.tcz.dep ...
I believe the  build.txt  you attached (reply #62) is the same file you attached to reply #60 and not a fresh file.

The new  php7.config file  shows you removed  --enable-so  option but the  build.txt  file you posted still contains this:
Code: [Select]
configure: WARNING: unrecognized options: --enable-so
I also ran a  diff  on the 2  build.txt  files and they are identical.


... openssl need to be in version 0.9.8 ...
No, it says:
Code: [Select]
  --with-openssl=DIR      Include OpenSSL support (requires OpenSSL >= 0.9.8)That means  0.9.8  is the minimum version, so  1.1.1  is fine.

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #70 on: April 28, 2022, 07:24:29 AM »
Hi,
I'm compiling the php version of raspberry PI (here : http://www.tinycorelinux.net/8.x/armv7/tcz/src/php7/ ) and also I repost the same file because after compiling php7 I'll still have the same error than the last one sorry if it's disturb you .
But I found something in the build file:
Code: [Select]
/home/tc/php-7.0.8/ext/openssl/openssl.c:1923:15: error: invalid use of incomplete typedef 'X509_EXTENSION' {aka 'struct X509_extension_st'}
 1923 |  p = extension->value->data;
So with this I search in /usr/local/include/openssl/ossl_typ.h to see if the funxtion x509 is here.
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14544
Re: LAMP environment
« Reply #71 on: April 28, 2022, 08:09:07 AM »
php-7.4.14 builds on an RPi3 against openssl-1.1.1 and apache-2.4.46..
« Last Edit: April 28, 2022, 08:46:23 AM by Juanito »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: LAMP environment
« Reply #72 on: April 28, 2022, 08:12:08 AM »
Hi MrToga
Try changing this:
Code: [Select]
--with-openssl \To this:
Code: [Select]
--with-openssl-dir=/usr/local \
--with-openssl=shared,/usr/local \
in your  php7.config  file.

Also make sure  openssl-dev  is loaded.

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #73 on: April 29, 2022, 02:46:19 AM »
Hello guys,

After I wrote the commands Rich said I still have the same error, and I also tried a new version of php (php7.4.29.tar.xbz link:https: //www.php.net/downloads ) but in this new version he doesn't fin oniguruma during the comilation.
Here is the build.txt from the php7.0
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14544
Re: LAMP environment
« Reply #74 on: April 29, 2022, 02:53:28 AM »
I think you will need to build libonig and use php-7.4.14 - this is what I did on piCore-13.1 and it worked.