WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] RP4 eeprom update not working  (Read 2934 times)


  • Guest
[Solved] RP4 eeprom update not working
« on: August 18, 2020, 07:45:21 PM »

I attempted to follow Juanito's excellent post at my own risk.

Code: [Select]
SNIP out some stuff
Dedicated VL805 EEPROM detected

sudo vcgencmd bootloader_version
Apr 16 2020 18:11:26
version a5e1b95f320810c69441557c5f5f0a7f2460dfb8 (release)
timestamp 1587057086
# as purchased a few days

ls rpi-eeprom/firmware/stable/pieeprom*
# mount after reboot after edit of config

cat /mnt/mmcblk0p1/config.txt | grep dtpar

cat /mnt/mmcblk0p1/config.txt | grep dtoverlay
# dtoverlay=pi3-disable-bt
dtoverlay spi-gpio40-45

# I have a pi4 does that original config naming  pi3 look correct?

lsmod | grep spi
spidev                 20480  0
spi_bcm2835            20480  0

sudo flashrom -p "linux_spi:dev=/dev/spidev0.0,spispeed=16000" -w "pieeprom-2020-07-31.bin"
flashrom v1.2 on Linux 4.19.81-piCore-v7l (armv7l)
flashrom is free software, get the source code at https://flashrom.org

Using clock_gettime for delay loops (clk_id: 1, resolution: 1ns).
No EEPROM/flash device found.
Note: flashrom can never write if the flash chip isn't found automatically.

# hmmm maybe it has to be flashed and rebooted sequentially?
sudo flashrom -p "linux_spi:dev=/dev/spidev0.0,spispeed=16000" -w "pieeprom-2020-06-15.bin"
same error

Any clues?
« Last Edit: August 20, 2020, 10:43:17 AM by Rich »

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 1099
Re: RP4 eeprom update not working
« Reply #1 on: August 19, 2020, 09:36:36 AM »
To be honest, the easiest way would be up just use a RasPiOS image, then run a full update.  it automatically does the updates.   I have a procedure that uses the normal RasPiOS methods, but I need to update my git repo to include the latest firmwares.

Your question about the bluetooth overlay, yes, that still works.  When the pi4 came out they dropped the pi3 from the overlay names, but kept them as aliases for backwards compatability.

dtoverlay=pi3-disable-bt  is the same as



  • Guest
Re: RP4 eeprom update not working
« Reply #2 on: August 19, 2020, 05:32:07 PM »

Thanks for the heads up. I will look at that soonish and will update when I know more. I have been watching some youtubers so was aware of Rasparian/RasPiOS and mention had been made noobs is supposed to automate the eeprom stuff.

Allegedly updates will allow usb booting and claims of a temp drop too.

Congrats on Admin promotion, well deserved.


  • Guest
Re: RP4 eeprom update not working
« Reply #3 on: August 20, 2020, 06:40:53 AM »
I followed a tutorial for noobs/rasp*
It needed a file on the Debian system root edit to change setting from critical to stable.

Code: [Select]
tce-load -i rpi-vc
rpi-vc is already installed!
tc@rpi:~$ sudo vcgencmd bootloader_version
Jul 31 2020 14:43:39
version f8d1dc69144b10b4bd78b4b6d08658ac3005726d (release)
timestamp 1596203019
tc@rpi:~$ sudo rpi-eeprom/firmware/vl805
VL805 FW version: 000138a1

This step appears to be missing from the tutorial. And I can no longer tell if that was all that was stopping me.
There appear to be 2 text files that could rename critical but I am leaning towards just one.

I am so new at RPI I do not know if I am Arthur or Martha so I will let you decide if there is any merit in checking this allegation
And this suggestion is TIME BASED. At some point in time, updates that might be useful might reside in a diff  dir

Anyhow please mark as solved thanks
« Last Edit: August 20, 2020, 06:43:11 AM by aus9 »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11282
Re: [Solved] RP4 eeprom update not working
« Reply #4 on: August 20, 2020, 10:44:24 AM »
Hi aus9
... Anyhow please mark as solved thanks
Marked. :)