WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wifi on Linx 7 (rtl8723bs)  (Read 523 times)

Offline mdt01

  • WikiUser
  • *
  • Posts: 15
Re: wifi on Linx 7 (rtl8723bs)
« Reply #15 on: October 12, 2019, 08:41:18 AM »
Thanks. I am booting with no wifi related extensions loaded then doing the following:
Code: [Select]
tce-load -i firmware-rtlwifi
tce-load -i wifi
sudo mkdir /lib/modules/4.19.10-tinycore64/kernel/net/wireless
sudo cp /home/tc/tmp/linux-4.19.10/drivers/staging/rtl8723bs/r8723bs.ko  /lib/modules/4.19.10-tinycore64/kernel/net/wireless
sudo depmod -a
sudo modprobe r8723bs
sudo wifi.sh

which returns "No wifi devices found!"

The last few lines of dmesg are:
Code: [Select]
ACPI: AC: found native INT33F4 PMIC, not loading
ACPI: AC: found native INT33F4 PMIC, not loading
platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
platform regulatory.0: Falling back to syfs fallback for: regulatory.db
r8723bs: module is from the staging directory, the quality is unknown, you have been warned.
RTL8723BS: module init start
RTL8723BS: rtl8723bs v4.3.5.5_12290.20140916_BTCOEX20140507-4E40
RTL8723BS: rtl8723bs BT-Coex version = BTCOEX20140507-4E40
RTL8723BS: module init ret =0
cfg80211: failed to load regulatory.db

    [EDIT]: Added code tags.  Rich
« Last Edit: October 12, 2019, 08:57:24 AM by Rich »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11018
Re: wifi on Linx 7 (rtl8723bs)
« Reply #16 on: October 12, 2019, 10:13:58 AM »
If you load the crda extension before the firmware does that help?

Offline mdt01

  • WikiUser
  • *
  • Posts: 15
Re: wifi on Linx 7 (rtl8723bs)
« Reply #17 on: October 12, 2019, 10:46:55 AM »
Thanks, but loading the crda extension first has not helped.
Still "No wifi devices found!" and the last 10 lines of dmesg are identical to those shown above.

Offline mdt01

  • WikiUser
  • *
  • Posts: 15
Re: wifi on Linx 7 (rtl8723bs)
« Reply #18 on: October 12, 2019, 12:24:11 PM »
Not sure if this helps, but I noticed the lshw extension is now available on the 64 bit TC version so I ran it on TinyCore64 where the wifi is not found and compared it to the same command on Ubuntu where the wifi is found:

TinyCore64 output:

Code: [Select]
tc@box:~$ sudo lshw -c network
  *-network:0 DISABLED     
       description: Ethernet interface
       physical id: 1
       logical name: dummy0
       serial: e6:18:c3:b1:ab:77
       capabilities: ethernet physical
       configuration: broadcast=yes driver=dummy driverversion=1.0
  *-network:1
       description: Ethernet interface
       physical id: 2
       logical name: eth0
       serial: 00:e0:4c:68:c2:d7
       size: 100Mbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.9 duplex=full ip=192.168.1.6 link=yes multicast=yes port=MII speed=100Mbit/s


Ubuntu 16.04 output:

Code: [Select]
mdt01@Ubuntu16:~$ sudo lshw -c network
  *-network:0             
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 08:d8:33:6b:9d:b4
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs ip=192.168.1.17 multicast=yes wireless=IEEE 802.11bgn
  *-network:1
       description: Ethernet interface
       physical id: 2
       logical name: enx00e04c68c2d7
       serial: 00:e0:4c:68:c2:d7
       size: 100Mbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.9 duplex=full ip=192.168.1.6 link=yes multicast=yes port=MII speed=100Mbit/s

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11018
Re: wifi on Linx 7 (rtl8723bs)
« Reply #19 on: October 12, 2019, 09:59:33 PM »
You could try using rfkill to enable wifi.

Offline mdt01

  • WikiUser
  • *
  • Posts: 15
Re: wifi on Linx 7 (rtl8723bs)
« Reply #20 on: October 13, 2019, 06:36:23 AM »
Thanks. Regrettably no progress with rfkill.



Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11018
Re: wifi on Linx 7 (rtl8723bs)
« Reply #21 on: October 13, 2019, 06:44:32 AM »
Does it list your WiFi as disabled?

Offline mdt01

  • WikiUser
  • *
  • Posts: 15
Re: wifi on Linx 7 (rtl8723bs)
« Reply #22 on: October 13, 2019, 07:20:11 AM »
The wifi was not listed at all

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6839
Re: wifi on Linx 7 (rtl8723bs)
« Reply #23 on: October 13, 2019, 01:45:49 PM »
Hi mdt01
Thanks. I am booting with no wifi related extensions loaded then doing the following:
Code: [Select]
tce-load -i firmware-rtlwifi
tce-load -i wifi
sudo mkdir /lib/modules/4.19.10-tinycore64/kernel/net/wireless
sudo cp /home/tc/tmp/linux-4.19.10/drivers/staging/rtl8723bs/r8723bs.ko  /lib/modules/4.19.10-tinycore64/kernel/net/wireless
sudo depmod -a
sudo modprobe r8723bs
sudo wifi.sh
...

After you do that, do this:
Code: [Select]
dmesg > dmesg.txt
lsmod > lsmod.txt
and attach those files to your next post.

Offline mdt01

  • WikiUser
  • *
  • Posts: 15
Re: wifi on Linx 7 (rtl8723bs)
« Reply #24 on: October 14, 2019, 04:48:46 AM »
Thanks. Files attached.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11018
Re: wifi on Linx 7 (rtl8723bs)
« Reply #25 on: October 14, 2019, 05:29:30 AM »
If you load the crda extension and copy /usr/local/lib/crda/regulatory.bin to /usr/local/lib/firmware before loading r8723bs does that help?

or maybe:
Quote
If you have kernel version 4.15 or newer, the regulatory database format and location has been changed. It is now loaded using the same mechanism as the firmware files. The new files can be found at https://kernel.googlesource.com/pub/scm/linux/kernel/git/sforshee/wireless-regdb/ and you'll need two files, regulatory.db and regulatory.db.p7s. Place them into /lib/firmware/ directory.
« Last Edit: October 14, 2019, 05:42:53 AM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11018
Re: wifi on Linx 7 (rtl8723bs)
« Reply #26 on: October 14, 2019, 05:48:49 AM »
When I copy regulatory.db* to /usr/local/lib/firmware I get this:
Code: [Select]
$ dmesg
...
platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
platform regulatory.0: Falling back to syfs fallback for: regulatory.db
Intel(R) Wireless WiFi driver for Linux
Copyright(c) 2003- 2015 Intel Corporation
iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7260-17.ucode failed with error -2
iwlwifi 0000:02:00.0: Falling back to syfs fallback for: iwlwifi-7260-17.ucode
iwlwifi 0000:02:00.0: loaded firmware version 17.459231.0 op_mode iwlmvm
iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
iwlwifi 0000:02:00.0: base HW address: a0:a8:cd:2c:3e:13
ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'

..so that looks like the way to go?

Offline mdt01

  • WikiUser
  • *
  • Posts: 15
Re: wifi on Linx 7 (rtl8723bs)
« Reply #27 on: October 14, 2019, 07:32:43 AM »
Thanks. The second method in the above two posts, i.e. getting the files from the link in reply#25 and copying regulatory.*  to /usr/local/lib/firmware before loading r8723bs gets rid of the "cfg80211: failed to load regulatory.db" message. The last few lines of dmesg are now:
Code: [Select]
...
platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
platform regulatory.0: Falling back to syfs fallback for: regulatory.db
r8723bs: module is from the staging directory, the quality is unknown, you have been warned.
RTL8723BS: module init start
RTL8723BS: rtl8723bs v4.3.5.5_12290.20140916_BTCOEX20140507-4E40
RTL8723BS: rtl8723bs BT-Coex version = BTCOEX20140507-4E40
RTL8723BS: module init ret =0

However, the wifi is still not detected. sudo wifi.sh still says "No wifi devices found!" and iwconfig says "no wireless extensions".

This wifi module has an SDIO interface whereas most have a pci or pci-e interface, including Juanito's "Intel(R) Dual Band Wireless AC 7260".

Could there be something that supports the SDIO interface that we are missing?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11018
Re: wifi on Linx 7 (rtl8723bs)
« Reply #28 on: October 14, 2019, 08:13:14 AM »
You could check the tinycore lsmod with the other distro lsmod line by line to see if an sdio related driver is loaded.

What does modinfo rtl8732bs show?
« Last Edit: October 14, 2019, 08:14:51 AM by Juanito »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10040
Re: wifi on Linx 7 (rtl8723bs)
« Reply #29 on: October 14, 2019, 10:41:45 AM »
No, there is no generic sdio part that could be missing; a lot of supported wireless drivers have sdio options enabled. Tracking why the driver does not find your card would probably involve some kernel debugging, adding debug prints in the driver, etc.

edit: Well, unless the sdio host controller driver of your device was also in staging.
edit 2: Ubuntu's dmesg may have some clues too.

Also, this device seems to be one of the buggy ones:
https://en.wikipedia.org/wiki/Silvermont#Erratum
The USB, SD and LPC parts of the chip may die starting from 18 months of use. Yours has clearly not yet died if it works under Ubuntu, but good to keep in mind.
« Last Edit: October 14, 2019, 10:51:49 AM by curaga »
The only barriers that can stop you are the ones you create yourself.