WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TCL V10 Boot Problem  (Read 2695 times)

Offline gmc

  • Full Member
  • ***
  • Posts: 141
TCL V10 Boot Problem
« on: February 13, 2019, 08:35:28 PM »
I have a system that has been running TCL 4.7.7 without any problems for some years now.

I have a custom Xorg configuration that gives me a virtual desktop with multiple resolutions that I can easily switch between with Ctrl-Alt+ or Ctrl-Alt-.

I just tried to run (CD boot) the new TCL V10 on this machine and ran into a problem.  When I boot Tiny Core (not Plus), it boots almost to the desktop (GUI) and then black screens and stops.  It looks like there is an extremely short flash of the desktop just before the black screen.  I can drop to the CLI after the black screen/stop.  Boot code 'base' allows a full boot to GUI desktop, but without grabbing the Xorg settings from sda1.

I can boot TCL V9.0 and it imports the Xorg settings from version 4.7.7 on sda1 and I have my customized Xorg resolutions.

I have tried boot codes such as VGA=, xvesa=xxx,yyy,nn, and xsetup.  None of those affect the outcome in any noticeable manner (xsetup does not appear to do anything at all).  'Norestore' has no effect.

I have tried a number of other desktop Window Mangers from the menu (using TCL+), they all have the same outcome, that is to say, they boot to a black screen just before the GUI would normally load and then stop.

If I delete the version 4.7.7 files from sda1 and then boot version 10 I get the normal boot with GUI, but of course there is no customized Xorg.

I would like to keep the Xorg setup I already have in place.  If Xorg is the problem, how do I proceed?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: TCL V10 Boot Problem
« Reply #1 on: February 13, 2019, 08:49:05 PM »
Hi gmc
It sounds like it's finding your  tce  directory for version 4.7.7. I'm guessing some of those extensions are not compatible
with TC10. I would do an install to a separate partition including the TC10 versions of your current extensions and then
copy your  Xorg.conf  file over.

Offline gmc

  • Full Member
  • ***
  • Posts: 141
Re: TCL V10 Boot Problem
« Reply #2 on: February 14, 2019, 08:14:56 AM »
Thanks, that makes sense to me.  I was hoping to be able to narrow the problem down to a specific "thing" but this may be the way to go.  I'll give it a try.

Offline mocore

  • Hero Member
  • *****
  • Posts: 508
  • ~.~
Re: TCL V10 Boot Problem
« Reply #3 on: February 14, 2019, 11:02:52 AM »
ftr using something like

Code: [Select]
# eg create new/blank disk or partition , with the label NCORE

mkdir test ;
cd test ;

echo "http://tinycorelinux.net/9.x/x86_64/release/distribution_files/vmlinuz64



" | while read line ; do
    [ -z "$line" ] || wget -nc -nH -x "$line" ;

# create link to make  tce= boot option use linked tcz dir
ln ./9.x/x86_64/tcz ./9.x/x86_64/optional

the above to store different tc versions, tcz ect

it is possible to have a local directory structure like tinycorelinux.net
and isolate different tc versions+tcz on the same folder/disk/partition  !
by setting the appropriate paths in boot loader config file !!

++grub2 eg menu
Code: [Select]
menuentry "tc-test " {
 search --no-floppy --fs-uuid --set=root  --label NCORE

         linux  /test/9.x/x86_64/release/distribution_files/vmlinuz64 norestore base tce=LABEL=NCORE/test/9.x/x86_64/
         initrd /test/9.x/x86_64/release/distribution_files/corepure64.gz

« Last Edit: February 14, 2019, 11:07:09 AM by mocore »