WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Can't get GUI to install on Microcore 9.x  (Read 493 times)

Offline asilentmurmur

  • WikiUser
  • *
  • Posts: 4
Can't get GUI to install on Microcore 9.x
« on: September 16, 2018, 09:43:44 AM »
Hello all

I am new to this forum ( I think or I havent posted in ages). I recently installed TinyCore Microcore 64 bit using the TinyCorePure64-current.iso.  The installation was pretty straightforward and I got a new CLI installation.  Now I want to install the GUI on it so I can use it as a full fledged desktop OS. I searched online and in the forums for any suggestions on how to do it, and all I found was outdated information such as installing TC.tcz  which did not work because TC.tcz could not be found in the repo.  Any ideas on how to install the GUI on Microcore?  Also a few observations:

1 - Why is there a CorePlus ISO but not a 64 bit CorePlus ISO?  That doesnt make any sense
2 - The wiki needs a section dedicated to installing a GUI in a straightforward manner

All help is GREATLY appreciated!

Thank you

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1701
Re: Can't get GUI to install on Microcore 9.x
« Reply #1 on: September 16, 2018, 11:01:44 AM »
You probably want something like this:
Code: [Select]
tce-load -wi Xvesa.tcz Xlibs.tcz Xprogs.tcz aterm.tcz flwm_topside.tcz wbar.tcz


TC.tcz is for piCore (Raspberry Pi) only.
Download a copy and keep it handy: Core book ;)

Offline asilentmurmur

  • WikiUser
  • *
  • Posts: 4
Re: Can't get GUI to install on Microcore 9.x
« Reply #2 on: September 16, 2018, 12:17:08 PM »
You probably want something like this:
Code: newbielink:javascript:void(0); [nonactive]
tce-load -wi Xvesa.tcz Xlibs.tcz Xprogs.tcz aterm.tcz flwm_topside.tcz wbar.tcz


TC.tcz is for piCore (Raspberry Pi) only.

Thank you for your response.  Xvesa.tcz was not able to be found in the repository

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10163
Re: Can't get GUI to install on Microcore 9.x
« Reply #3 on: September 16, 2018, 01:03:09 PM »
Xvesa does not work on 64-bit, you need to use Xfbdev or Xorg-7.7

Offline asilentmurmur

  • WikiUser
  • *
  • Posts: 4
Re: Can't get GUI to install on Microcore 9.x
« Reply #4 on: September 16, 2018, 01:26:07 PM »
Xvesa does not work on 64-bit, you need to use Xfbdev or Xorg-7.7

Thank you for your reply. is Xfbdev or Xorg as minimal as Xvesa is when it comes to resource consumption?

Offline asilentmurmur

  • WikiUser
  • *
  • Posts: 4
Re: Can't get GUI to install on Microcore 9.x
« Reply #5 on: September 16, 2018, 03:09:05 PM »
Xvesa does not work on 64-bit, you need to use Xfbdev or Xorg-7.7

After I installed Xfbdev, I tried to run startx from the command line and I got an error that said Failed in waitforX.. I have no idea how to proceed with that

Offline polikuo

  • Sr. Member
  • ****
  • Posts: 352
Re: Can't get GUI to install on Microcore 9.x
« Reply #6 on: September 16, 2018, 08:06:42 PM »
Check out the file xbase.lst in TinyCorePure64-9.0.iso
Code: [Select]
aterm.tcz
bzip2-lib.tcz
fltk-1.3.tcz
flwm.tcz
freetype.tcz
glib2.tcz
graphite.tcz
harfbuzz.tcz
imlib2-bin.tcz
imlib2.tcz
libffi.tcz
libfontenc.tcz
libICE.tcz
libjpeg-turbo.tcz
libpng.tcz
libSM.tcz
libX11.tcz
libXau.tcz
libxcb.tcz
libXdmcp.tcz
libXext.tcz
libXfont.tcz
libXi.tcz
libXmu.tcz
libXpm.tcz
libXrandr.tcz
libXrender.tcz
libXt.tcz
pcre.tcz
wbar.tcz
Xfbdev.tcz
Xlibs.tcz
Xorg-fonts.tcz
Xprogs.tcz

Or try this for short
Code: [Select]
Xfbdev.tcz
Xorg-fonts.tcz
aterm.tcz
flwm.tcz
libXi.tcz
libXpm.tcz
libXrandr.tcz
wbar.tcz

Save the shortened list as "/etc/sysconfig/tcedir/onboot.lst"
Code: [Select]
tce-load -w `cat /etc/sysconfig/tcedir/onboot.lst`
sudo reboot

If Xfbdev doesn't work on your machine, go for Xorg-7.7
It's much more stable
« Last Edit: September 16, 2018, 08:14:52 PM by polikuo »