WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Poor 3D performance in glxgears on RPi0 2 W  (Read 965 times)

Offline trithilon

  • Newbie
  • *
  • Posts: 11
Poor 3D performance in glxgears on RPi0 2 W
« on: August 12, 2022, 08:01:30 AM »
The only extensions I load are TC and glxinfo.
I seem to be getting 24 FPS in the default window size.
My HDMI resolution doesn't seem to matter nor does enabling/disabling KMS drivers from config.txt

glxgears on Raspian (Buster) gives me 200 FPS on Legacy drivers.
And upto 700 FPS on Full KMS drivers.

Is there a way to achieve the same performance on TCL?

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14620
Re: Poor 3D performance in glxgears on RPi0 2 W
« Reply #1 on: August 12, 2022, 08:11:31 AM »
You need the Xorg-3d extension and:

dtoverlay=vc4-kms-v3d
gpu_mem=128
sudo rm /usr/local/share/X11/xorg.conf.d/fbturbo.conf


Offline trithilon

  • Newbie
  • *
  • Posts: 11
Re: Poor 3D performance in glxgears on RPi0 2 W
« Reply #2 on: August 13, 2022, 08:32:12 PM »
It worked. Thanks! Getting 800+ FPS :)
For anyone else reading make sure you delete fbturbo.conf BEFORE your run startx. Else it won't work.

Could you tell me what is the purpose of deleting the fbturbo.conf for my learning?
« Last Edit: August 13, 2022, 08:46:16 PM by trithilon »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14620
Re: Poor 3D performance in glxgears on RPi0 2 W
« Reply #3 on: August 14, 2022, 12:38:46 AM »
Could you tell me what is the purpose of deleting the fbturbo.conf for my learning?

The fbturbo driver prevents 3d from working.