WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: grub settings  (Read 371 times)

Offline punkgeek

  • WikiUser
  • *
  • Posts: 5
grub settings
« on: July 13, 2017, 02:07:28 PM »
Hello,
I've try to load x86 extensions from x86_64 and after searching, I got should to do this:
vmlinuz64 + rootfs.gz + modules64.gz

but I cant understand how should I do that in menu.lst from grub:

kernel /boot/vmlinuz64 quite
initrd /boot/rootfs.gz, /boot/modules64.gz

it dose not worked for me.

I need to install chntpw from tinycore64 and it is not exist from x86_64 repo, is there anything to do that without load rootfs.gz? like convert x86 package to x86_64?

Thank you

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2453
Re: grub settings
« Reply #1 on: July 13, 2017, 04:45:07 PM »
Hello,
I've try to load x86 extensions from x86_64 and after searching, I got should to do this:
vmlinuz64 + rootfs.gz + modules64.gz

but I cant understand how should I do that in menu.lst from grub:

I need to install chntpw from tinycore64 and it is not exist from x86_64 repo, is there anything to do that without load rootfs.gz? like convert x86 package to x86_64?

Thank you

Hi
I think you mean to load chntpw.tcz from the TC8 x86 repo

If you need tinycore64 to run 32bit chntpw with 64bit kernel, then

for Grub2 use
Code: [Select]
linux /boot/vmlinuz64 loglevel=3
initrd /boot/rootfs.gz /boot/modules64.gz

I'm not sure about use with grub4dos however..

Good luck
« Last Edit: July 13, 2017, 04:49:39 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2453
Re: grub settings
« Reply #2 on: July 13, 2017, 07:03:04 PM »
I did some digging..

It appears that grub4dos and grub2 share some features for compatibility so looks like the grub2 menu format will work for grub4dos also.
Therefore try this
Code: [Select]
linux /boot/vmlinuz64 loglevel=3
initrd /boot/rootfs.gz /boot/modules64.gz

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1528
Re: grub settings
« Reply #3 on: July 13, 2017, 10:34:43 PM »
Note that with
vmlinuz64 + rootfs.gz + modules64.gz
you have 64-bit kernel and 32-bit user-space.
i.e. "Core 64"

Meaning the kernel operates at 64-bit and can access more than 4GB RAM
but your apps are 32-bit.

So the  x86_64  repo doesn't apply to you in this situation.

If you want  "Core Pure 64" (64-bit apps), load  rootfs64.gz  instead of  rootfs.gz .
Download a copy and keep it handy: Core book ;)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9472
Re: grub settings
« Reply #4 on: July 13, 2017, 10:39:20 PM »
You should be able to compile chntpw for 64-bit just fine.
The only barriers that can stop you are the ones you create yourself.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9282
Re: grub settings
« Reply #5 on: July 13, 2017, 11:58:12 PM »
chntpw posted to corepure64 repo

*** not tested ***

Offline punkgeek

  • WikiUser
  • *
  • Posts: 5
Re: grub settings
« Reply #6 on: July 15, 2017, 10:36:15 AM »
Thank you
It's done

But how can I install grub on tinycore x86_64 ?
I could not found it from repo
And how can I compile 32 bit extensions for 64 bit systems?

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2453
Re: grub settings
« Reply #7 on: July 15, 2017, 10:44:04 AM »
But how can I install grub on tinycore x86_64 ?
I could not found it from repo
You should find " grub2-multi.tcz " in the TC-8 x86_64 repo

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9282
Re: grub settings
« Reply #8 on: July 15, 2017, 10:46:21 AM »
..and 32-bit extensions will not work on corepure64

Offline punkgeek

  • WikiUser
  • *
  • Posts: 5
Re: grub settings
« Reply #9 on: July 15, 2017, 11:10:59 AM »
I've tried to install but I got this error from grub2_multi.tcz extension:

Code: [Select]
$ sudo grub-install --root-directory=/mnt/sda1 /dev/sda1
installing for i386-pc platform.
grub-install: warning: cannot open directory '/usr/local/share/locale': no such file or directory.
grub-install: warning: file system 'ex2' doesn't support embedding.
grub-install: warning: embedding is not possible. grub can only be installed in this setup using blocklists. however, blocklists are UNRELIABLe and their ise is discouraged..
grub-install: error: will not proceed with blocklists.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9282
Re: grub settings
« Reply #10 on: July 15, 2017, 11:43:00 AM »
Does this work:
Code: [Select]
$ sudo grub-install --target=i386-pc --boot-directory=/mnt/sda1/boot /dev/sda

Offline punkgeek

  • WikiUser
  • *
  • Posts: 5
Re: grub settings
« Reply #11 on: July 16, 2017, 02:28:48 AM »
Thank you but i got this error:

Code: [Select]
installing for i386-pc platform.
grub-install: warning: cannot open directory '/usr/local/share/locale': no such file or directory.
installation finished. no error reported

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5313
Re: grub settings
« Reply #12 on: July 16, 2017, 03:54:25 AM »
Hi punkgeek
That's not an error, that's a warning. That last line is telling you that the installation completed. The warning is due to the various
language files for messages not being found.

Offline punkgeek

  • WikiUser
  • *
  • Posts: 5
Re: grub settings
« Reply #13 on: July 16, 2017, 04:14:12 AM »
Thank you, It's worked :x

But, how can I config the grub2? becuase I cant find grub.cfg file from /mnt/sda1/boot/grub
I made a grub.cfg from this directory, but It does'nt work:
Code: [Select]
menuentry "tinycore63" {
linux /boot/vmlinuz quiet
initrd /boot/corepure64.gz
}

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9282
Re: grub settings
« Reply #14 on: July 17, 2017, 08:11:58 AM »
grub.cfg is not installed - you need to create you own.

You probably need to tell grub where to look for vmlinuz/corepure64.gz - see:

http://forum.tinycorelinux.net/index.php/topic,19364.msg119228.html#msg119228