Tiny Core Extensions > TCE 2.x

ndiswrapper

(1/2) > >>

Juanito:
ndiswrapper tcem/tczm extensions re-compiled for tc_2.x and posted:
--- Code: ---Title:          ndiswrapper.tcem
Description:    ndiswrapper
Version:        1.54
Author:         see list of sites below
Original-site:  see list of sites below
Copying-policy: see list of sites below
Size: 94KB
Extension_by:   juanito
Comments:       ndiswrapper for tc_2.x
                ----------
                Requires the perl5 and wireless_tools extensions
                ----------
                example howto:
                $ sudo ndiswrapper -i /mnt/sda1/drivers/ndiswrapper/bcmwl5.inf
                $ sudo ndiswrapper -l
                $ sudo ndiswrapper -m
                $ sudo modprobe ndiswrapper
                ----------
                Note: you can now make an extension out of everything in
                .. /etc/ndiswrapper and use it with the ndiswrapper extension
                ..to avoid having to use the perl5 extension
                ----------
                This extension contains:
                ndiswrapper-1.54 - GPL - http://freefr.dl.sourceforge.net/sourceforge/ndiswrapper/ndiswrapper-1.54.tar.gz
Change-log:     2009/03/13
                Re-compiled for tc_2.x
Current:        2009/06/19
--- End code ---

coreplayer:
This saved me from insanity thanks :)

only issue for me is each time I run "sudo ndiswrapper -m"  there is an error "modeprobe: invalid option -- "c"
otherwise seems to produce the desired results thanks.

maro:

--- Quote from: coreplayer on June 07, 2011, 06:52:52 AM ---only issue for me is each time I run "sudo ndiswrapper -m"  there is an error "modeprobe: invalid option -- "c"

--- End quote ---

That is easily explained: Until TC 2.6 the Core contained the GNU version of 'modprobe', and with TC 2.6 this changed to the BusyBox version that does not support the '-c' option.

I could be wrong, but the two occasions where 'modprobe -c' is used in '/usr/local/sbin/ndiswrapper' don't seem to be critical to the use of 'ndiswrapper'. OTOH one could always install the 'module-init-tools.tcz' extension (that contains the GNU version of 'modprobe') if one has concerns about this warning message.

But based on the fact that things seemed to work without it, I like to suggest to NOT add it to 'ndiswrapper.tcz.dep'.

coreplayer2:
The important thing is the wrapper really did work for me, and was extremely easy to use.
thank again. 
:)

roberts:
It is quite easy to use. I have never used the ndiswrapper -m
Starting with 3.7 it is even easier to use, as you can directly read the Windows driver.
See post: http://forum.tinycorelinux.net/index.php?topic=9873.msg53985#msg53985

Navigation

[0] Message Index

[#] Next page

Go to full version