WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Failed to open the TCP port number in the license.  (Read 9278 times)

Offline 52free

  • Newbie
  • *
  • Posts: 3
Failed to open the TCP port number in the license.
« on: June 18, 2009, 12:29:06 AM »
when I start lmgrd,
I get this error.

tc@box:~$ lmgrd -c license.dat
16:25:56 (lmgrd) -----------------------------------------------
16:25:56 (lmgrd)   Please Note:
16:25:56 (lmgrd)
16:25:56 (lmgrd)   This log is intended for debug purposes only.
16:25:56 (lmgrd)   In order to capture accurate license
16:25:56 (lmgrd)   usage data into an organized repository,
16:25:56 (lmgrd)   please enable report logging. Use Macrovision's
16:25:56 (lmgrd)   software license administration  solution,
16:25:56 (lmgrd)   FLEXnet Manager, to  readily gain visibility
16:25:56 (lmgrd)   into license usage data and to create
16:25:56 (lmgrd)   insightful reports on critical information like
16:25:56 (lmgrd)   license availability and usage. FLEXnet Manager
16:25:56 (lmgrd)   can be fully automated to run these reports on
16:25:56 (lmgrd)   schedule and can be used to track license
16:25:56 (lmgrd)   servers and usage across a heterogeneous
16:25:56 (lmgrd)   network of servers including Windows NT, Linux
16:25:56 (lmgrd)   and UNIX. Contact Macrovision at
16:25:56 (lmgrd)    newbielink:http://www.macrovision.com [nonactive] for more details on how to
16:25:56 (lmgrd)   obtain an evaluation copy of FLEXnet Manager
16:25:56 (lmgrd)   for your enterprise.
16:25:56 (lmgrd)
16:25:56 (lmgrd) -----------------------------------------------
16:25:56 (lmgrd)
16:25:56 (lmgrd)
16:25:56 (lmgrd) Can't make directory /usr/tmp/.flexlm, errno: 2(No such file or directory)
16:25:56 (lmgrd) Can't make directory /usr/tmp/.flexlm, errno: 2(No such file or directory)
16:25:56 (lmgrd) Can't open /usr/tmp/.flexlm/lmgrdl.5689, errno: 2
16:25:56 (lmgrd) Failed to open the TCP port number in the license.
16:25:56 (lmgrd) Can't remove statfile /usr/tmp/.flexlm/lmgrdl.5689: errno No such file or directory

tc@box:~$cat license.dat     
SERVER box any 27000
DAEMON avantd /mnt/sda2/software/Cosmos/CosmosScope/bin/snpslmd
......
« Last Edit: June 18, 2009, 12:43:47 AM by 52free »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7818
Re: Failed to open the TCP port number in the license.
« Reply #1 on: June 18, 2009, 02:11:58 AM »
It seems to fret because there is no directory /usr/tmp. Bad practise not to check for parent directory's existence. Try creating the directory before running the script:
Quote
sudo mkdir /usr/tmp
sudo chmod 1777 /usr/tmp
The only barriers that can stop you are the ones you create yourself.

Offline 52free

  • Newbie
  • *
  • Posts: 3
Re: Failed to open the TCP port number in the license.
« Reply #2 on: June 18, 2009, 04:00:23 AM »
It seems to fret because there is no directory /usr/tmp. Bad practise not to check for parent directory's existence. Try creating the directory before running the script:
Quote
sudo mkdir /usr/tmp
sudo chmod 1777 /usr/tmp


tc@box:~$ lmgrd -c license.dat
19:55:07 (lmgrd) -----------------------------------------------
19:55:07 (lmgrd)   Please Note:
19:55:07 (lmgrd)
19:55:07 (lmgrd)   This log is intended for debug purposes only.
19:55:07 (lmgrd)   In order to capture accurate license
19:55:07 (lmgrd)   usage data into an organized repository,
19:55:07 (lmgrd)   please enable report logging. Use Macrovision's
19:55:07 (lmgrd)   software license administration  solution,
19:55:07 (lmgrd)   FLEXnet Manager, to  readily gain visibility
19:55:07 (lmgrd)   into license usage data and to create
19:55:07 (lmgrd)   insightful reports on critical information like
19:55:07 (lmgrd)   license availability and usage. FLEXnet Manager
19:55:07 (lmgrd)   can be fully automated to run these reports on
19:55:07 (lmgrd)   schedule and can be used to track license
19:55:07 (lmgrd)   servers and usage across a heterogeneous
19:55:07 (lmgrd)   network of servers including Windows NT, Linux
19:55:07 (lmgrd)   and UNIX. Contact Macrovision at
19:55:07 (lmgrd)    newbielink:http://www.macrovision.com [nonactive] for more details on how to
19:55:07 (lmgrd)   obtain an evaluation copy of FLEXnet Manager
19:55:07 (lmgrd)   for your enterprise.
19:55:07 (lmgrd)
19:55:07 (lmgrd) -----------------------------------------------
19:55:07 (lmgrd)
19:55:07 (lmgrd)
19:55:07 (lmgrd) Failed to open the TCP port number in the license.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^this error !!!

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7818
Re: Failed to open the TCP port number in the license.
« Reply #3 on: June 18, 2009, 05:28:26 AM »
Okay, the error wasn't related to the directory errors. Seems to be a bug in the software, why not contact Macrovision?
The only barriers that can stop you are the ones you create yourself.

Offline 52free

  • Newbie
  • *
  • Posts: 3
Re: Failed to open the TCP port number in the license.
« Reply #4 on: June 18, 2009, 05:52:24 AM »
Okay, the error wasn't related to the directory errors. Seems to be a bug in the software, why not contact Macrovision?

It can work in other OS. For example ubuntu,debian etc.
I guess the reason is the tcp port 27000 is closed.
how can I open it?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7818
Re: Failed to open the TCP port number in the license.
« Reply #5 on: June 18, 2009, 09:11:46 AM »
There is no firewall in the base, and we have several servers running at various ports, apache, vsftpd, tftpd, sshd to name a few, and none of them complain. This is the first time I've seen an error like this in TC, which leads me to think it would be in this script/app.
The only barriers that can stop you are the ones you create yourself.

Offline micharath

  • Newbie
  • *
  • Posts: 1
Re: Failed to open the TCP port number in the license.
« Reply #6 on: May 04, 2010, 02:10:58 AM »
Though this thread is a bit old, I have to tell you that I found the solution after a bit of "strace"ing:

It's simply the missing file /etc/protocols and there just the line

tcp     6 TCP

is enough to make it work. Oh my - two days of work and such a simple solution!

I don't know which kernel/library functions use this file but perhaps it would be a good idea to include it (without all the comments ::) ) into the core system...

Regards

Michael

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7818
Re: Failed to open the TCP port number in the license.
« Reply #7 on: May 04, 2010, 03:34:02 AM »
See iana-etc.tcz.
The only barriers that can stop you are the ones you create yourself.

Offline dddtc2005

  • Newbie
  • *
  • Posts: 1
Re: Failed to open the TCP port number in the license.
« Reply #8 on: March 18, 2012, 04:38:33 AM »
Hi Michael,

Thanks  a lot , actually I have the same problem. A friend's PC wanted to use some engineering app ( Hspice ), but the licensing manager ( FELXnet )  keep reporting error, it says that "Failed to open the TCP port number in the license file. ".
Finally, I found your post, and it reminded me of checking the C:\windows\system32\drivers\etc\ 
and I found the "protocol" file has been missing.  So I copy a correct one from other system. Then it all works well.

Regards,
TF

Though this thread is a bit old, I have to tell you that I found the solution after a bit of "strace"ing:

It's simply the missing file /etc/protocols and there just the line

tcp     6 TCP

is enough to make it work. Oh my - two days of work and such a simple solution!

I don't know which kernel/library functions use this file but perhaps it would be a good idea to include it (without all the comments ::) ) into the core system...

Regards

Michael

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3354
Re: Failed to open the TCP port number in the license.
« Reply #9 on: March 18, 2012, 07:39:05 AM »
Please do not hijack 2 year old threads to post off topic content.