WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: MCP2515 CAN interface  (Read 10457 times)

Offline johand

  • WikiUser
  • *
  • Posts: 19
Re: MCP2515 CAN interface
« Reply #15 on: September 18, 2015, 08:49:35 AM »
I can see that you added iproute2 to armv6 as well, but that extension have a broken dependency. It depends on the not existing extension netfilter-4.1.6-piCore+.

Johan

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: MCP2515 CAN interface
« Reply #16 on: September 18, 2015, 09:44:33 AM »
Seems to be working perfect now! Thanks for your support!

I it possible to add these extensions to armv6 as well? I have a plan using MCP2515 with the Raspberry Pi Compute Module in near future.

Johan

piCore 7.0alpha for 4.1.7 kernel is a work in progress. There are some issues but will be available soon. There are no intention to release new kernel modules for 7.0alpha with 4.1.6 or older kernel thought.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline mb300sd

  • WikiUser
  • *
  • Posts: 5
Re: MCP2515 CAN interface
« Reply #17 on: January 22, 2017, 01:38:04 PM »
Can these modules be added to 8.x as well? I'm trying to use the same chip. Thanks.

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: MCP2515 CAN interface
« Reply #18 on: January 22, 2017, 02:33:22 PM »
Why not make your own extension with it...like this..
Just when the tce-load command remove the w if you get this error message.
tce-load -wil squashfs-tools.tcz
squashfs-tools is already downloaded.


Code: (bash) [Select]
cd
wget http://tinycorelinux.net/8.x/armv6/releases/RPi/src/kernel/4.4.39-piCore%2B_modules.tar.xz -O - | tar -xvJf -
mkdir /tmp/package/usr/local/lib/modules/4.4.39-piCore\+/kernel/drivers/net/can/
cp /home/tc/modules/4.4.39-piCore\+/kernel/drivers/net/can/can-dev.ko $_
mkdir /tmp/package/usr/local/lib/modules/4.4.39-piCore\+/kernel/drivers/net/can/spi/
cp /home/tc/modules/4.4.39-piCore\+/kernel/drivers/net/can/spi/mcp251x.ko $_
tce-load -wil squashfs-tools.tcz
mksquashfs package /etc/sysconfig/tcedir/optional/mcp251x.tcz
echo mcp251x.tcz >> /etc/sysconfig/tcedir/onboot.lst
sync
sudo reboot

« Last Edit: January 22, 2017, 02:36:01 PM by patrikg »

Offline mb300sd

  • WikiUser
  • *
  • Posts: 5
Re: MCP2515 CAN interface
« Reply #19 on: January 22, 2017, 03:39:04 PM »
Thanks :) I'm pretty new to tinycore, that was easy enough.