WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TimeZone(another) - won't set up time.  (Read 1580 times)

Offline vinikon

  • Newbie
  • *
  • Posts: 43
TimeZone(another) - won't set up time.
« on: February 21, 2018, 04:20:54 PM »
Hello people,

I'm trying to make my Raspi ver.1 to show the right time.

  • Tried to add bootcode "tz=EST"; after reboot shows five hours more than EST.
  • changed server in /etc/sysconfig/ntpserver to 1.ca.pool.ntp.org - nothing new
  • tried another bootcode: tz=EST-1EDT,M3......'and so on'; nothing. The system show time in GMT
  • changed system time by using date -s command. It changes but after reboot it is back;

What I did wrong?
An inspired user of TinyCore...

Offline Greg Erskine

  • Sr. Member
  • ****
  • Posts: 404
Re: TimeZone(another) - won't set up time.
« Reply #1 on: February 21, 2018, 08:49:46 PM »
hi vinikon,

I can assure you it works. Here's my boot file for example.

Code: [Select]
host=piCorePlayerSCREEN3 dwc_otg.fiq_enable=0 dwc_otg.fiq_fsm_enable=0 tz=EST-10EST,M10.1.0,M4.1.0/3 waitusb=2 dwc_otg.lpm_enable=0 console=tty1 root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed smsc95xx.turbo_mode=N noswap cron consoleblank=0
One thing though, the ntp script waits for the network to be up, so it may take a little while for the time to be set after booting.

I recently had to test a RPi rebooting and had to put a 10 second delay to catch the corrected time in the log file. On the odd occassion, this was still not long enough. I was using a RPi2B for this test, so a RPi1B may require longer.